Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Allowed memory size of 33554432 bytes exhausted
 
StainesUK
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2007-10-26
Surrey
 

Hi,

I’m having problems installing V7.14800, I have had previous versions of magento working on the system fine but I’m can’t seem to get the new V installed.

What it’s going on:
Vista
XAMPP V2.5

I have removed old version and started from scratch, when I get to the download update page things start to go wrong, it looks like its updated with lots of Install ok: messages but at the end I get an error message.

Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 134 bytes) in C:\xampp\htdocs\magento\lib\pear\php\PEAR\Registry.php on line 1053

all the buttons are then greyed out all I can do is close the ie window. If I then start the install again and all goes well I get a pop up “All packages were installed successfully, click ok to continue with the installation” The config page is ok but on the next page it errors out with a load of code
the bit that looks like it might be helpful to you is:

Please contact developers with following information:
exception ‘Zend_Controller_Response_Exception’ with message ‘Cannot send headers; headers already sent in C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php, line 253’ in C:\xampp\htdocs\magento\lib\Zend\Controller\Response\Abstract.php:265
Stack trace:
#0 C:\xampp\htdocs\magento\lib\Zend\Controller\Response\Abstract.php(131): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 C:\xampp\htdocs\magento\app\code\core\Mage\Install\controllers\WizardController.php(305): Zend_Controller_Response_Abstract->setRedirect(’http://localhos...’)
#2 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Controller\Varien\Action.php(332): Mage_Install_WizardController->configPostAction()
#3 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(149): Mage_Core_Controller_Varien_Action->dispatch(’configPost’)
#4 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Controller\Varien\Front.php(166): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 C:\xampp\htdocs\magento\app\Mage.php(411): Mage_Core_Controller_Varien_Front->dispatch()
#6 C:\xampp\htdocs\magento\index.php(29): Mage::run(’base’)
#7 {main}

Thanks in advance for your help
Regards

P.S
I have tried both the ALFHA and BETA

 
Magento Community Magento Community
Magento Community
Magento Community
 
stevewar
Jr. Member
 
Total Posts:  20
Joined:  2008-05-24
 

FYI I had the same problem using Firefox (over and over for at least 12 hours), and for some reason switching to IE (I know php is server side, I don’t get it either) fixed ths problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
mikewhitby
Member
 
Total Posts:  38
Joined:  2008-09-08
 

I had this issue, and I knew my memory_limit was 64m in php.ini, but then it struck me, I was Ubuntu and the php.ini I edited was in /etc/php5/apache2/php.ini - so this was only editing the php configuration for php via apache, I had to edit the php.ini in /etc/php5/cli for the changes to work via SSH

Hope this helps someone

 
Magento Community Magento Community
Magento Community
Magento Community
 
breastfed
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-09-24
Münster - Germany
 

I had the same Issue - i changed the memory_limit to 50M

Works now with 1.17 -> 1.1.8

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roly
Sr. Member
 
Total Posts:  276
Joined:  2008-04-30
 

Fatal error:  Allowed memory size of 33554432 bytes exhausted

Your memory limit set for your PHP is too low.

As what breastfed suggest, increase your memory_limit. An ideal value is 50M .

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lesiu
Member
 
Total Posts:  51
Joined:  2008-10-31
Poland
 
meph137 - 24 November 2008 05:21 AM

I had this issue, and I knew my memory_limit was 64m in php.ini, but then it struck me, I was Ubuntu and the php.ini I edited was in /etc/php5/apache2/php.ini - so this was only editing the php configuration for php via apache, I had to edit the php.ini in /etc/php5/cli for the changes to work via SSH

Hope this helps someone

Thank you so much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Paul Williams
Jr. Member
 
Total Posts:  6
Joined:  2009-07-15
 
Mike Whitby - 24 November 2008 05:21 AM

I had this issue, and I knew my memory_limit was 64m in php.ini, but then it struck me, I was Ubuntu and the php.ini I edited was in /etc/php5/apache2/php.ini - so this was only editing the php configuration for php via apache, I had to edit the php.ini in /etc/php5/cli for the changes to work via SSH

Hope this helps someone

Thanks so much for this, worked straight away. Why php and apache have multiple locations for the same setting I’ll never understand. But anyway, a new thing learned today :)

 
Magento Community Magento Community
Magento Community
Magento Community
 
digitiser
Jr. Member
 
Total Posts:  29
Joined:  2009-03-02
 

Yep, changing the PHP memory_limit worked for me too.

In my case, this particular install was in a cpanel / WHM account.  The cpanel .htaccess memory_limit was set to 128m but WHM was set to 32mb which overrode the account setting.  Changing the PHP memory limit in WHM fixed the problem for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Elitek
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2010-06-12
 

Hello,

I am having the same problem, I get the following error, but in the php.ini I incrase memory_limit.

these is copied from phpinfo()

max_execution_time 18000 1800
memory_limit 128M 1428M

cp:/var/www/vhosts/makspro.si/httpdocs# php importStock.php

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /var/www/vhosts/makspro.si/httpdocs/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Indexer/Price/Default.php on line 269

Any sugestion?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Elitek
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2010-06-12
 

Hello,

I am having the same problem, I get the following error, but in the php.ini I incrase memory_limit.

these is copied from phpinfo()

max_execution_time 18000 1800
memory_limit 128M 1428M

cp:/var/www/vhosts/makspro.si/httpdocs# php importStock.php

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /var/www/vhosts/makspro.si/httpdocs/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Indexer/Price/Default.php on line 269

Any sugestion? s

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top