Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento 1.7 Probleme Import Exportmodul
 
Markwordt
Jr. Member
 
Total Posts:  30
Joined:  2010-03-03
 

Hallo,

Ich habe folgende Probleme.

1. Ich will über Import Artikel importieren, wenn aber ein neuer Artikel enthalten ist. Bricht er mit Fehler ab.
Ich habe als Basis des Artikels von Vinai Kopp Schnell importieren eine Importroutine geschrieben, die Daten werden aus der Erp exportiert und per FTP hochgeladen und dann wird das Script gestartet. Wenn aber ein neuer Artikel enthalten ist kommt der Fehler
Invalid value for Attribute Set column (set does not exists?) :::: In Line(s) 147.
Irgendwie werden keine neuen Artikel importiert.

2. Problem nach dem Import werden alle Lagerbestände auf die gleiche Anzahl gesetzt. Ich habe aber keine Spalten für die Lagerverwaltung in der CSV

Hat jemand dafür eine Lösung.  Ich verzweifle langsam.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Markwordt
Jr. Member
 
Total Posts:  30
Joined:  2010-03-03
 

Hallo nochmal
manchmal hat man Freitags doch noch eine gute Idee.
Also das erste Problem habe ich gefunden
es lag an _attribute_set, ich hatte es ohne _ jetzt klappt es

app/code/core/Mage/ImportExport/Model/Import/Entity/Product.php
const COL_ATTR_SET = ‘_attribute_set’;
Ich weiß jetzt nicht ob es neu in 1.7 ist.

Nun hoffe ich finde noch das zweite Problem.
Beim Import nimmt er immer qty vom ersten Artikel

Hat vielleicht jemand eine Idee?

Danke und schönes Wochenende

 
Magento Community Magento Community
Magento Community
Magento Community
 
pgunn
Jr. Member
 
Total Posts:  11
Joined:  2011-10-27
 

Hallo,

hatte das gleiche Problem: beim import wurde für alle Produkte die qty vom ersten Artikel gesetzt.
Es gibt hier eine einfache Lösung dafür, scheint ein Magento-Bug zu sein.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top