Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem when upgrading to 1.7 - site down
 
fuze
Jr. Member
 
Total Posts:  3
Joined:  2009-02-10
 

Hi,

Hope you can help.

My website went down and started showing the following error:

PHP Fatal error: Method Varien_Object::__tostring() cannot take arguments in /var/www/vhosts/crystalswork.com/httpdocs/lib/Varien/Object.php on line 488

My host recommended I upgrade to the latest version latest version to support PHP 5.3.

I therefore upgraded to 1.7.

Upon upgrade I got the following error

....................................................

There has been an error processing your request
Error in file: \"/var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Customer/sql/customer_setup/upgrade-1.6.1.0-1.6.2.0.php\" - Invalid mode for clean() method

Trace:
#0 /var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(\’Mage_Core\’, \’Error in file: ...\’)
#1 /var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(\’upgrade\’, \’1.6.1.0\’, \’1.6.2.0.1\’)
#2 /var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(\’1.6.1.0\’, \’1.6.2.0.1\’)
#3 /var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /var/www/vhosts/crystalswork.com/httpdocs/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /var/www/vhosts/crystalswork.com/httpdocs/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#7 /var/www/vhosts/crystalswork.com/httpdocs/index.php(87): Mage::run(\’\’, \’store\’)
#8 {main}

Error log record number: 1529120943

.........................................................

I followed http://www.magentocommerce.com/boards/viewthread/227131/

Now I have the following error

...............................

Server error
The website encountered an error while retrieving http://www.crystalswork.com/. It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this web page later.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.

.......................................

What should I do?

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

please see server error log
and magento exception log

thank you

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top