Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cannot Invoice or Ship items
 
aloeroot
Jr. Member
 
Total Posts:  18
Joined:  2008-07-24
 

There’s already a thread here that deals with inability to invoice or ship items in 1.1.8 along with a problem with price rules. In that thread someone posted a fix for the price rules, but the problem with invoicing and shipping remains.

In short, I’ve got orders coming into my store but i can’t create invoices or ship orders because there’s no “submit” button on the page anymore. The only options are “back” and “reset”. Not very useful. Any ideas on how to make the functionality return? I already attempted the upgrade to 1.2.0.1 and the entire store crashed, generating 500 errors, so that’s not an option at present considering that today is the launch deadline. grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
raven
Jr. Member
 
Total Posts:  10
Joined:  2008-07-08
Philippines
 

Has anyone solved this problem?

I am also having this kind of problem. I can’t create invoices because there’s no “submit” button on the “New Invoice” page.

I noticed that this problem is only with those products that had their Product Type set to “Simple Product”. Products which are “Virtual Product” (no shipping options), don’t have this kind of problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
junger
Member
 
Avatar
Total Posts:  31
Joined:  2008-05-02
 

I can’t create invoices because there’s no “submit” button on the “New Invoice” page.

I was having the same problem here, and just solved. :D :D :D :D

In my case the error was not related to an upgrade. I was testing some payment and shipment modules, and they silently wrote things in my database.

I deleted the last rows at “core_config_data table” (I recognized my not-so-friends in these rows) and back to admin > orders, invoice funcionality was working perfectly again. Viva!

Thanks sherrie and talmor on http://www.magentocommerce.com/boards/viewthread/15299/

 
Magento Community Magento Community
Magento Community
Magento Community
 
AnneLise
Sr. Member
 
Avatar
Total Posts:  154
Joined:  2008-09-08
Bergen, Norway
 

After searching every post I could find on the forum regarding this, I found the solution.

There is something about the e-mails Magento doesn’t like.

In the app/locale/en_US/template/ folder, there is a folder called “emails”.

Find the original Magento files, and restore this folder.  Then customize your e-mails again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
modison
Jr. Member
 
Total Posts:  3
Joined:  2009-08-04
 

Even we want the solution for the same problem as Kenn mentioned. Can you please clearly explain the steps for it. Our situation is also that we had identified few items as Drop ship items and do the purchase order process. But the client wants to do the sales invoice for those drop ship items due to Business need. But for arriving at the COGS, the cost of the item should be got after posting the purchase invoice, Presently the system does not allow to transfer to invoice without posting the purchase invoice. We can remove the tag (which indicates the link between PO & SO), but we dont want to do it since the cost will not get updated automatically.
Give us a solution.

__________________________
credit rating
advance cash online

 
Magento Community Magento Community
Magento Community
Magento Community
 
jazkat
Sr. Member
 
Total Posts:  154
Joined:  2009-07-09
 

Thanks junger for pointing to this solution, deleting last record from “core_config_data table” table worked for me.

As it happens, I was trying to create some shipping custom model following one tutorial, which didn’t work (I didn’t quite figured out what went wrong), when suddenly this error happened- I couldn’t create Invoices/Shipments.

-------------------------------------------------------------------------
Magento v 1.3.2.4

 
Magento Community Magento Community
Magento Community
Magento Community
 
heronfisher
Jr. Member
 
Total Posts:  4
Joined:  2010-03-12
 

AnyOrder in its normal configuration has the following fields for the customer’s address:  Name, Address1, Address2, City, State or Province, Postal Code, Zip Extension and Country.  Most businesses will find this sufficient.  However, if you commonly work with long addresses, then you can configure the program to include an additional address field (Address3).  For more information, see User Defined Fields.

If this is a totally new customer, type in the name and billing address.  If this customer has a Customer Number then you don’t have to worry about typing in the name and address.  That’s automatically done for you when you enter the Customer Number.

If this customer doesn’t have a number but has ordered at least once from you in the past, then click on the “L” button ("L" is for “List") or double-click in the “Bill-to” blank.  This will bring up a pop-up list of all past customers.  There are several ways of ordering the list and locating customers.

 
Magento Community Magento Community
Magento Community
Magento Community
 
buitenkeuken
Jr. Member
 
Total Posts:  2
Joined:  2010-05-13
 

Thanks a lot for the solution, been searching like crazy to solve this strange issue rasberry
much appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
subsidie
Jr. Member
 
Total Posts:  6
Joined:  2010-09-30
 

This is an error from the old version right? as i now have a similar issue :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
wright83
Member
 
Total Posts:  47
Joined:  2010-01-13
 

I too how having the problem after clicking SHIP. im using 1.3.2.4

 
Magento Community Magento Community
Magento Community
Magento Community
 
sherrie
Mentor
 
Avatar
Total Posts:  1655
Joined:  2007-12-14
Waterloo, ON
 

If you guys are using custom shipping extensions it’s possible you’re running into the issue because of that - not all shipping extensions were updated or created properly for 1.1+.

 
Magento Community Magento Community
Magento Community
Magento Community
 
EricBuhlman
Jr. Member
 
Total Posts:  2
Joined:  2011-02-08
 

I am having a similar problem.  When I go to create an invoice for a new order, the bottom half of the page just ends and there is know way to finish process of creating the invoice.  I’ve attached two screen shots that show the formatting problem.  If you look at the top navigation, it is spaced very strangely compared to other pages, and there is also no Magento footer.

I’ve tried many of the solutions relating to this problem with no result.

I do have custom shipping extensions installed.  After disabling them and refreshing the cache, the problem persists.  With some amazing support from WebShoppApps (awesome shipping extensions by the way) we were able to determine with out a doubt that none of their extensions were causing the issue.  Nonetheless, their support team was kind enough to take a look and help me.  Here is where I’m at so far:
http://wiki.webshopapps.com/the-faq#TOC-Invalid-Model-For-Shipping-Method:-

This is a helpful link that can apply to cleaning up all Magento shipping extensions that you might be concerned about.

Thanks for any help or suggestions!

Magento ver. 1.4.1.1

Image Attachments
Screen shot 2011-03-08 at 1.49.17 PM.pngScreen shot 2011-01-24 at 10.57.52 AM.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
EricBuhlman
Jr. Member
 
Total Posts:  2
Joined:  2011-02-08
 

UPDATE

Thanks to WebShopApps my problem has been solved! By looking at the source code of the page in question, we found an error code.  After downloading this error in a text editor, WebShopApps helped me find that another extension that I previously removed that was causing the problem.  It was the Admin Custom Shipping Rate extension found here: http://www.magentocommerce.com/magento-connect/i960/extension/1477/admin-custom-shipping-rate.

After following the instructions below, it fixed my problem…

“To fix this you need to run some sql - see wiki below - change matrixrate with umosaco.

The problem originates because you have removed a shipping extension - it’s a magento bug where they dont ignore this scenario. There is no way in magento to uninstall an extension, so when you remove a shipping extension you must run this.”

http://wiki.webshopapps.com/the-faq#TOC-Invalid-Model-For-Shipping-Method:-

Thank you WebShopApps!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jongosi
Jr. Member
 
Total Posts:  15
Joined:  2012-11-18
 

Just encountered this same error in Magento CE 1.7.0.2! Trying to create an invoice for any order that was placed via Paypal or created manually resulted in an exception fatal error with a report entry ’Cannot get order instance‘.

We recently purchased and installed MageWorx Store & Currency Auto Switcher Magento Extension v1.1.0 and this was causing the problem. Deleting the last rows in the core_config_data table did not work.

Solution:

Log into admin area. Go to System > Configuration > (MageWorx) Customers > Customer Location and set

Enable In Order View

to No

Flush cache, problem solved smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
iita
Jr. Member
 
Total Posts:  4
Joined:  2013-03-13
 

I don\\\’t get your men what is mean of last row of core_config_data you mean which row?!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top