Magento Forum

   
Amasty Multiple Coupons issue with Magento 1.7
 
royalije
Member
 
Total Posts:  37
Joined:  2008-05-29
Spain
 

We just updated to Magento 1.7 from 1.4 and I’m getting the following error when the Amasty_coupons (Multiple coupons extension) is enabled.
I tried with a brand new installation and immediately I added the extension it broke. We’re still waiting for Amasty’s response but in the meantime wanted to check if someone else had experienced this issue. Any help is welcome.

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘website_ids’ in ‘where clause’

Trace:
#0 Y:\staging\17\lib\Varien\Db\Statement\Pdo\Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)
#1 Y:\staging\17\lib\Zend\Db\Statement.php(300): Varien_Db_Statement_Pdo_Mysql->_execute(Array)
#2 Y:\staging\17\lib\Zend\Db\Adapter\Abstract.php(479): Zend_Db_Statement->execute(Array)
#3 Y:\staging\17\lib\Zend\Db\Adapter\Pdo\Abstract.php(238): Zend_Db_Adapter_Abstract->query(’SELECT `main_ta...’, Array)
#4 Y:\staging\17\lib\Varien\Db\Adapter\Pdo\Mysql.php(419): Zend_Db_Adapter_Pdo_Abstract->query(’SELECT `main_ta...’, Array)
#5 Y:\staging\17\lib\Zend\Db\Adapter\Abstract.php(734): Varien_Db_Adapter_Pdo_Mysql->query(’SELECT `main_ta...’, Array)
#6 Y:\staging\17\lib\Varien\Data\Collection\Db.php(734): Zend_Db_Adapter_Abstract->fetchAll(’SELECT `main_ta...’, Array)
#7 Y:\staging\17\app\code\core\Mage\Core\Model\Resource\Db\Collection\Abstract.php(521): Varien_Data_Collection_Db->_fetchAll(’SELECT `main_ta...’, Array)
#8 Y:\staging\17\lib\Varien\Data\Collection\Db.php(566): Mage_Core_Model_Resource_Db_Collection_Abstract->getData()
#9 Y:\staging\17\app\code\core\Mage\SalesRule\Model\Validator.php(100): Varien_Data_Collection_Db->load()
#10 Y:\staging\17\app\code\core\Mage\SalesRule\Model\Quote\Freeshipping.php(60): Mage_SalesRule_Model_Validator->init(’1’, ‘1’, NULL)
#11 Y:\staging\17\app\code\core\Mage\Sales\Model\Quote\Address.php(957): Mage_SalesRule_Model_Quote_Freeshipping->collect(Object(Mage_Sales_Model_Quote_Address))
#12 Y:\staging\17\app\code\core\Mage\Sales\Model\Quote.php(1264): Mage_Sales_Model_Quote_Address->collectTotals()
#13 Y:\staging\17\app\code\core\Mage\Checkout\Model\Cart.php(464): Mage_Sales_Model_Quote->collectTotals()
#14 Y:\staging\17\app\code\core\Mage\Checkout\controllers\CartController.php(126): Mage_Checkout_Model_Cart->save()
#15 Y:\staging\17\app\code\core\Mage\Core\Controller\Varien\Action.php(419): Mage_Checkout_CartController->indexAction()
#16 Y:\staging\17\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch(’index’)
#17 Y:\staging\17\app\code\core\Mage\Core\Controller\Varien\Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#18 Y:\staging\17\app\code\core\Mage\Core\Model\App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#19 Y:\staging\17\app\Mage.php(683): Mage_Core_Model_App->run(Array)
#20 Y:\staging\17\index.php(87): Mage::run(’’, ‘store’)
#21 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
gorjanagriffin
Jr. Member
 
Total Posts:  1
Joined:  2011-10-03
 

have you found a fix for this?  we’re having this similar error but not using amasty.  we suspect it’s a database upgrade change error…

 
Magento Community Magento Community
Magento Community
Magento Community
 
royalije
Member
 
Total Posts:  37
Joined:  2008-05-29
Spain
 

No we haven’t. We contacted Amasty but they’ve been very irresponsible and they haven’t provided any support for this - we sent them several emails and no response from them.

I thought it was also the DB being corrupted during the upgrade but everything else works and I tried using the module in a brand new installation (clean db, etc) and immeditely I enabled it I got the same error.  So it’s definitely the extension.
(I don’t know why they claim to be compatible with Magento 1.7 if clearly it’s not).

Are you using any other third party module? Do you get the error when tryiing to add products to cart?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jorge Lima Jr
Jr. Member
 
Total Posts:  8
Joined:  2010-10-14
 

Amasty sent me the update and the problem was solved.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Amasty
Mentor
 
Avatar
Total Posts:  3749
Joined:  2009-11-10
 

Hi, just found the tread.

First of all, thank you for using our extension.

Please should you have any issues with the modules - contact us directly via support form.  You have free support included with your purchase, do not hesitate to use it.

For Magento 1.7+ please use latest module versions as the database in the 1.7 has been changed.

Best wishes,
Alex

 
Magento Community Magento Community
Magento Community
Magento Community
 
idealclic
Jr. Member
 
Total Posts:  24
Joined:  2010-10-11
 

Don’t expect any support from their team, it’s been two weeks since I have asked to make the extension I bought working and no response (3 tickets submitted, 4 emails, 1 FB mail, 1 Twit) ! I will continue to troll the web with this message until I get an answer !

 
Magento Community Magento Community
Magento Community
Magento Community
 
Peppermay
Sr. Member
 
Avatar
Total Posts:  111
Joined:  2008-10-18
Lille, France
 

So ? Have you been fulfilled ?
I meet the very same problem when upgrading from 1.4 to 1.7…

 
Magento Community Magento Community
Magento Community
Magento Community
 
elfling
Enthusiast
 
Avatar
Total Posts:  899
Joined:  2008-10-21
 

The error is in Amasty_Coupons_Model_Rewrite_Mysql4_Rule_Collection

They have added a new function called addWebsiteGroupDateFilter to deal with this error.The error is solved in their current releases.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top