Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Images not Uploading. Destination folder not writable
 
jacobs_ny
Jr. Member
 
Total Posts:  13
Joined:  2008-11-30
 

Don’t know what is going on.. I am unable to upload images for new products or existing. I am running 1.2 magento.. The permissions on the folders are fine..  Hope someone will have some insight.. I will be preparing to go back to 1.8..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kelvin Jones
Jr. Member
 
Total Posts:  6
Joined:  2009-01-08
 

I am also having this same problem, i’ve scoured the forums and tried various suggestions but to no-avail!

I have tried:
checking the permissions of all the media directories…
chown-ing the folders using Putty…
fixing Image.php to skip a file check or 2 around line 140…
even removing the .htaccess file incase its that that was stopping me applying settings.

I’m so at a loss?

Any of this sounding familiar?

My PHPINFO lists all of these and yet i’m still missing something:

./configure --prefix=/opt/php-5.2 --with-jpeg-dir=/usr --with-xpm-dir=/usr/X11R6 --with-png --with-png-dir=/usr --with-gd=shared --enable-gd-native-ttf --with-t1lib --enable-track-vars --enable-sysvsem --enable-sysvshm --with-zlib=shared --with-config-file-path=/usr/local/etc/httpd/conf --enable-memory-limit --enable-calendar --with-db3=shared --with-gdbm=shared --with-ndbm=shared --with-dbase=shared --with-xml --with-expat-dir=/usr --enable-debugger --enable-ftp=shared --enable-exif --with-ttf --enable-bcmath=shared --enable-mbstring=all --enable-soap --enable-wddx --with-openssl=shared --enable-trans-sid --with-mysql=shared,/opt/mysql-5.0 --with-mysqli=shared,/opt/mysql-5.0/bin/mysql_config --with-pdo=shared --with-pdo_mysql=shared,/opt/mysql-5.0 --with-imap=shared --with-imap-ssl --with-dom=shared --with-bz2=shared --enable-zip --with-curl=shared --with-mhash=shared --with-mcrypt=shared --with-pgsql=shared --with-ming=shared --with-gmp=shared --with-gettext=shared --with-iconv=shared --with-pspell=shared --with-kerberos --with-xmlrpc=shared --with-xsl=shared --with-unixODBC=shared,/usr --with-mssql=shared --with-tiff-dir=/usr --enable-xslt --with-xslt-sablot=shared --with-freetype-dir=/usr --with-apxs=/usr/sbin/apxs --with-pear

GD Support    enabled
GIF Read Support    enabled
GIF Create Support    enabled
JPG Support    enabled
PNG Support    enabled
WBMP Support    enabled

This is what happened:
Installed clean, Played around with settings (nothing major), uploaded an image.
After checking the live site i found that the uploaded image didn’t display… instead it was the place holder image??
I checked the file existed, check it was in the database - all fine.
Deleted the image tried to upload another one.......... nothing?

I SHOULD ADD GIF FILES WORK FINE!!!
If you try this as, well you’ll know if you have the same issue as me.

Any help would be excellent, cheers all.

K
__________________________________________________
--11/01/09 EDIT
OK, I can now add a little more info to this...

Internet explorer 7, despite being slow!, allows you to upload JPEGs so it is a browser issue! Chrome and Firefox don’t?

But the plot thickens…
IE7 reloads the page and the images seem to be gone?
See the images below: I select the file, click upload, save and continue then it show’s me the image is uploaded.... 3 seconds later the page refreshes and the images are gone???????

And the images STILL DON’T SHOW on the product pages..... what am i missing here?

K

Image Attachments
phase_1.jpgphase_2.jpgphase_3.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
bizz
Jr. Member
 
Total Posts:  25
Joined:  2008-12-03
 

I am having the same issue since upgrading to 1.2
a solution would be great as I need to get some images up asap…

any solutions out there?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bizz
Jr. Member
 
Total Posts:  25
Joined:  2008-12-03
 

okay, forget that,

i ran a 777 chmod on the entire media folder & subdirectories, and that did the trick.
thank you fliezilla rasberry

Ben

 
Magento Community Magento Community
Magento Community
Magento Community
 
abdelkarim
Jr. Member
 
Total Posts:  7
Joined:  2008-05-02
 

suhosin.session.cryptua = off

If suhosin it’s activate, don’t work also if put suhosin.session.cryptua = off

Also if php it’s on SuPHP, use of htaccess php_fags o php_values don’t work.,

Must put apropiate values onto php.ini per virtual host.

 
Magento Community Magento Community
Magento Community
Magento Community
 
TemplatesMaster
Guru
 
Avatar
Total Posts:  308
Joined:  2008-04-01
Switzerland
 

We had same bug after moving to new server with 1.2.  Setting chmod 777 to all directories in media didn’t helped us. We were able to fix this bug after deleting everything in media/tmp. We can’t explain this.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top