Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Simple Products Take 5 Minutes to Save or More (Read more…)
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

Hey folks,

I just upgraded to 1.7.0.0 and simple products that belong to 2 or more bundle products take 5 minutes or more to save. and sometimes throw the following error code:

SQLSTATE[HY000]General error1205 Lock wait timeout exceeded; try restarting transaction

It does not happen if a simple product belongs to only 1 bundle product or does not belong to any bundle products.

Please help me fix this. ohh

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

hm
have you tried to :
1- do a clean(this is very important) reboot of your DB
2- check mysql logs
3- mysql> show engine innodb status;
4- check timeouts, slowdowns and deadlocks
5- ram available and php cpu usage.

etc…

 
Magento Community Magento Community
Magento Community
Magento Community
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

Thank you. By the way, how do you do a “Clean” reboot of the database?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

Here is a more clear summary of what is happening:

Ever since I upgraded to 1.7.0.0, some products take forever (up to 5 min) to save in Magento. It only happens to simple products that belong to 2 or more bundle products. Some bundle products also do that. During the save process two things happen:

1. MySQL process takes up 100% of CPU for about 5 minutes.
2. During that time, I get multiple errors “SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded. Mostly search related.

For example, there are 2 sets of MySQL queries that run when I save a certain simple product (which I’m guessing is because this product is associated with 2 different bundle products). Each of these queries takes about 120 seconds to run (and takes up about 3 pages of normal typed document), and because I have the index management set to “Update on Save” for the Product Prices index, every time you save a product, it has to re-index the product prices for each updated bundled product.

I’ve disabled the “Update on Save” feature of the Index Management, and saving the product takes about 10 seconds now, the only downside is that I’ll have to manually refresh the Product Prices index, but updating that manually only takes about 10 seconds as well.

This is only happening in 1.7.0.0. Attached is the actual MySQL query from the example product above. As you can see, it’s very long.

Can anyone please help?

File Attachments
mysqil_query.txt  (File Size: 21KB - Downloads: 126)
 
Magento Community Magento Community
Magento Community
Magento Community
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

still having this problem. could anyone point me in the right direction?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ryan Grow
Jr. Member
 
Total Posts:  21
Joined:  2009-12-04
 

I’m not sure what version of MySQL you are running or how much ram you have, but we have a multi-site setup of magento and it was taking over 3 mins to save a product.
We where able to reduce it by switching our database server to MariaDB 5.5.
I would suggest trying to see if it resolves your save time issues as well.

As for the issue your having with the search not working and getting lock wait timeouts, unfortunately it’s a bug in the magento 1.6.2.0 and higher code.

So, there is 2 solutions for the search issue, either move your searching to Solr, or you have to modify the catalog search re-indexer and turn off update on save.

You will want to go into this file and change the reindexAll function back to the 1.6.1.0 version:
/app/code/core/Mage/CatalogSearch/Model/Indexer/Fulltext.php

public function reindexAll()
{
$this->_getIndexer()->rebuildIndex();
}

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mirasvit
Guru
 
Avatar
Total Posts:  639
Joined:  2009-08-22
 

When a laaarge number of goods or attributes need to be saved, backend works very slow, as each time you save data the system re-indexes the goods through the entire catalog.

Asynchronous Re-indexing is a solution of this problem. When a product or category is saved it is not immediately re-indexed, but put into a queue. The queue is re-indexed in the background. This greatly speeds up the backend. This mechanism is implemented by using an extension of http://mirasvit.com/magento-extensions/magento-asynchronous-reindex.html.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Hurup
Jr. Member
 
Total Posts:  1
Joined:  2013-01-17
 

Hello,

Magento has made some improvements on Magento CE 1.8 of the database connectivity :
http://www.magentocommerce.com/knowledge-base/entry/ce-18-later-release-notes#ce18-1800fixes

I would just like a fix for this issue instead of should upgrading the whole Magento.

Rasmus

 
Magento Community Magento Community
Magento Community
Magento Community
 
bijalbhavsar99
Jr. Member
 
Total Posts:  2
Joined:  2013-11-10
 

Hi all,

Anyone found the patch to resolve deadlocks issue with product save and re-indexing in magento 1.7.0.0.
It is taking too long time to save product and result into deadlock :( .

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top