Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t login to disable compiler
 
jbs325is
Jr. Member
 
Total Posts:  3
Joined:  2012-03-23
 

I made the mistake of trying to install GoogleShopping API extension while running compiler mode.  Now i can’t get into my backend at all and I’ve tried everything I know.  I hope someone can help.  Here’s the error message i get:

a:5:{i:0;s:69:"Mage registry key “_singleton/googleshopping/observer” already exists";i:1;s:1441:"#0 /home/jordanb0/public_html/app/Mage.php(192): Mage::throwException(’Mage registry k...’)
#1 /home/jordanb0/public_html/app/Mage.php(446): Mage::register(’_singleton/goog...’, false)
#2 /home/jordanb0/public_html/app/code/core/Mage/Core/Model/App.php(1283): Mage::getSingleton(’googleshopping/...’)
#3 /home/jordanb0/public_html/app/Mage.php(416): Mage_Core_Model_App->dispatchEvent(’controller_acti...’, Array)
#4 /home/jordanb0/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(509): Mage::dispatchEvent(’controller_acti...’, Array)
#5 /home/jordanb0/public_html/app/code/core/Mage/Adminhtml/Controller/Action.php(152): Mage_Core_Controller_Varien_Action->preDispatch()
#6 /home/jordanb0/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(409): Mage_Adminhtml_Controller_Action->preDispatch()
#7 /home/jordanb0/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch(’login’)
#8 /home/jordanb0/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#9 /home/jordanb0/public_html/app/code/core/Mage/Core/Model/App.php(349): Mage_Core_Controller_Varien_Front->dispatch()
#10 /home/jordanb0/public_html/app/Mage.php(640): Mage_Core_Model_App->run(Array)
#11 /home/jordanb0/public_html/index.php(80): Mage::run(’’, ‘store’)
#12 {main}”;s:3:"url”;s:6:"/admin”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:5:"admin";}

I’ve commented out compiler on the config.php but still no luck.

The frontend seems to be fine but i have no access to the backend.  Also tried reinstalling and uninstalling from /downloader.

Please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kneemahp
Sr. Member
 
Total Posts:  116
Joined:  2008-08-07
 

just go back to www.yourdomain.com/downloader and login and uninstall the extension. then go back to admin and disable compiler.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Or log in with a secure shell session (ssh) and navigate to the shell/ folder, run compiler.php with the following command

php -f compiler.php clear
This disables the compiler and empties the compiler code cache.

Then go delete all the subfolders in var/cache.

Disabling the compiler, emptying its code store and manually clearing the Magento cache should bring your system back up. Once there, check to make sure the new extension is functioning with your website for a few hours and then see if you can reenable the compiler.

When installing ANY module, check that it actually is listed as working with your Magento version before installing and then observe the following.

1) Log into the admin backend, Flush and disable the Magento Cache.
2) Disable the compiler and flush its code store.
3) Log out of admin and delete all files in var/session.
4) Install the module.
5) Log into the administrative backend and when the backend finally shows, log back out.
6) Log into the administrative backend and go check module configuration settings for your new module.
7) Once you are sure things are working, log in and reenable the Magento Cache.
8) After running the site and making sure the new module is functional and living well with your code base, try reenabling the Compiler and recompiling. Be prepared to manually disable the compiler if things go south because a module isn’t compatible with Magento’s compilation process. In shell/, manually execute php -f compiler.php clear to shut it off, then consult with the module’s creator to see if there’s an upgrade available.

Module installation and first run is an operation that must not be interrupted by cached code, sessions referencing old code.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top