Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

General advice from an experienced Magento user regarding the 1.7 upgrade
 
focallocal
Jr. Member
 
Total Posts:  16
Joined:  2012-04-18
 

Hi everyone, i’ve just started and i think i’ve picked the worst possible time.

i nearly finished building a site when i got the notification that 1.7 had been launched so i upgraded and my site died. as a new user running a small shop i want to stick to free templates for the moment but i cant find any which are 1.7 compatible - i was using magento absolute.

does anyone on here have any advice that could help? i’m not sure whether to try a fresh 1.6 install and recover what i can from the old site so i can keep working on it (i hope to publish by the weekend), or to wait for 1.7 compatible themes to be released. or if there are some already out there that i have just been unable to find.

it would be brilliant if someone with a bit more magento experience could give me an idea how they would proceed in my situation.

thanx for reading.

Andy

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dullahan
Jr. Member
 
Total Posts:  4
Joined:  2010-07-05
 

A Magento 1.6 theme should work just fine in 1.7. As long as the theme was written correctly, you should have no problems. I just upgraded from 1.6. to 1.7 with a theme I created and there was no issues. Hope that helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ladle
Sr. Member
 
Avatar
Total Posts:  173
Joined:  2009-06-11
 
focallocal - 01 May 2012 09:01 AM

Hi everyone, i’ve just started and i think i’ve picked the worst possible time.

i nearly finished building a site when i got the notification that 1.7 had been launched so i upgraded and my site died. as a new user running a small shop i want to stick to free templates for the moment but i cant find any which are 1.7 compatible - i was using magento absolute.

does anyone on here have any advice that could help? i’m not sure whether to try a fresh 1.6 install and recover what i can from the old site so i can keep working on it (i hope to publish by the weekend), or to wait for 1.7 compatible themes to be released. or if there are some already out there that i have just been unable to find.

it would be brilliant if someone with a bit more magento experience could give me an idea how they would proceed in my situation.

thanx for reading.

Andy

How about some more info, besides my site died.  Maybe then you can get more exact help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
joeymad
Jr. Member
 
Total Posts:  10
Joined:  2011-06-24
 

I was able to successfully upgrade from 1.6.1 to 1.7.0 using Magento Connect Manager.

Here are the steps I followed, I apologize if I leave something out, I am going off of memory at this point. This was what I had to do to go from 1.6.1 to 1.7.0, the steps may be a bit different based on your installation and what extensions you have.

1. Go to http://yourdomain.com/magento/downloader/ (of course, make this match your installation’s path.
2. Because I had installed Magento using tar.gz package provided with a skin I wanted to use, Magento Connect didn’t have all the extensions listed for upgrading. I had to type “connect20.magentocommerce.com/community/Mage_All_Latest” in the “Install New Extensions / Paste extension key to install”
3. If you run into an error along the lines of “CONNECT ERROR: Package ‘Mage_All_Latest’ is invalid” repeated several times, once for each package, it is because the files already exist, and you have to remove a line of code in order for it to over-write data. Follow the instructions in this post to fix that. I would comment it out rather than delete the lines though.
4. After everything has updated, you will probably have some errors. Make sure you clean the cache and session directories (delete everything in /var/cache and /var/session)
5. If you receive a “500 Internal Server Error” it is more than likely because of file and folder permissions. Follow the instructions on this wiki. The simplest method on there, and the way I achieve success was to download the “Magento Cleanup Tool” and run it. It took .5 sec to reset all of the permissions to what they needed to be.
6. If you receive a “Service Temporarily Unavailable The server is temporarily unable to service your request” error on a Magento formatted header, it is probably because the store is set to offline mode to prevent visitors from screwing up the installation process. To fix this, delete the “maintenance.flag” file found in the root of your magento installation directory.
7. Everything should be good to go!

I hope this helps somebody out, because I went into this blindly and was expecting to screw everything up, but after searching for solutions to every issue I ran into along the way, I arrived at a working installation of 1.7.0!

I can’t say that it was completely without issues. Here is what I have experienced so far:
* Haven’t found out how to see/ set the mobile skin to the new HTML5 version, I can only set it to the OLD mobile skin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
focallocal
Jr. Member
 
Total Posts:  16
Joined:  2012-04-18
 

thanx for the replies. i’m using the absolute template. the upgrade seemed to go fine and the site is still there (without the template) but when i log into the administrator section i get a white page with this error:

Fatal error: Call to a member function checkUpdate() on a non-object in /home/oliveboa/public_html/app/code/community/TM/Core/Model/Observer.php on line 14

so i cant access the admin area at all - not even to change back to 1.6.

someone in another thread said this was an issue with my template.

 
Magento Community Magento Community
Magento Community
Magento Community
 
focallocal
Jr. Member
 
Total Posts:  16
Joined:  2012-04-18
 

here is the file it has a issue with:

<?php

class TM_Core_Model_Observer
{
/**
* Predispath admin action controller
*
* @param Varien_Event_Observer $observer
*/
public function preDispatch(Varien_Event_Observer $observer)
{
if (Mage::getSingleton(’admin/session’)->isLoggedIn()) {
$feedModel = Mage::getModel(’tmcore/notification_feed’); ............*this is line 13*
$feedModel->checkUpdate();
}
}
}

 
Magento Community Magento Community
Magento Community
Magento Community
 
JonnyCowling
Jr. Member
 
Total Posts:  2
Joined:  2012-04-04
 

Hi there, I’m a total newbie to Magento…

Is there a user guide to follow for upgrading to Magento 1.7? I can’t find one anywhere.

Many thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
focallocal
Jr. Member
 
Total Posts:  16
Joined:  2012-04-18
 

joeymad wrote a really good one above.

 
Magento Community Magento Community
Magento Community
Magento Community
 
aaronwallace
Member
 
Total Posts:  59
Joined:  2011-07-18
 
focallocal - 01 May 2012 09:01 AM

Hi everyone, i’ve just started and i think i’ve picked the worst possible time.

i nearly finished building a site when i got the notification that 1.7 had been launched so i upgraded and my site died. as a new user running a small shop i want to stick to free templates for the moment but i cant find any which are 1.7 compatible - i was using magento absolute.

does anyone on here have any advice that could help? i’m not sure whether to try a fresh 1.6 install and recover what i can from the old site so i can keep working on it (i hope to publish by the weekend), or to wait for 1.7 compatible themes to be released. or if there are some already out there that i have just been unable to find.

it would be brilliant if someone with a bit more magento experience could give me an idea how they would proceed in my situation.

thanx for reading.

Andy

In case you are still looking for Magento 1.7 Theme for FREE....download them here: http://www.expertmagentodevelopers.com/blog/download-free-magento-1-7-themes/

Our Magento Developers have exclusively tested these themes on Magento 1.7. Some of theme have been modified by them too.

I hope it will work for you.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top