Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Artikelbilder erscheinen nicht, weder Back- noch Frontend
 
rhae
Jr. Member
 
Total Posts:  2
Joined:  2012-04-24
 

Hallo,

seit Tagen kämpfe ich mit der Installation von Magento 1.7. Mittlerweile läuft das System ganz gut, nur der Upload bzw. die Anzeige von Artikelbildern funktioniert nicht richtig. Nach dem Upload stehen die Bilder zunächst im Verzeichnis <b>media/tmp/catalog/product/Buchstabe</b> und nach dem Speichern des Artikeln erscheinen sie in <b>media/catalog/product/Buchstabe</b>, also eigentlich so wie es sein soll. Trotzdem kommt in der Artikelverwaltung weder ein Vorschaubild noch wird der Dateiname angezeigt.

Erwähnen möchte ich noch, dass Magento bei uns nicht mit der normalen .htaccess-Datei funktioniert, unsere sieht zur Zeit so aus:

DirectoryIndex index.php

RewriteEngine on
RewriteBase 
/
RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l
## RewriteRule .* index.php 
RewriteRule ^(.*)$ /magento/index.php [L]

## php_flag magic_quotes_gpc off
## php_flag session.auto_start off
## php_flag suhosin.session.cryptua off

<IfModule mod_fcgid.c>
FcgidMaxRequestLen 1000000000
</IfModule>

(den unteren Abschnitt fand ich als Tipp in einem Forum, Änderungen im Verhalten gabe es damit aber nicht).

Hat jemand einen rettenden Tipp für mich?

vg Ralph

Image Attachments
magento-fehler.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
rhae
Jr. Member
 
Total Posts:  2
Joined:  2012-04-24
 

Mal eine kurze Antwort von mir selbst. Mit Hilfe der error_log-Datei des Servers konnte ich die .htaccess Datei des media-Verzeichnisses anpassen (vorher war keine .htaccess in /media vorhanden, warum auch immer). Mit folgenden Einträgen erscheinen die Artikelbilder jedenfalls:

## Options All -Indexes
## <IfModule mod_php5.c>
## php_flag engine 0
## </IfModule>

AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi
## Options -ExecCGI

<IfModule mod_rewrite.c>

##    Options +FollowSymLinks
    
RewriteEngine on
    RewriteCond 
%{REQUEST_FILENAME} !-f
    RewriteRule 
.* ../get.php [L]
    
</IfModule>

Das Ausklammern einiger Optionen musste sein, sonst gab es wieder nur Fehler.

Was mich jetzt noch irritiert, ist die Fehlermeldung:

[Wed May xxx] [error] [client 213.131.xxx.xxx] client denied by server configuration: /home/www/web78/html/magento/app/etc/local.xml

Sie kommt jedesmal beim Aufruf einer Funktion im Admin-Menü (z.B. Klick auf “Ãœbersicht"), bei Aktionen im Frontend kommt sie aber nicht. In der local.xml stehen eigentlich nur die Zugangsfunktionen zur Datenbank drin, aber was löst den Fehler denn dann aus?  :(

vg Ralph

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nürnberger
Jr. Member
 
Total Posts:  1
Joined:  2010-12-02
 

Hallo,

ich wollte kurz nachfragen, hast du schon eine Lösung gefunden? Ich habe das selbe Problem! Bin aber totaler magento Neuling!

 
Magento Community Magento Community
Magento Community
Magento Community
 
motribot
Jr. Member
 
Total Posts:  1
Joined:  2011-05-15
 

Hallo , ich habe einfach die .htaccess im Ordner media entfernt. Nun werden alle Bilder gefunden und angezeigt !

Gruß

Martin Boot

 
Magento Community Magento Community
Magento Community
Magento Community
 
sringel
Member
 
Avatar
Total Posts:  55
Joined:  2012-02-20
 

Schau mal die Berechtigungen des media Ordners an.  Die htaccess zu entfernen, sollte eigentlich nicht die Lösung sein.
Allgemein einmal schauen, ob die Berechtigungen korrekt sind. Viele Fehler bei Magento lassen sich auf falsche Rechte oder htaccess zurückführen.

 
Magento Community Magento Community
Magento Community
Magento Community
 
soigroeg
Jr. Member
 
Total Posts:  1
Joined:  2012-08-26
 
sringel - 08 August 2012 05:27 AM

Schau mal die Berechtigungen des media Ordners an.  Die htaccess zu entfernen, sollte eigentlich nicht die Lösung sein.

Ist sie aber. Bei mir hat das Löschen der htaccess im Media Ordner auch Abhilfe geschaffen.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top