Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

CMS -> Seiten Verwalten = 404 Page not found
 
Michael Melster
Jr. Member
 
Total Posts:  10
Joined:  2008-01-07
 

Hallo zusammen,

ich hoffe jemand kann mir einen Tipp geben um folgenden Fehler zu beheben.

Immer wenn ich auf CMS -> Seiten bearbeiten klicke um Inhalte zu bearbeiten, kommt die 404 - Page not found Seite.

Hätte jemand einen Anhaltspunkt, wo ich anfangen kann mit der Fehlersuche bzw. woran es eventuell liegen könnte?

Ich habe hier im Forum gelesen, dass dieser Fehler bereits mehrmals vorgekommen ist. Die Lösungsansätze haben bei mir aber leider nicht geholfen.

danke & viele grüße
micha

 
Magento Community Magento Community
Magento Community
Magento Community
 
selsys
Member
 
Avatar
Total Posts:  73
Joined:  2009-07-03
 

Hallo,

Ich habe das selbe Problem. Kennt jemand einen Workaround dafür?

Bin für alle Tips dankbar…

 
Magento Community Magento Community
Magento Community
Magento Community
 
bown
Jr. Member
 
Total Posts:  24
Joined:  2009-03-31
 

selbes Problem nach Market Ready Germany Extension installation! Ich habe einen multi store und leider die extension erst später eingebunden!

hoffe jemand kann helfen.

lg
bown

 
Magento Community Magento Community
Magento Community
Magento Community
 
bown
Jr. Member
 
Total Posts:  24
Joined:  2009-03-31
 

hat keiner eine idee wonach man suchen muss?

würde mir echt sehr helfen!!1

lg
bown

 
Magento Community Magento Community
Magento Community
Magento Community
 
bown
Jr. Member
 
Total Posts:  24
Joined:  2009-03-31
 

Hallo also ich habe die Lösung gefunden. Man gehe in die Datenbank unter CMS_pages unde unter CMS_pages_store Dort sollte man die ID’vergleichen und schaun welche Seiten falsch verlinken dann die verknüpfungen der flaschen Seiten löschen.

Viel Spass dabei

 
Magento Community Magento Community
Magento Community
Magento Community
 
charismeki
Member
 
Avatar
Total Posts:  35
Joined:  2009-02-27
Potsdam
 

Hallo bown,

habe genau dasselbe Problem bzw. kommt die 404 Fehlerseite immer nach dem Login. Wäre es möglich die Lösung etwas genauer zu beschreiben, da ich kein mysql experte bin:

- in phpmyadmin finde ich die table cms_page und cms_page_store
--in cms_page das feld page ids und dort sind die page ids bei mir abwärts sortiert von 1 - 15
--in cms_page_store habe ich ebenfalls ein feld page_id: dort sind die page_ids durcheinander aber den jeweilgen pages richtig zugeordnet. Wie finden ich die falschen IDs heraus?

Wäre über einen Tipp sehr dankbar, denn die 404 Ansicht ist lästig.

Vielen Dank und Gruß!

LG,
c

 
Magento Community Magento Community
Magento Community
Magento Community
 
ichwars83
Jr. Member
 
Total Posts:  21
Joined:  2009-07-08
 

Hallo,

hab auch dieses Problem.
Ich verwende das Blue Theme. Ich weiß das es gestern bzw. anfang der Woche noch ging. Habe lediglich die boxes.css, reset.css, die list.phtml und media.phtml. bearbeitet. Habe alle Demo- und Testprodukte gelöscht.

Das Problem tritt wie gesagt nur im Backend auf, denn im Frontend funktionieren soweit alle Seiten.

Vielleicht hat einer einen schnellen Rat. Ansonsten bleibt mir nix als den Shop neu aufzusetzen und die Anpassungen zu wiederholen.

Cache ist aktualisiert und auf dem Server ist alles auf 777 gestellt.

Viele Grüße
Pat

 
Magento Community Magento Community
Magento Community
Magento Community
 
ds_1984
Mentor
 
Avatar
Total Posts:  3116
Joined:  2008-12-09
Potsdam, Germany
 

Zunächst einmal die Frage - warum 777 - es werden für die Verzeichnisse 755 & für die Dateien 644 als empfohlen angesehen.

Das kann man hiermit schnell global setzen: http://www.mxperts.de/magento-cleanup-tool-sorgt-fur-ordnung-und-kompatiblitat/

Des Weiteren empfehle ich bei solchen Fehlern im Backend mal nach System->Konfiguration->Erweitert->Admin zu gehen und dort bei “Sicherheit" unter “Secret-Key zu URLs hinzufügen” auf Nein umzustellen.

Ich hatte mal ähnliche Probleme im Backend und konnte es so lösen (die Links der Navigation treffen nicht Ihr Ziel in manchen Installationen) daher dieser Fehler.

Liebe Grüße - Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
ichwars83
Jr. Member
 
Total Posts:  21
Joined:  2009-07-08
 

Hallo Daniel,

habe mal deine Lösungsvorschläge durchgeführt, doch jedoch waren diese ohne Erfolg.

Ich habe das gefühl, das ich wohl Magento neu aufsetzen muss...-_-

Oder gibt es noch andere Vorschläge.

mfg

 
Magento Community Magento Community
Magento Community
Magento Community
 
roeschen
Jr. Member
 
Total Posts:  18
Joined:  2008-11-02
 

Unter core_store sind in der Datenbank die store_id’s zu finden, die im jeweiligen Shop mit welchem zugehörigen store veknüpft sind. Mit diesen IDs nun unter cms_page_store die jeweilge Seite dem richtigen Store zuordnen. Die Seite und den Anfang derer kann ggf. unter cms_page nochmal nachgeschaut werden. Ziel ist es jedoch, dass alle Seiten nur gültige IDs haben wie unter core_store zu entnehmen ist. Notfalls hier einfach eine gültige store_id zuordnen und dann im Adminbereich überprüfen, ob es wirklich der richtige war.
Ich hab dadurch das Problem nach der Installation der Market Ready Germany Extension bei mir gelöst.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Johannes Lietz
Jr. Member
 
Total Posts:  12
Joined:  2009-05-12
Wuppertal, Germany
 

Danke, das war der Fehler…

roeschen - 29 November 2009 06:51 AM

Unter core_store sind in der Datenbank die store_id’s zu finden, die im jeweiligen Shop mit welchem zugehörigen store veknüpft sind. Mit diesen IDs nun unter cms_page_store die jeweilge Seite dem richtigen Store zuordnen. Die Seite und den Anfang derer kann ggf. unter cms_page nochmal nachgeschaut werden. Ziel ist es jedoch, dass alle Seiten nur gültige IDs haben wie unter core_store zu entnehmen ist. Notfalls hier einfach eine gültige store_id zuordnen und dann im Adminbereich überprüfen, ob es wirklich der richtige war.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xindustry
Jr. Member
 
Total Posts:  6
Joined:  2010-03-22
 

Auch bei der neuen Erweiterung German Shop trat der Fehler bei mir auf. Diese Anleitung hat auch hier geholfen. Vielen Dank.

 
Magento Community Magento Community
Magento Community
Magento Community
 
domochevsky
Jr. Member
 
Total Posts:  20
Joined:  2012-05-02
 

Dasselbe Problem - nur an anderer Stelle!

Im Grunde funktioniert alles sehr gut, nur gelangt man bei meinen angelegten Artikeln über den Link “Erfahren Sie mehr” auf der 404-Error-Seite.

Magento habe ich lokal mittels XMAPP installiert und auch hier gab es keine Schwierigkeiten. Die Kategorien sind da, einzelne Artikel in der Sortimentübersicht, Gruppen, Bundles, die ich erstellt habe, nur wie gesagt, gelangt man nicht auf die einzlnen Artikelseiten.

Aus der Datenbank-Anleitung komme ich nicht klar.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top