Magento Forum

Page 1 of 2
Installing Magento 1.7 with WAMP 2.2 error
 
perspres
Jr. Member
 
Total Posts:  11
Joined:  2012-04-20
 

I’m having a some problems installing Magento 1.7 (full) with WAMP.

I’m just receiving an error (ERR_CONNECTION_RESET) when trying to load the installer. I’ve checked all the apache/php/mysql logs and everything seems fine there. I’ve even renamed the /errors/local.xml.sample to local.xml and I’m still not receiving any further error details.

This has been tested on two different terminals, one of which had a fresh copy of WAMP on it. I previously loaded 1.6 without any problems, which is why I find this surprising!

Is anyone else receiving an issue or know or a means to get some more error feedback so I can work out what is going on here?

SPECS:
Magento 1.7.0
WAMP 2.2
Apache 2.2.1
PHP 5.3.10 (error_reporting=E_ALL)
MySQL 5.5.20

 
Magento Community Magento Community
Magento Community
Magento Community
 
manuel_dacosta
Jr. Member
 
Total Posts:  1
Joined:  2012-02-07
 

Hi, I have the same problem with wamp and magento 1.7. although I had no problem with the 1.7 alpha version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
perspres
Jr. Member
 
Total Posts:  11
Joined:  2012-04-20
 
manuel_dacosta - 26 April 2012 05:31 AM

Hi, I have the same problem with wamp and magento 1.7. although I had no problem with the 1.7 alpha version.

Glad to see that I’m not the only one. I’ve heard some success stories from users running WAMP 2.0. I’m going to attempt this and I’ll report back.

 
Magento Community Magento Community
Magento Community
Magento Community
 
perspres
Jr. Member
 
Total Posts:  11
Joined:  2012-04-20
 

Okay,

We’re getting somewhere. I’ve managed to successfully install 1.7 on WAMP 2.0 without any problems.

Although this is a temporary fix, I’d still like to work out why it’s not working with WAMP 2.2. I’ve noticed that the version of WAMP 2.0 that i’ve downloaded is an x86 version as apposed to the orginal x64 version of WAMP 2.2. I’m going to have a play around and see if I can work out why Magento 1.7 doesn’t like WAMP 2.2.

If you want a temporary fix then you can use the link below to download WAMP 2.0i x86. First make a backup of the following files to help you migrate your setting/vhosts across.

\wamp\bin\apache\Apache2.2.11\bin\php.ini
\wamp\bin\apache\Apache2.2.11\bin\conf\extra\httpd-vhosts.conf

I’ll report back should I have any success with WAMP 2.2 rasberry

 
Magento Community Magento Community
Magento Community
Magento Community
 
perspres
Jr. Member
 
Total Posts:  11
Joined:  2012-04-20
 

Woop woop!

I have successfully installed Magento 1.7 (full) on WAMP 2.2. smile

Problem: In short, Magento 1.7 doesn’t like the PHP 5.3.10 that comes with WAMP. Not sure why, but it doesn’t!. The solution is to install the PHP5.3.0 addon available from the wampserver website.

Points to note:
1. The addons on the wampserver site do not come loaded with 64-bit DLLs so if your running with WAMP 64-bit then your going to have to switch to 32-bit.
2. You need to set up a virtualhost within apache for your site (e.g. magento.localhost) or you will not be able to login to the admin panel as most browsers do not enable cookies on sites without a . (decimal) in the url. I’m not going to detail how to do this here as theres loads on vhosts on google, all of which are written by better educated dudes than myself!

Basic Guide to Install Magento 1.7 on WAMP2.2

Download the following:

WAMP 2.2d MUST BE 32-bit!
Sourceforge - WAMP2.2d 32-bit

PHP 5.3.0
WAMP PHP 5.3.0 Addon

It’s best to start fresh, so take this opportunity to uninstall your current version of WAMP and ensure to delete any remaining folders left behind in “c:\wamp”. Please note that this going to wipe any databases/site files so ensure you make backups first if nessecesary.

1. Install WAMP2.2d.
2. Right Click WAMP icon > Apache > Apache Modules > ‘rewrite_module’ - enable.
3. Install PHP 5.3.0 and WAMP should restart in the process.
4. Enable PHP 5.3.0 by selecting it under WAMP icon > PHP > Version > ‘5.3.0’.
5. Edit your php.ini under WAMP icon > PHP > php.ini to uncomment ‘extension=php_curl.dll’.
6. WAMP icon > Restart all services.

You should now be left with a nice green WAMP icon and a version of PHP 5.3.0. If you proceed with Magento 1.7 as per normal, you should now be successful.

Good luck! :D

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeemVision
Jr. Member
 
Total Posts:  1
Joined:  2011-06-08
 

I have the same exact issue with WAMP 2.2 and Magento 1.7, and apache crashes as soon as I hit the page. Please keep us posted with any updates.

 
Magento Community Magento Community
Magento Community
Magento Community
 
perspres
Jr. Member
 
Total Posts:  11
Joined:  2012-04-20
 
Hessam - 26 April 2012 12:09 PM

I have the same exact issue with WAMP 2.2 and Magento 1.7, and apache crashes as soon as I hit the page. Please keep us posted with any updates.

The solution is above Hessam. Switch to WAMP 32-bit if your using the 64-bit version, download/install and enable the PHP 5.3.0 add-on.

That should do the trick but please let me know if your still having issues.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FalseWall
Jr. Member
 
Total Posts:  1
Joined:  2012-04-28
 

I did everything and got to the install, but once I change the database name and click submit, I get this message after 30 secs.

“Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\lib\Zend\Db\Statement\Pdo.php on line 228”

Has this issue been solved?

Going into both ini files in Apache and PHP to change the max execution times from 30s to 1800s doesn’t work.  Also changing the memory from 128M to 1024M doesn’t help either.

 
Magento Community Magento Community
Magento Community
Magento Community
 
perspres
Jr. Member
 
Total Posts:  11
Joined:  2012-04-20
 
FalseWall - 28 April 2012 03:00 PM

I did everything and got to the install, but once I change the database name and click submit, I get this message after 30 secs.

“Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\lib\Zend\Db\Statement\Pdo.php on line 228”

Has this issue been solved?

Going into both ini files in Apache and PHP to change the max execution times from 30s to 1800s doesn’t work.  Also changing the memory from 128M to 1024M doesn’t help either.

Hmm strange one FalseWall…

Changing the max_execution time should have resolved that. You sound like you know what your doing but I’m going to ask it anyway; you have restarted wamp to ensure it loads the changes in your php.ini? If you haven’t already done so it may also be worth confirming that the changes have been implemented by running a phpinfo.

You can do this by running the following if their isn’t one already available in your WAMP WWW dir.

<?php phpinfo(); ?>

Again, I don’t mean to state the obvious!

Dave

 
Magento Community Magento Community
Magento Community
Magento Community
 
euchenio
Jr. Member
 
Total Posts:  1
Joined:  2012-05-07
 

I have PHP 5.3.8 and I have same problem too, when I want to configuration DB with Magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
Appmerce
Guru
 
Avatar
Total Posts:  376
Joined:  2008-05-13
Amsterdam, The Netherlands
 

The strange thing is that Magento 1.7-rc1 does not have this problem, only 1.7.0.0

But what is the REAL solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
uhaish
Jr. Member
 
Total Posts:  1
Joined:  2012-04-05
 

I faced this same problem with WAMP after wasting SAT and half SUN I finally switched to XAMPP and it worked out of the box .

 
Magento Community Magento Community
Magento Community
Magento Community
 
jumla25_guy
Jr. Member
 
Total Posts:  9
Joined:  2012-01-21
 

Can confirm perspres’s solution:
WAMP 2.2d 32bit with either PHP 5.3.0 or 5.3.1 also is working for me on Windows-7 64bit.

 
Magento Community Magento Community
Magento Community
Magento Community
 
navid59
Jr. Member
 
Total Posts:  2
Joined:  2012-05-28
 

I have the same wamp wampserver2.2d-x32 but I have this problem , How can I solve it.
I install on my laptop by this version of wampsever, it’s worked but I have the same configuration on my PC , but it dosn’t work
please help me

 
Magento Community Magento Community
Magento Community
Magento Community
 
navid59
Jr. Member
 
Total Posts:  2
Joined:  2012-05-28
 

Finally I solved it , By reinstall the wampserver 2.2d 64 bit
wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
jicksonkoottala
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2012-03-06
Aluva
 

The magento 1.7.0 does not works in php 5.3.10 and apache 2.2.21 ( Both are used in wamp 2.2d X64 version .........)

So if you are using a wamp 2.2d x64 version dont need to uninstall it for magento 1.7.0
you just add-on the following things to your x64 bit wamp Magento 1.7.0 Installation in Wamp 2.2d x64

1. php 5.3.0
2. apache 2.2.11
3. and change your apache settings under wamp icon----> Right Click WAMP icon > Apache > Apache Modules > ‘rewrite_module’ - enable.
4.  Restart all the service

if you face problem during installation just increase maximum execution time to 1800 in your php.ini

PHP 5.3.0
Apache 2.2.11

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2