Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento error after trying to create a new store view
 
Artemis Mendrinos
Jr. Member
 
Total Posts:  2
Joined:  2009-01-02
 

Hello,

I have an eshop with over 1250 products and while I was trying to explore the possibilitis of magento, I just tried to create a new store view.

When requested to create the new store view I got the following error:

Error in file"/home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/CatalogIndex/sql/catalogindex_setup/mysql4-upgrade-0.7.9-0.7.10.php" SQLSTATE[42S01]Base table or view already exists1050 Table 'catalogindex_aggregation' already exists
Trace
:
#0 /home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/Core/Model/Resource/Setup.php(287): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '0.7.9', '0.7.10')
#2 /home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb('0.7.9', '0.7.10')
#3 /home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/Core/Model/Config.php(215): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/pezzio/public_html/pezziostore.com/public/app/code/core/Mage/Core/Model/App.php(241): Mage_Core_Model_Config->init(Array)
#6 /home/pezzio/public_html/pezziostore.com/public/app/Mage.php(427): Mage_Core_Model_App->init('', 'store', Array)
#7 /home/pezzio/public_html/pezziostore.com/public/app/Mage.php(446): Mage::app('', 'store', Array)
#8 /home/pezzio/public_html/pezziostore.com/public/index.php(52): Mage::run()
#9 {main}

And the eshop is now unusable!

Could anyone know a way to recover from this issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
andiszek
Member
 
Total Posts:  31
Joined:  2008-11-02
 

same thing here.
fortunately i don`t have any products, just categories and a manually created translation.

i have upgraded to the latest Magento version. then all my categories and subcategories were gone.
i said OK, no problem, i create a new store and manually recreate all the categories.
after creating the new store and making it default, the shop & admin are unusable.

one thing learned: ALWAYS make a folder backup BEFORE any stupid upgrades or system changes.

Artemis, have you found any solution? could you share it?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top