Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Using htacess to enable php5 to php files [error screenshot]
 
antoniomax
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-01-17
 

Hi

I have php 5 on my hosing server but only when you use php5 extension.
So on my htacess file ive written:

AddHandler application/x-httpd-php5 .php

And now it doesnt seem to have any php version errors, but anyway i cannot install since the page looks without any css and broken.
Ive attached a screenshot.
Somebody can point me any directions to go from now on?

Thanks
Max

Image Attachments
pic.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Radovan Jablonovsky
Jr. Member
 
Total Posts:  1
Joined:  2008-01-14
 

Hello,

I have similar problem. I have open SuSE 10.3 linux with mod_php (5.2.5) , apache (2.2.4) and problem with installation page. What could be wrong?
My .htaccess is in /srv/www/htdocs/slavo/magento and web root is /srv/www/htdocs
.htaccess is:
############################################
## uncomment these lines for CGI mode

#Action php5-cgi /cgi-bin/php-cgi
#AddHandler php5-cgi .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

php_flag short_open_tag on

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

RewriteBase /slavo/magento/

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php

</IfModule>

Order allow,deny
Allow from all

Sincerely,
Rado

Image Attachments
magento_broken_css.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
antoniomax
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-01-17
 

can anyone point any direction on this issue?
its seems that the code isnt being executed at all, and after some google i´ve found that some running stores had this issue before just checking google cache at running magento stores arround, example?
google for:
getChildHtml
the third result gives you the url of
http://www.grayrobbins.com/
if you click it, you see a running magento store, but if you click the cache button, it gives you the same screen i have.

any tips please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JAGwar1905
Jr. Member
 
Total Posts:  4
Joined:  2008-01-16
 

Thats my Site

 
Magento Community Magento Community
Magento Community
Magento Community
 
antoniomax
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-01-17
 

grayrobbins.com ? So what had you done to get it working since you had that same screen?
****** fs *

 
Magento Community Magento Community
Magento Community
Magento Community
 
JAGwar1905
Jr. Member
 
Total Posts:  4
Joined:  2008-01-16
 

i reinstalled my sever
ubuntu
then used xampp
so im not sure what exactly fixed that

 
Magento Community Magento Community
Magento Community
Magento Community
 
antoniomax
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-01-17
 

Can you provide a copy of your.htaccess file so we can compare it to our files? I have no idea on where to start to debug this kinda error, but checking your file is at least a start.
Thanks anyway.

 
Magento Community Magento Community
Magento Community
Magento Community
 
antoniomax
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-01-17
 

After running some tests looks like that mod_rewrite might not be ‘enabled’ on my hosting provider. Could that be the issue behind that error page?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JAGwar1905
Jr. Member
 
Total Posts:  4
Joined:  2008-01-16
 

############################################
## uncomment these lines for CGI mode

#Action php5-cgi /cgi-bin/php-cgi
#AddHandler php5-cgi .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

php_flag short_open_tag on

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

#RewriteBase /magento/

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php

</IfModule>

Order allow,deny
Allow from all

 
Magento Community Magento Community
Magento Community
Magento Community
 
antoniomax
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-01-17
 

Managed to get it installed on another hosting company.
That one was a FreeBSD plataform with no mod_rewrite enabled, the new one is a linux machine.
Perhaps that error message is related to a server config, not the magento config?
All i know is that i have an up and running magento store on test now and thanks, its awesome.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top