Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

[PARTLY SOLVED] ERROR with cache system! How do i disable cache manually? 
 
fupper
Member
 
Total Posts:  33
Joined:  2008-11-27
 

I did nothing to my magento and it was working well for like 3 weeks or so.
The 3 weeks was spent design the frontend and when the site was finally gonna go LIVE, i got this problem.
I enabled caching(as i was done with the designing and stuffs) for all the avaliable stuffs to cache and used the storewide discount feature before disaster strike.

Warning: simplexml_load_string() [function.simplexml-load-string]: namespace error : Failed to parse QName ‘sn:’ in /home/globalwh/public_html/fupt/lib/Varien/Simplexml/Config.php on line 383
Trace:
#0 /home/globalwh/public_html/fupt/lib/Varien/Simplexml/Config.php(383): mageCoreErrorHandler(2, ‘simplexml_load_...’, ‘/home/globalwh/...’, 383, Array)
#1 /home/globalwh/public_html/fupt/app/code/core/Mage/Core/Model/Config.php(149): Varien_Simplexml_Config->loadCache(’init()
#3 /home/globalwh/public_html/fupt/app/Mage.php(427): Mage_Core_Model_App->init(Array)
#4 /home/globalwh/public_html/fupt/app/Mage.php(446): Mage::app(’’, ‘store’, Array)
#5 /home/globalwh/public_html/fupt/index.php(52): Mage::run(’’, ‘store’, Array)
#6 {main}

After doodling around for quite a while, i realise that when i MANUALLY clear my cache in var/cache, i was able to load the site sucessfully for that one load. After that, var/cache is filled again and the next load(on any clicks on the site) actually gives me the above error again.

So i assume that it’s a problem with the caching system.

Is there anyone with the above error and any solutions? (searched on this site but did not get any results)

Or is there anyone who knows how to disable caching MANUALLY in Magento?
I was thinking that i should start debuging from this, but after exploring the mysql database and searching through core_config(and other datas), i couldn’t find the string to disable the cache manually. Any help?

Thanks! I am operating on 1.2.0.1 now as i have upgraded Magento successfully(i think) through SimpleScripts. This is the only problem brought through the upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fibo
Sr. Member
 
Avatar
Total Posts:  107
Joined:  2008-06-25
Marseille, France
 

Be careful when clearing the cache manually: in one earlier version this apparently caused the system to crash and I had to painfully recreate a cache. (Lesson 1: make a local copy of the remote cache in case you need it)

If you go to admin / system / cache management, you will be able to disable and clear the cache for most objects.

Specially needed for 1.2.0.1: clear the cache for searches

 
Magento Community Magento Community
Magento Community
Magento Community
 
fupper
Member
 
Total Posts:  33
Joined:  2008-11-27
 

Hey Fibo! i understand about disabling the cache through the admin panel, however, my admin is currently inaccessible too due to that error!
Hmm, i actually delete all the files at once in the cache system (something from a to z)..
So the whole site is down and i’m looking at disabling the cache manually in the database or somewhere else. Anyone?

I realise that since my caching system is switched on, whenever it starts to cache, the whole system just crashed and burnt.

Help required! i really don’t want to recreate the shop again! it’s a lot of work(since it was just about to go live!)!

 
Magento Community Magento Community
Magento Community
Magento Community
 
fupper
Member
 
Total Posts:  33
Joined:  2008-11-27
 

SOLVED with Crucial’s wiki submission.

http://www.magentocommerce.com/wiki/groups/227/cache_is_not_writable

Thanks Crucial!!!!

now.. gonna solve another problem.. that is, infinite re-directing loops for some users.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fupper
Member
 
Total Posts:  33
Joined:  2008-11-27
 

PROBLEM.

after deleting use_cache.ser, i can surf the site as per normal.

HOWEVER, once i enable cache, the same error appear.

help?
i need caching for my site or it will be a resource drain!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top