Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error on clicking on “Ship” on customer order
 
sheba2
Sr. Member
 
Avatar
Total Posts:  111
Joined:  2011-01-05
United States
 

I have shiprush installed which is how shipment is completed.  Without the PAP connector it works perfectly - I click on ship,it sends the info to shiprush, label is generated, tracking code entered in system AND order status changes to COMPLETED.

Now I get this error message when I click ship:
Fatal error: require_once() [function.require]: Failed opening required ‘PAP/PapApi.class.php’ (include_path=’/home/user/public_html/app/code/local:/home/user/public_html/app/code/community:/home/user/public_html/app/code/core:/home/user/public_html/lib:.:/usr/lib/php:/home/user/public_html/lib/PEAR:/home/user/public_html/lib/Zing’) in /home/user/public_html/app/code/local/Mage/Pap/Model/Config.php on line 142

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageGuys
Guru
 
Avatar
Total Posts:  380
Joined:  2008-06-07
 

The module is not correctly installed. That API file should have been placed in the lib directory. Download the manual installation file from http://www.priacta.com/code/magento-affiliate/magento-post-affiliate-pro.php and try manually installing.

Also, if you are using hosted PAP you\’ll almost certainly need to update the API file (otherwise you\’ll get warnings.) Instructions for updating are at http://www.magentocommerce.com/boards/viewthread/197113/#t253614.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top