Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Another Bug - After successful checkout, the cart is not empty
 
Redhat
Jr. Member
 
Total Posts:  16
Joined:  2008-07-06
Tel Aviv
 

I survived the upgrade to 1.2.0.1 after i applied some of the fixes suggested by community members. Except few issues with the reports, everything looks OK.

One bug that i discovered is still affecting the store performance:

When a customer is going through the checkout process and complete an order, instead of being redirected to the “Thank You” page (success.phtml) he is redirected to his cart again and the items remain in it.

The system does add his order to the orders report, the credit card processing reports (UK protx) does show the transaction and the standard email is being sent to the customer with order confirmation.

The apache server logs show that a call to /checkout/onepage/success/ was done.

The redirect to the cart is done with HTTPS, not as regular cart pages which are usually displayed in HTTP.

I made couple of tests with IE7 and FF3 and all had the same problem.

I have this problem on 2 different Magento installations (both run 1.2.0.1), each one of them running couple of websites with couple of stores, each store with single store view. I tested with all stores and i had the same problem with all of them.

I suggest to all of you to run full purchase tests with your stores and see if the checkout process ends as expected or if you have this bug.

Any idea how to fix that problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
House of Type
Jr. Member
 
Total Posts:  14
Joined:  2009-01-07
 

I’ve had this problem too.

A quick and speedy resolution would be greatly appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Redhat
Jr. Member
 
Total Posts:  16
Joined:  2008-07-06
Tel Aviv
 

Forgot to mention - the payment module being used with that system is Protx.

House of Type - Are you also using Protx module?

I can’t find anyone else in the forums that have the same problem so i am starting to think that the protx module is the problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

We are getting the same in Protx direct and Paypal Payments Pro.

Causing SERIOUS issues.

Checkout completes OK and then redirects to cart page which still has item in cart so customers are checking out several times and getting charged several times.

Funny we thought we had tested everything on 1.2.01 on our dev system and we never came across this bug hence made live today.

Tested on Firefox & IE - and same issues.

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

Just wandering if making the changes recommended in this thread is causing the issues:

http://www.magentocommerce.com/boards/viewthread/27102/P0/

We had the non SSL problem and implemented the suggestions in that thread - it certainly fixed the non ssl issues but may have caused other issues????

Just thinking out loud for resolutions....

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 
golles - 07 January 2009 12:50 PM

Just wandering if making the changes recommended in this thread is causing the issues:

http://www.magentocommerce.com/boards/viewthread/27102/P0/

We had the non SSL problem and implemented the suggestions in that thread - it certainly fixed the non ssl issues but may have caused other issues????

Just thinking out loud for resolutions....

Scrap that - just tested by reverting back that change and still the same issue - checkout complete and then redirect to cart page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

Bug reported:

http://www.magentocommerce.com/bug-tracking/issue?issue=4740

 
Magento Community Magento Community
Magento Community
Magento Community
 
House of Type
Jr. Member
 
Total Posts:  14
Joined:  2009-01-07
 

we also use Protx, however I tried this using the Check / Postal Order payment method and found the same error.

I looked into the javascript for the save / processing the order, and it appeared to be fine, and it redirects to the success page as it should. So it must be an error with the success page or the accompanying code for it,.

It’s not the fix for the SSL problem causing this, as we had not implemented this and still had this problem.

I am certain that it is the success page, or code which is called before the page is displayed which is causing this. The JS file which sends the order via AJAX when you click the last button on the Checkout (opcheckout.js) in your template js folder is fine and has not changed from the 1.8 version.

Can anyone shed any more light on this ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Redhat
Jr. Member
 
Total Posts:  16
Joined:  2008-07-06
Tel Aviv
 

Golles, i also followed the solution from here
http://www.magentocommerce.com/boards/viewthread/27102/P0/

I am on that issue for the last few hours and could not find any clue. The Protx payment module is a part of the problem - we see that we all use it and we all suffer from the same problem.

However, it was not changed in the last few weeks so it is nothing to do with it’s code, only with the way it interacts with Magento.

Besides that, i have no idea how to find out where the problem is. Magento is built from tens of thousands of small files that call one each other. I could not find how to keep track of what files are accessed during the checkout.

Customers submit their credit cards 2-5 times before they notice that they get an email with transaction approval and then they contact the support. This problem need a quick fix…

 
Magento Community Magento Community
Magento Community
Magento Community
 
House of Type
Jr. Member
 
Total Posts:  14
Joined:  2009-01-07
 

Well out of interest is there anyone who has uinstalled the protx module and still has this problem ? or can someone on the magento team look at this module and see what it’s doing that is upsetting the new version of magento ?

regards

House of Type

 
Magento Community Magento Community
Magento Community
Magento Community
 
suleyman
Member
 
Total Posts:  53
Joined:  2008-10-19
 

hi guys just thought id add myself to this list

yes same issue here

and yes im using protx direct

i posted this twice on the forum before i found this thread im really hoping someone takles this issue because im also having issues with people placing double sometimes triple orders

someone PLEASE PLEASE PLEASE HELP

 
Magento Community Magento Community
Magento Community
Magento Community
 
Redhat
Jr. Member
 
Total Posts:  16
Joined:  2008-07-06
Tel Aviv
 

Some other problem that somehow looks similar:

Another Problem

The callback URL is wrong - not https in that case.
Google reject the transaction because it cannot send the results over SSL.

My theory:
The end of the purchase (onepage checkout) is calling the un-secured URL which redirect back to the cart without “accepting” the order.

This worth a check with other forum threads regarding different payment modules that stopped working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

Just to follow up on our testing, we have tried, these payment modules and all give the same problems:

1) Protx Direct -
2) Paypal Payments pro
3) Cheque

All result in customers going through checkout order is completed fine but they are then redirected to cart page, which still has the product(s) they just paid for in the cart.

this is causing us immense issues. we have spent best part of 2 days trying to debug this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

Just out of interest - what theme are you all using?

Just trying to pinpoint the issue.

We are a modified version of modern. We have not changed any of what I would call the core files of modern though - checkout, js files etc - they are all still as per core.

we are checking the svn version of modern against ours at the moment to see if there are any theme changes that could caused the issues.

also enabling the default theme to see if that has the same issues.

will update later.

 
Magento Community Magento Community
Magento Community
Magento Community
 
golles
Sr. Member
 
Total Posts:  257
Joined:  2008-01-15
 

Ok we are pretty sure this is NOT theme related.

The issue is present on all themes we have tried

1) default
2) Modern - standard
3) Modern - our modified version

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dave Smith
Member
 
Avatar
Total Posts:  58
Joined:  2008-02-03
Tamworth, UK
 

EXACTLY the same issue here. Using protx direct, magento 1.2.01 and a custom built theme.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4