Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgraded from 1.1.8 to 1.2.0.1 - Site Not Working - Fatal Error!! 
 
hindleydp
Sr. Member
 
Total Posts:  98
Joined:  2008-11-14
 

Hi,

I upgraded today to 1.2.0.1 and now I get the following error and my site won’t function at all now:

Fatal error: Call to private method Zend_Currency::_checkparams() from context ‘Mage_Core_Model_Locale_Currency’ in /home/mysite/public_html/app/code/core/Mage/Core/Model/Locale/Currency.php on line 64

Anyone have any ideas?

This is the line it is referring to:

$params = self::_checkParams($currency, $locale);

 
Magento Community Magento Community
Magento Community
Magento Community
 
hindleydp
Sr. Member
 
Total Posts:  98
Joined:  2008-11-14
 

Having updated some more core modules through ssh I now can login through admin but am taken to a completely blank screen with no error message at all!  On the homepage it appears that only half of the page is loading..there is no error message here either...does anyone know what to try in this situation?!  I am utterly stumped......

 
Magento Community Magento Community
Magento Community
Magento Community
 
hindleydp
Sr. Member
 
Total Posts:  98
Joined:  2008-11-14
 

Just to note that having shown errors on the homepage it is definately the following that is causing the errors after I upgraded:

Fatal error: Call to private method Zend_Currency::_checkparams() from context ‘Mage_Core_Model_Locale_Currency’ in /home/mysite/public_html/app/code/core/Mage/Core/Model/Locale/Currency.php on line 64

Some pages, like my account etc..are loading up fine.  The hompage only loads half way and all products appear blank.  Admin also logs in fine but then a blank screen appears....argghhhh!!

Any help greatly appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hindleydp
Sr. Member
 
Total Posts:  98
Joined:  2008-11-14
 

Anyone had this before?  My site has been completely down ever since I upgraded and I really need to get this operational again…

Any help greatly appreciated!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Hello,

It sounds like some of the modules may not have been upgraded. This can usually be fixed by installing the missing modules manually through PEAR. Are you hosted with us? I noticed our nameservers in your DNS. Feel free to open a support ticket, and a member of our support team will assist you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hindleydp
Sr. Member
 
Total Posts:  98
Joined:  2008-11-14
 

Hi Sindre,

Thanks so much for the response.  I am indeed hosted by yourselves.

I have just submitted a support ticket #336309

 
Magento Community Magento Community
Magento Community
Magento Community
 
hindleydp
Sr. Member
 
Total Posts:  98
Joined:  2008-11-14
 

Legendary...this has now been fixed by your support team!

I must say I cannot recommend Properhost enough, been superb ever since I joined them…

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruno Serges
Jr. Member
 
Total Posts:  2
Joined:  2008-07-05
 

I have same problem. Any one have solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ruckenfigur
Jr. Member
 
Total Posts:  3
Joined:  2010-02-12
 

I got this error after I reinstalled Zend from Magento Connect. Do you know which files I should upload to fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

ruckenfigur: do you have SSH access on the server? Try to run the following command from your store root directory:

./pear upgrade-all

It should download and install the missing files. Remember to clear your var/cache/ directory afterwards.

 
Magento Community Magento Community
Magento Community
Magento Community
 
J.S. Coolen
Sr. Member
 
Total Posts:  86
Joined:  2009-08-20
Den Haag, Nederland
 

I Tried the pear thing, but the error is still there.

Every time the program needs to show a currency this error apears:

Fatal error: Call to private method Zend_Currency::_checkparams() from context ‘Mage_Core_Model_Locale_Currency’ in /home/jcsl/public_html/webshop/app/code/core/Mage/Core/Model/Locale/Currency.php on line 64

I tried to find a solution on the internet but I couldn’t find anything.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WMechelle
Member
 
Avatar
Total Posts:  52
Joined:  2009-12-16
 

Did anyone ever find a solution to this problem

“ Fatal error: Call to private method Zend_Currency::_checkParams() from context ‘Mage_Core_Model_Locale_Currency’ in /var/www/vhosts/ier-online.com/httpdocs/app/code/core/Mage/Core/Model/Locale/Currency.php on line 64 “

I too have a complete new upload.. the front end is fine but the backend is not accessible. I have run all the ssh updates and all says it is installed.  I have read and searched to no avail....  help please.

Im runnning it on godaddy… NOT SUGGESTED btw.. they suck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
theresfogonthetyne
Jr. Member
 
Total Posts:  5
Joined:  2009-03-20
 
WMechelle - 04 May 2010 04:48 AM

Did anyone ever find a solution to this problem

“ Fatal error: Call to private method Zend_Currency::_checkParams() from context ‘Mage_Core_Model_Locale_Currency’ in /var/www/vhosts/ier-online.com/httpdocs/app/code/core/Mage/Core/Model/Locale/Currency.php on line 64 “

I too have a complete new upload.. the front end is fine but the backend is not accessible. I have run all the ssh updates and all says it is installed.  I have read and searched to no avail....  help please.

Im runnning it on godaddy… NOT SUGGESTED btw.. they suck!

I am having the same issue. Seems like a bug in Magento. This class Mage_Core_Model_Locale_Currency runs a function that is calling a private function Zend_Currency::_checkParams(). This is causing the PHPerror.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WMechelle
Member
 
Avatar
Total Posts:  52
Joined:  2009-12-16
 

OK.. I was stupid and did a MagentoConnect reInstall of a few things and now I have the issue again as stated above ...

“ Fatal error: Call to private method Zend_Currency::_checkParams() from context ‘Mage_Core_Model_Locale_Currency’ in /var/www/vhosts/ier-online.com/httpdocs/app/code/core/Mage/Core/Model/Locale/Currency.php on line 64 “

I too have a complete new upload.. the front end is fine but the backend is not accessible. I have run all the ssh updates and all says it is installed.  I have read and searched to no avail....  help please.

Will I never learn?  I did this as I have an error loading new products and It shows I am missing some files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Missing extension=mcrypt.so on Ubuntu 8.0.4 Server install for PHP CLI php.ini file let first pass of ./pear install go through, the error messages were hidden in the spew. Corrected this and it caught all the rest of the missing core modules it had failed to install.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top