Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Steuerberechnung schlägt fehl
 
gutebotschafter
Jr. Member
 
Total Posts:  5
Joined:  2010-09-22
 

Guten Tag zusammen!

Wir haben uns auf Basis eines deutschen Shops einen schweizer Ländershop aufgebaut und nun stehen wir vor einem Problem mit der Steuerberechnung.

Im schweizer Store View (Admin Center) kostet ein Produkt CHF 5,80 (inkl. Steuern), die “Tax Class” ist auf 2,5% gesetzt.

In der Produktansicht:
kostet der Artikel plötzlich CHF 5,95 – das entspricht jedoch CHF 5,80 + 2,5% und ist somit falsch.

Im Warenkorb:
ist der Einzelpreis (zzgl. steuern) mit CHF 5,80 angegeben, der Preis inkl. Steuern beläuft sich auf CHF 5,95.
Desweiteren steht dort als Zwischensumme CHF 5,95 (zu viel), unter “Steuer” steht CHF 0,15 und die Gesamtsumme ist ebenfalls CHF 5,95.

Also scheint Magento in diesem Fall den Preis inkl. Mehrwertsteuer, den ich einpflege, als Preis zzgl. Mehrwertsteuer zu verstehen.

Folgende Konfiguration:
Die Steuersätze (8% und 2,5%) sind dem Land “Schweiz” zugewiesen.
Die Website der “Schweiz” hat als Ursprungsland für die Steuerberechnung ebenfalls die Schweiz verpasst bekommen.

Die restliche Konfiguration der “Steuer” habe ich als Screenshot angehängt.

Das merkwürdige:
Im deutschen Shop funktioniert die Berechnung. Gebe ich dort 2,95 EUR als Preis inkl. Steuern an dann wird es überall als Preis inkl. Steuern angezeigt. Nirgends steht was von 3,16 EUR (Preis + 7 MwSt.).

Merkwürdiger wird es wenn ich einem schweizer Produkt im schweizer Store View eine deutsche Steuerklasse verpasse. Dann kostet der Artikel nämlich überall CHF 5,42 (bei 7% Steuern) – dann ist wenigstens im Warenkorb der Preis zzgl. und inkl. MwSt. gleich aber der Preis wird dann ja auch falsch berechnet.

Hat einer von euch eine Idee woran es bei uns scheitert?

Image Attachments
Bildschirmfoto 2012-03-20 um 15.31.49.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
jedo
Jr. Member
 
Total Posts:  18
Joined:  2008-10-26
 

Habe keine Lösung, aber dasselbe Problem.

Irgendjemand eine Idee?

 
Magento Community Magento Community
Magento Community
Magento Community
 
pcartist
Jr. Member
 
Total Posts:  26
Joined:  2012-06-12
 

Hallo,

das kommt mir bekannt vor. Wenn Ihr Bruttopreise für Länder mit abweichenden Steuerkonfigurationen in eurem Backend einpflegt, wird scheinbar der Bruttopreis als Nettowert in die Datenbank abgelegt. Schaut mal nach, ob unter dem Eingabefeld für den Preis etwas in den eckigen Klammern ein Wert steht.

Magento verwendet - warum auch immer - die Lokalisierung des Admins (vermutlich IP) als Grundlage.

Bei mir hat folgende Lösung funktioniert:

1) in der Konfiguration für “Standard” alles auf Netto setzen und dann die richtigen Enstellungen für die jeweiligen Storeviews treffen
2) Bei den Steuerzonen- und Sätze muss dernSteuersatz des Ziellandes auch dem eigenen Land verfügbar gemacht werden
--> Steuerkennung DE 8% - Land: Deutschland. - PLZ: eigene PLZ. - Steuerzatz: 8%

Bei der Artikelkonfiguration dann den Bruttopreis eintragen und unten dass Feld für die Steuer leer lassen, dann in den Storeviews für die Länder den Haken für die Standardwerte neben Preis und Steuerklasse entfernen und die entsprechende Steuerklasse (z.B. CH 8%) auswählen.

Viel Erfolg!

 
Magento Community Magento Community
Magento Community
Magento Community
 
twoleftfeet
Member
 
Total Posts:  59
Joined:  2008-08-14
 

Ich glaube, ich habe ein ähnliches Problem.

Ich arbeite mit Magento 1.7.0.2 und habe die Katalogpreise (und alle anderen auch) auf \\\"inkl. MwSt.\\\” gesetzt.

In der Listenansicht erscheint es wunderbar. 59.- inkl 8% MwSt.
Wenn ich den Artikel dann in den Warenkorb lege, rechnet er plötzlich nochmal 8% drauf. Macht aber gar keinen Sinn..

Habt ihr da eine Lösung gefunden?

Image Attachments
Screenshot (30).pngScreenshot (29).pngScreenshot (28).png
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top