Magento Forum

   
navigation principale page cms réecriture url incorrecte que dans certaines rubriques
 
creativemotion
Jr. Member
 
Total Posts:  1
Joined:  2011-12-28
 

bonjour,
j’ai installé un magento en local et afin de crée ma navigation horizontale j’utilise
le script suivant : qui compose une navigation avec
mon arborescence catalogue + mes pages cms....

la page contenant le code se trouve dans :
app/design/frontend/mondesign/blank/template/catalog/navigation/top.phtml
--------------------------------------

l’appel se fait dans :
app/design/frontend/mondesign/blank/template/page/html/header.phtml

<?php echo $this->getChildHtml('topMenu') ?>

------------------------------------

<?php $_menu = $this->renderCategoriesMenuHtml(0,'level-top') ?>
<?php $_menu_cms = Mage::getModel('cms/page')->getCollection(); ?>
<?php if($_menu): ?>
<div>
<ul id="nav">
<?php foreach($_menu_cms as $cmspage): ?>
<?php $page = $cmspage->getData(); ?>
<?php if($page['identifier'] == "no-route" || $page['identifier'] == "enable-cookies"){ } else { ?>
<?php echo "<li><a href=\"".$page['identifier']."\" title=\"".$page['title']."\">".$page['title']."</a></li>"; ?>
<?php } ?>
<?php endforeach; ?>
<?php echo $_menu ?>
<li><a href="<?php echo Mage::getBaseUrl(Mage_Core_Model_Store::URL_TYPE_WEB); ?>magasin principal/contacts” title="Contact Office Chairs">Contact Us</a></li>
</ul>
</div>
<?php endif ?>

ma navigation se génère correctement je récup bien les libellés et les urls seulement
lorsque je navigue sur ma boutique, quand je suis par exemple dans une page de résultats de recherche ou dans le panier l’url est:
maboutique/magasin principal/catalogsearch/result/about-magento-demo-store
alors qu’elle devrait être :
maboutique/magasin principal/about-magento-demo-store
seul la page contact dont l’url est générée avec getBaseUrl fonctionne peut importe ou l’on se trouve.....

(j’ai vidé plusieurs fois le cache magento)

je ne trouve pas de doc ou d’info sur ce sujet ...
il y a t-il une manip particulière, un réglage, ou paramètre a configurer ?
quelque chose que je devrais savoir ? (lol)

d’avance un grand merci pour vos réponses je suis dans la panade
ma charte graphique est déjà intégrée smile

et oui pour moi le menu marchait .... par ce qu’il générait les liens me suis pa dit
tiens si je testait si par hasard il décidait de générer des liens différents dans certaine rubriques… lol

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top