Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade issue from 1.5.1 to 1.6.2/Latest
 
Sorin_Mihai
Jr. Member
 
Total Posts:  1
Joined:  2012-02-15
 

Hello,

I have setup a store using Magento 1.5.1 CE and now I would like to upgrade to 1.6.2 but I am unable to do it.

I have done the following:

- Set file and folder permissions to 777
- cleared cache and sesions
- executed the ./mage utility as follows:
# ./mage mage-setup
# ./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force

I got the following error:

Error:
install: Package community/Mage_All_Latest failed: Uri doesn’t contain host part

I even tried to execute ./mage install community Mage_All_Latest but the same error occurs with or without the --force argument.

How am I supposed to upgrade Magento if that tool doesn’t work?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alexandrable
Member
 
Total Posts:  55
Joined:  2011-09-01
 

I’m not sure you’re looking exactly for this type of solution, but this may help: you can make the fresh installation of Magento 1.6.2 and then move all your data there from your old version. This may sound too much, but judging from what I’ve read so far on the net - this is one of the safest solutions, since you don’t risk your data being disrupted or any of your scripts torn out. Think about it.

And if you decide to go ahead with the fresh installation and would need help moving your database there, I can advise using this: http://www.shopping-cart-migration.com/shopping-cart-migration-options/223-magento-to-magento-migration. There’s also a video about the process of moving your data here: http://www.shopping-cart-migration.com/supported-carts/55-magento.

This should help. Good luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
herofish
Jr. Member
 
Total Posts:  13
Joined:  2010-12-29
 

I just recently upgraded from 1.5 -> 1.62 and had a number of issues also.

Ultimatly,what I did was the following:

2.  Attempted to follow instructions at http://miragedesign.net/newss/magento-upgrade-from-1-5-1-to-1-6-0/# (didn’t really work too well)
a.  Chmod 700 ./mage (worked)
b.  ./mage install community Mage_Downloader –force (this errored because I didn’t use 2 hyphens before force) Then, when I figured out that issue, it failed halfway through, and actually removed the mage binary, seemingly along with a bunch of stuff in the ../downloader directory This meant I couldn’t’ perform the next step.  I restored the old mage binary, and copied over everything again into the downloader dir from a backup
c.  ./mage install community Mage_All_Latest –force (worked)
d.  ./mage sync-pear (worked)
e.  ./mage list-installed (worked)
f.  ./mage list-upgrades (worked)
g.  ./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force (worked)
h.  – I didn’t do the remaining items (since I didn’t want to set my site to beta)
i.  Cd var/cache then rm –r * (clear cache)
j.  Cd ../session then rm –r * (clear all sessions)
k.  Cd ../shell then php indexer.php reindexall (resulted in no errors)
l.  Upgrade done…

The above were notes I created afterwards since it was such a pain.  I hope it helps.  One of the biggest annoyances was that copying from webpages the string for ./mage install .... didn’t copy the double hypens in front of force properly.  I had to make sure they were actually both there, then the install worked.

Hope it helps.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top