Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

“Zend_Db_Adapter_Exception - max_user_connections “ (0.7.14800)
 
LapinLove404
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2007-11-04
 

Hello,

Since I installed the 0.7.14800 I often receive the below error message when loading pages from my site (both Front-end and Back-end).

Most of the time, I can simply hit reload to eventually load the page without error.

Any idea what would cause such error and how to fix it ?

exception 'Zend_Db_Adapter_Exception' with message 'SQLSTATE[42000] [1203] User db_username already has more than 'max_user_connections' active connections' in /home.27/c/o/l/colorful/www/lib/Zend/Db/Adapter/Pdo/Abstract.php:131
Stack trace
:
#0 /home.27/c/o/l/colorful/www/lib/Varien/Db/Adapter/Pdo/Mysql.php(91): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home.27/c/o/l/colorful/www/lib/Zend/Db/Adapter/Abstract.php(380): Varien_Db_Adapter_Pdo_Mysql->_connect()
#2 /home.27/c/o/l/colorful/www/lib/Zend/Db/Adapter/Pdo/Abstract.php(206): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#3 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(32): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8')
#4 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Resource.php(71): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#5 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Mysql4/Resource.php(35): Mage_Core_Model_Resource->getConnection('core_read')
#6 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Config.php(619): Mage_Core_Model_Mysql4_Resource->__construct(Array)
#7 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Config.php(645): Mage_Core_Model_Config->getModelInstance('core_mysql4/res...', Array)
#8 /home.27/c/o/l/colorful/www/app/Mage.php(316): Mage_Core_Model_Config->getResourceModelInstance('core/resource', Array)
#9 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Resource/Setup.php(101): Mage::getResourceModel('core/resource')
#10 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Resource/Setup.php(94): Mage_Core_Model_Resource_Setup->applyUpdates()
#11 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/Config.php(156): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#12 /home.27/c/o/l/colorful/www/app/code/core/Mage/Core/Model/App.php(135): Mage_Core_Model_Config->init(NULL)
#13 /home.27/c/o/l/colorful/www/app/Mage.php(390): Mage_Core_Model_App->init('base', NULL)
#14 /home.27/c/o/l/colorful/www/app/Mage.php(410): Mage::app('base', NULL)
#15 /home.27/c/o/l/colorful/www/index.php(29): Mage::run('base')
#16 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
LapinLove404
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2007-11-04
 

mmmhhh… seems that noone has an answer to this :-(

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsperri
Sr. Member
 
Total Posts:  126
Joined:  2007-08-31
Fistufle
 

As the error says, it looks like your server is getting too many connections on the mysql user account.
Are you on a dedicated box or shared environment ?
Is the mysql account that you setup for Magento used by other applications ?
What’s the value for max_connections in your mysql setup (my.cnf) can you try to increase it and restart mysql ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
LapinLove404
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2007-11-04
 

Hello jsperri,

Thanks for your answer.

So, it’s not directly related to Magento but rather to my mysql setup ?

I’am on a shared server and I can’t change the max_connections.

It’s currently at 3 - which may be a bit low. I can easily upgrade my service and get 10 max_connection.
Would that be enough for Magento ?

What seems strange to me is that this only happens since I installed ver 0.7.14800.
I had installed previous version on the same server and it worked like a charm.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top