Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
How do I add more than 1001 products to a category in the admin? 
 
Flaxton
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2010-06-03
Houston
 

<LocationMatch "shop/(index\.php/)?admin/">
    <
IfModule mod_php5.c>
    
php_value max_input_vars 100000
    
</IfModule>
</
LocationMatch>

What do I need to put if I am not using shop as the install directory?

I have magento installed to a domain.com/html and I am using symlinks to point there from three other domains on the same server in different directories.

I have tried

<LocationMatch "domain.com/html/(index\.php/)?admin/">
    <
IfModule mod_php5.c>
    
php_value max_input_vars 100000
    
</IfModule>
</
LocationMatch>

&

<LocationMatch "domain.com/(index\.php/)?admin/">
    <
IfModule mod_php5.c>
    
php_value max_input_vars 100000
    
</IfModule>
</
LocationMatch>

I just keep getting an internal server error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thotosch
Jr. Member
 
Total Posts:  2
Joined:  2010-10-18
 

Putting this code in the htaccess file also gives me an error 500.
The Apache log tells me:

<LocationMatch not allowed here

So when I remove the location match part of the code, it indeed works.
However, this denies the purpose of it being secure.

Anybody has a clue on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
thotosch
Jr. Member
 
Total Posts:  2
Joined:  2010-10-18
 

Putting this code in the htaccess file also gives me an error 500.
The Apache log tells me:

<LocationMatch not allowed here

So when I remove the location match part of the code, it indeed works.
However, this denies the purpose of it being secure.

Anybody has a clue on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
michael lehmkuhl
Jr. Member
 
Total Posts:  6
Joined:  2009-01-30
 

Flaxton,

If you’ve installed Magento in your document root directory, this would be what you’d use:

<LocationMatch "(index\.php/)?admin/">
    <
IfModule mod_php5.c>
    
php_value max_input_vars 100000
    
</IfModule>
</
LocationMatch>

Or maybe you’ve installed in a directory called “magento”:

<LocationMatch "magento/(index\.php/)?admin/">
    <
IfModule mod_php5.c>
    
php_value max_input_vars 100000
    
</IfModule>
</
LocationMatch>
 
Magento Community Magento Community
Magento Community
Magento Community
 
michael lehmkuhl
Jr. Member
 
Total Posts:  6
Joined:  2009-01-30
 

thotosch,

LocationMatch is not allowed in .htaccess. You’ll need to put it in your Apache server config or virtual host .conf files.

http://httpd.apache.org/docs/2.2/mod/core.html#locationmatch

 
Magento Community Magento Community
Magento Community
Magento Community
 
gazpach
Jr. Member
 
Total Posts:  2
Joined:  2014-02-10
 
symfony XIB - 20 March 2012 01:23 PM

Hi,

I’ve just found the explanation:
Since PHP version 5.3.9 , the function parse_str appears to be subject to the php.ini directive “max_input_vars”, which is 1000 by default.
The setting is changeable in php.ini, .htaccess or httpd.conf, but not during runtime.

See:
http://php.net/manual/en/info.configuration.php#ini.max-input-vars

this worked for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
christinavick
Guru
 
Total Posts:  355
Joined:  2013-11-13
 

Hi,

Have a look this thread for help [url=http://forum.azmagento.com/how-to/how-do-i-add-more-than-1001-products-to-a-category-in-the-admin-63-nbsp--81313.html]http://forum.azmagento.com/how-to/how-do-i-add-more-than-1001-products-to-a-category-in-the-admin-63-nbsp--81313.html[/url]

Hope this will help you!!

Thanks

iLoveMage

 
Magento Community Magento Community
Magento Community
Magento Community
 
naitsirch
Jr. Member
 
Total Posts:  1
Joined:  2010-07-22
 

LocationMatch not allowed in .htaccess files. It can only be used in server config or virtual host context.
See http://stackoverflow.com/questions/6663611/htaccess-locationmatch-server-error

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2