Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

[SOLVED - sort of… ] Blank admin pages and 500 errors on all catalog pages - Upgrade 1.1.8 to 1.2.0
 
squirrels
Sr. Member
 
Total Posts:  93
Joined:  2008-08-27
 

I did an upgrade from 1.1.8 to 1.2.0 using Magento Connect a couple of days ago and have tried to get it to work since then but not succeeded. I use the modern theme.

The front page works as does all sub pages that are either static or are not connected to the catalog (the log-in page, advanced search, contact us etc...)

But…

As soon as you click on a link to the catalog (my categories) or make a search for something in the catalog I get the following error:

Server error!

The server encountered an internal error and was unable to complete your request.

Error message:
Premature end of script headers: index.php

If you think this is a server error, please contact the webmaster.

Error 500

I also have a problem with the admin part, I get the log in page but after logging in I just get a blank page. I look at the url and it says:
http://www.mydomain.com/index.php/admin/dashboard/

If I change that into:
http://www.mydomain.com/index.php/admin/admin/dashboard/ I get a 404-error BUT I see all the menus and I can access all other admin pages but I can not make any changes (or rather I make the changes but when I click save it goes back to the way it was)
So it seems the dashboard url or the dashboard page itself that is wrong somewhere?
And there is something I need to correct with rights since something doesn’t seem to be writable?

I suppose that since I haven’t gotten that far on the site I should upgrade to 1.2.0.1 as soon as possible but I feel a bit put off using Magento Connect, can I do it manually and might this solve some of my problems?

 
Magento Community Magento Community
Magento Community
Magento Community
 
squirrels
Sr. Member
 
Total Posts:  93
Joined:  2008-08-27
 

Hmmm… After reading soe more on the forums I tried to fix this problem by emptying the var/cache and var/session folders but this has resulted in the entire site showing the Server error message described above (both front and admin).

I guess I should go through the permissions on all files and folders but my hosting company tells me I can’t do it automatically but have to do it manually(!). I’m thinking about downloading the entire site locally and then set permissions for files (755) and folders (644) in my ftp-program when I upload it again. Then there are some files and folders that need greater permissions but those I can set manually I guess.

 
Magento Community Magento Community
Magento Community
Magento Community
 
squirrels
Sr. Member
 
Total Posts:  93
Joined:  2008-08-27
 

Well… I kind of solved it by removing all the old files and uploading a new installation of Magento (version 1.2.0.1) I kept the old database so all my categories and other settings are still there.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top