Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Custom Module Installation
 
thx2000
Jr. Member
 
Total Posts:  4
Joined:  2008-01-02
 

I created a subclass to Mage_Catalog_Block_Navigation, and had it working in the previous release with a couple edits of local.xml, config.xml.  After an upgrade, this no longer works.

Moshe mentioned in his post entitled “Changes in 0.7.14800 for developers” that “Custom module declarations in separate files in app/etc/modules per namespace, distributor or package.  With this feature you won’t loose your module declarations with next upgrades by overwriting config.xml or local.xml”

What exactly does that mean?  Does anyone have any pointers for getting modules set up with this new method?

Thanks,

THX2000

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsperri
Sr. Member
 
Total Posts:  126
Joined:  2007-08-31
Fistufle
 

I think that just means you can declare your custom modules in your own XML files in app/etc/modules directory instead of modifying local.xml file.
This way it is easier to keep your new module setup when upgrading.

I can confirm it worked for me (0.7.14800)

 
Magento Community Magento Community
Magento Community
Magento Community
 
thx2000
Jr. Member
 
Total Posts:  4
Joined:  2008-01-02
 

Turns out my problem was an upgrade to 0.7.14800 had, for some reason, reset my default root category and so my additions weren’t functioning properly.  This method, however, is much better for adding code.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top