Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 4 of 4
[SOLVED!] Search on front end returns no results after upgrade 1.1.8 to 1.2.01
 
elvar
Member
 
Total Posts:  59
Joined:  2009-01-30
 

One cent from me for the topic.

I did everything - attribute dropdown exluded, cache cleare, index rebuilded, search terms deleted (I cried when I did that) but nohting.

No error logs nothing.

And luckily one app Automatic Sale Category from MeanBee for installing and using said:
\\\’Please ensure that the \\\’Is Anchor\\\’ setting on the root category of each store is set to \\\’Yes\\\’\\\’

When I did that (and my root category is just for root - not visible hence there was not Yes in IsAnchor attribute) everything worked!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
orangify
Jr. Member
 
Total Posts:  2
Joined:  2012-05-10
 

You must remove the “/app/design/frontend/default/bluedepth/layout/catalogsearch.xml” file( and magento will use the default catalogsearch.xml ) or add the following code into <catalogsearch_result_index> tag of catalogsearch.xml( in the blue depth theme layout):

<reference name="left">
            <
block type="catalogsearch/layer" name="catalogsearch.leftnav" after="currency" template="catalog/layer/view.phtml"/>
        </
reference>

This solve the problem of minisearch.

I’m using Magento 1.7

- Alex -

 
Magento Community Magento Community
Magento Community
Magento Community
 
TarasMK
Jr. Member
 
Total Posts:  2
Joined:  2012-09-15
 
elvar - 01 January 2012 08:41 AM

And luckily one app Automatic Sale Category from MeanBee for installing and using said:
\\\’Please ensure that the \\\’Is Anchor\\\’ setting on the root category of each store is set to \\\’Yes\\\’\\\’

Thanks a lot!!! That was the cause in my case too!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 4 of 4