Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
HTML in Product Descriptions broken after 1.2.0.1 Upgrade
 
sktung
Jr. Member
 
Total Posts:  15
Joined:  2008-09-25
 

Was working perfect on 1.1.8. After upgrade (using Modern theme), the PRODUCT DESCRIPTION tab still displays HTML correctly, but all the boxes in the ADDITIONAL INFORMATION tab display the complete HTML code as one long continuous line.

This is very critical for our store - anyone know a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 

ops… same here…

oh my god, lots of pdf file icon now converted in lines of html code.... :-(

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

From the activecodeline.com blog:

Open the following file

/app/code/core/Mage/Catalog/Block/Product/View/Attributes.php

Now on line 71 you will see the following code

$value $this->htmlEscape($value);

Just replace it with

$value $value;
 
Magento Community Magento Community
Magento Community
Magento Community
 
harry12bar
Sr. Member
 
Avatar
Total Posts:  168
Joined:  2008-01-07
 
skippybosco - 31 December 2008 06:54 AM

From the activecodeline.com blog:

Open the following file
/app/code/core/Mage/Catalog/Block/Product/View/Attributes.php

Now on line 71 you will see the following code
$value $this->htmlEscape($value);

Just replace it with
$value $value;

WORKS A TREAT!!!!!!!

HAPPY NEW YEAR YODA CODER wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiaraweb
Guru
 
Avatar
Total Posts:  721
Joined:  2008-03-21
Aviano ~ Italy
 

GREAT! IT WORKS!!

MANY THANKS!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 

Thank you very much for solution.

Has anybody reported this as an issue to the bugtracker? Why this option has been changed?

Happy New Year!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rodolfo_Oliveira
Jr. Member
 
Total Posts:  22
Joined:  2008-11-19
 

Thanks for solution!

 
Magento Community Magento Community
Magento Community
Magento Community
 
andreladocruz
Guru
 
Total Posts:  322
Joined:  2008-05-07
Brazil
 

thanks…

works for me too.

regards.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thavoc
Jr. Member
 
Total Posts:  3
Joined:  2009-01-06
 

Works for me too, GJ!

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

This bug was the result of v1.2.0. And in v1.2.0.1 it was closed as ‘resolved’, yet I am still seeing it in the v12.0.2.  cool mad

 
Magento Community Magento Community
Magento Community
Magento Community
 
roco
Sr. Member
 
Total Posts:  191
Joined:  2008-03-18
 

Thanks for the tip.  Can I ask what happens the next time I try to use the downloader?  Will it choke or fail because the “core” has been modified?  I have not modified the core before and am not familiar with how this affects upgrades.

 
Magento Community Magento Community
Magento Community
Magento Community
 
toujour
Jr. Member
 
Total Posts:  5
Joined:  2009-01-08
 

thank u....

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 

Since this line doesn’t actually do anything:

$value $value;
...it would make more sense to comment out the line that causes the problem

(just being fussy)

Also, I noted that this newer bug report is showing as ‘assigned’:
http://www.magentocommerce.com/bug-tracking/issue?issue=4856
(it was a good idea that the person found the problem on the demo store)

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

it doesn’t look like Vairen wants it fix. I upgraded to v1.2.1, and have updated all phtml/xml files dated back to v1.1.8, still I am seeing the same thing.

How annoying!  >:(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 
chinesedream - 03 February 2009 06:28 PM

it doesn’t look like Vairen wants it fix. I upgraded to v1.2.1, and have updated all phtml/xml files dated back to v1.1.8, still I am seeing the same thing.

How annoying!  >:(

With quite a lot of bug reports in the system and new ones getting added I guess they have to choose and prioritise which ones will be dealt with in a particular release.  It was probably not viewed as a critical issue, and as a result they didn’t want to hold up the 1.2.1 release for it.

I’m sure it will be included in the first release after the issue has been fixed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
antcommerce
Jr. Member
 
Total Posts:  19
Joined:  2008-05-06
the Netherlands
 

If i’m correct there is no need to change any code, just an admin setting.

The above-mentioned line in /app/code/core/Mage/Catalog/Block/Product/View/Attributes.php is preceded by elseif (!$attribute->getIsHtmlAllowedOnFront())

The attribute setting of getIsHtmlAllowedOnFront has apparently been handled in the bugfix below since v1.2.1. I solved this problem by going to Admin > Catalog > Attributes > Manage atributes, select the attribute with the HTML code and set the option ‘Allow HTML-tags on Front-end’ to YES.

Fixed #9899: Attribute with URL displays HTML code (Added “Allowed HTML-tags on Front-end” option to attribute)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4