Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Installationsanleitung Magento auf Strato Server
 
Holger.Gross
Jr. Member
 
Total Posts:  1
Joined:  2009-08-23
 

Mein Versuch einen Magento Shop auf einem Strato Server zu installieren (Managed Server SX-7 (V.10.4)) hat mich einige Abende, viel Nerven und vor allem jede Menge Recherche im Internet gekostet. Leider bin ich nie auf eine Seite gestossen, die die diversen Probleme bei der Installation aufzeigte und Lösungen für die dadurch auftretenden Fehlermeldungen gab.

Fehler wie z.B. der “500 Internal Server Error” oder “503 Service Unavailable” haben mich fast den letzten Nerv gekostet. Aber den diversen Internetforen sei Dank und durch tüchtig Experimentieren habe ich die Versionen Magento 1.5.1, Magento 1.6.1 und Magento 1.6.2 zum Laufen gebracht. Ich möchte Euch meine Lösung der Probleme nicht vorenthalten.

Hier mein Rezept zur Magento Installation auf einem Strato Server:

Installationsanleitung Magento auf Strato Server

 
Magento Community Magento Community
Magento Community
Magento Community
 
ds_1984
Mentor
 
Avatar
Total Posts:  3116
Joined:  2008-12-09
Potsdam, Germany
 

- Der 500er Error kommt von einer falscher Vorkonfiguration von fastcgi seitens Strato.
- Normalerweise ist es im Modus fastcgi/PHP nicht nötig noch extra Rechte zuzuweisen,
da bereits der Webuser der ausführende Owner der PHP Skripte ist, die gemachte Konfiguration funktioniert zwar,
dessen Grund (ebenfalls wahrscheinlich falsche Vorkonfiguration von Seiten des Providers) verstehe ich aber nicht.

- PHP 5.2.17 vs. 5.3:
Ab Magento 1.4 sollte es keine Fehlermeldungen mehr geben - wenn dann kommen diese wohl eher davon das APC nicht kompatibel mit dem Zend Optimizer ist (falls diese zusammen laufen). Des Weiteren hat Strato wohl nicht das überempfindliche Error Reporting unter PHP 5.3 gefixt, was man tun sollte. Sondern schlicht wie alle Massenhoster das Standard PHP Build bereit gestellt. Ich rate aber aus 2 Gründen trotzdem zu einer PHP 5.3er Version wenn Error frei: 1. Signifikante Performance Unterschiede zu PHP 5.2.x (die interne Ausführung von PHP ist an sich schneller geworden ab 5.3, gerade bei Funktionsausführungen wie bei Magento andauernd, macht das schon Unterschiede) - 2. PHP 5.2.17 war das letzte Sicherheits- und Stabilitäts Release für den 5.2.x Zweig, es wird davon keine Aktualisierungen mehr geben. Es wird offiziell von der PHP Group nicht mehr unterstützt und gilt als veraltet.

Trotzdem:
- Vielen Dank für deinen sehr detaillierten Beitrag und somit Erfahrungsaustausch.
- Einige Kunden von mir besitzen ähnliche Umgebungen auf denen Magento laufen soll,
von daher sehr brauchbar dein schönes Tutorial für einen Strato Server, gerade mit den ganzen Screenshoots der einzelnen Schritte!  grin

LG - Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top