Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Secure Urls not working when checking out
 
pixelpusher
Sr. Member
 
Avatar
Total Posts:  135
Joined:  2008-04-23
SoCal
 

@ stephan

change your “current configuration scope” to the store level and use the same values you have in your “default config” scope.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pixelpusher
Sr. Member
 
Avatar
Total Posts:  135
Joined:  2008-04-23
SoCal
 

This issue seems to have been resolved in 1.2.0.2

 
Magento Community Magento Community
Magento Community
Magento Community
 
fastboxgaming
Sr. Member
 
Avatar
Total Posts:  101
Joined:  2008-10-11
 

Kind of dissapointing that’s the only bug fixed in 1.2.0.2, when many people are experiencing several bugs including users not able to edit information from the frontend on certain templates, not able to add a role(a temperary solution is available), some payment options not working(protx and maybe more i’m not sure). But this is a step in the right direction.

 
Magento Community Magento Community
Magento Community
Magento Community
 
AngelEyes
Member
 
Total Posts:  74
Joined:  2008-02-25
 

I am having this exact same issue in 1.1.8.

Once I get into a secure checkout area, when I come out the whole site remains secure, except if i go to the cart which then reverts everything back to normal.

Any ideas?

Thanks.

Adam

 
Magento Community Magento Community
Magento Community
Magento Community
 
lunchboxcollective.com
Jr. Member
 
Total Posts:  5
Joined:  2009-02-23
 

The process below works. I simply unchecked “Use Default” and “Use Website” on every setting and now without any htaccess tricks the Use Secure URL’s on Frontend works where necessary (account, checkout, etc) and reverts to http where applicable (in catalog, etc). Provided you have an SSL cert of course.

Our store hierarchy is the demo store hierarchy.

Default Config
>Main Website (uncheck Use Default on all in both secure/unsecure)
>>Storename
>>>English (uncheck Use Website on all on all in both secure/unsecure)
>>>French (uncheck Use Website on all on all in both secure/unsecure)
>>>German (uncheck Use Website on all on all in both secure/unsecure)

Ensure Unsecure base url is http:// on all stores, clear cache, test front end. Works beautifully, though I wasted almost an hour trying to do it with an htaccess rewrite.

-Tom

eagleeyed - 03 January 2009 12:46 PM

EDIT: Hmmm, just saw Vadmic’s post, sorry, beat me too it.

Ok, everyone, have tested this a couple of times, and on separate installations, and I think I have found the problem and the cause.

The Varien Team Member did say how to fix it, but did not list all the steps.

To Get SSL enabled:

1. Go into your admin.
2. System and then configuration.
3. Go onto the ‘Web’ page.
4. Put your full secure link in both Secure URL and Secure Link URL.  eg. (https://www.yourdomainname.com/)
5. Copy and paste your secure name in full, as you will need it again.
6. On the same page make sure ‘Use Secure URLs in Frontend’ is enabled.  This will NOT enable SSL yet.
7. This is also very important, make sure your full Unsecure URL is where it is supposed to be in the Unsecure section.  If it is not your site will remain in SSL.
8. Click ‘Save Config’
9.For Current Configeration scope select your default store view.  If you have multiple store views you will have to do this for all of them.  These instructions presume you are using only one.
10. UNCHECK ‘Use Website’ next to the following three items: Base URL, Base Link URL and Use Secure URL’s in Frontend.

They must be unchecked as a bug in the current version is preventing it getting the settings from the website.

11. Paste the full secure URL (that I asked you to copy on Step 5) into both Base URL and Base LInk URL.
12. Make sure Use Secure URL’s in Frontend is set to yes.
13. Under ‘Unsecure’ make sure your Unsecure URL is in base link, else your site will remain secure on every single page.
14. Click ‘Save Config’
15. You should not have secure URL’s enabled for your website.  If not try deleting the cache folder.

As said, the cause of this problem as the Varien team member seemed to have figured out before in a earlier post, is that the Store configeration is not able to get the settings from the website, thereby unable to know your SSL address.

I also dont know why there are two Base URL things, one with Link in the name.

Hopefully this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lunchboxcollective.com
Jr. Member
 
Total Posts:  5
Joined:  2009-02-23
 

@pixelpusher

We’re running 1.2.1.2 and it wasn’t working until I made the changes in my previous post.

pixelpusher - 12 January 2009 01:05 PM

This issue seems to have been resolved in 1.2.0.2

 
Magento Community Magento Community
Magento Community
Magento Community
 
wolfdog85
Jr. Member
 
Total Posts:  12
Joined:  2008-09-29
Biloxi, MS, USA
 

this solution doesn’t work for me in 1.2.1.2 any ideas? I am running multiple stores in the same website with different domains and it is reverting back to the default store that is specified in the manage stores config for the main website.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bizz
Jr. Member
 
Total Posts:  25
Joined:  2008-12-03
 
eagleeyed - 03 January 2009 12:46 PM

EDIT: Hmmm, just saw Vadmic’s post, sorry, beat me too it.
To Get SSL enabled:

1. Go into your admin.
2. System and then configuration.
3. Go onto the ‘Web’ page.
4. Put your full secure link in both Secure URL and Secure Link URL.  eg. (https://www.yourdomainname.com/)
5. Copy and paste your secure name in full, as you will need it again.
6. On the same page make sure ‘Use Secure URLs in Frontend’ is enabled.  This will NOT enable SSL yet.
7. This is also very important, make sure your full Unsecure URL is where it is supposed to be in the Unsecure section.  If it is not your site will remain in SSL.
8. Click ‘Save Config’
9.For Current Configeration scope select your default store view.  If you have multiple store views you will have to do this for all of them.  These instructions presume you are using only one.
10. UNCHECK ‘Use Website’ next to the following three items: Base URL, Base Link URL and Use Secure URL’s in Frontend.

They must be unchecked as a bug in the current version is preventing it getting the settings from the website.

11. Paste the full secure URL (that I asked you to copy on Step 5) into both Base URL and Base LInk URL.
12. Make sure Use Secure URL’s in Frontend is set to yes.
13. Under ‘Unsecure’ make sure your Unsecure URL is in base link, else your site will remain secure on every single page.
14. Click ‘Save Config’
15. You should not have secure URL’s enabled for your website.  If not try deleting the cache folder.

Using 1.2.0.1 this worked perfectly for me, thanks!
does anyone know if this has been resolved in 1.3.0?

thanks again eagleeyed

 
Magento Community Magento Community
Magento Community
Magento Community
 
ModifyMage
Sr. Member
 
Avatar
Total Posts:  84
Joined:  2008-10-15
 
eagleeyed - 03 January 2009 12:46 PM

EDIT: Hmmm, just saw Vadmic’s post, sorry, beat me too it.

Ok, everyone, have tested this a couple of times, and on seperate installations, and I think I have found the problem and the cause.

The Varien Team Member did say how to fix it, but did not list all the steps.

To Get SSL enabled:

1. Go into your admin.
2. System and then configuration.
3. Go onto the ‘Web’ page.
4. Put your full secure link in both Secure URL and Secure Link URL.  eg. (https://www.yourdomainname.com/)
5. Copy and paste your secure name in full, as you will need it again.
6. On the same page make sure ‘Use Secure URLs in Frontend’ is enabled.  This will NOT enable SSL yet.
7. This is also very important, make sure your full Unsecure URL is where it is supposed to be in the Unsecure section.  If it is not your site will remain in SSL.
8. Click ‘Save Config’
9.For Current Configeration scope select your default store view.  If you have multiple store views you will have to do this for all of them.  These instructions presume you are using only one.
10. UNCHECK ‘Use Website’ next to the following three items: Base URL, Base Link URL and Use Secure URL’s in Frontend.

They must be unchecked as a bug in the current version is preventing it getting the settings from the website.

11. Paste the full secure URL (that I asked you to copy on Step 5) into both Base URL and Base LInk URL.
12. Make sure Use Secure URL’s in Frontend is set to yes.
13. Under ‘Unsecure’ make sure your Unsecure URL is in base link, else your site will remain secure on every single page.
14. Click ‘Save Config’
15. You should not have secure URL’s enabled for your website.  If not try deleting the cache folder.

As said, the cause of this problem as the Varien team member seemed to have figured out before in a earlier post, is that the Store configeration is not able to get the settings from the website, thereby unable to know your SSL address.

I also dont know why there are two Base URL things, one with Link in the name.

Hopefully this helps.

Worked like a charm in version 1.2.1.2.  Finally.  rasberry

And now all the <img src="{{skin url="images/really_cool_picture.jpg"}}" > CMS links work properly, too.

Thank you eagleeyed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jonny98002
Jr. Member
 
Total Posts:  27
Joined:  2009-02-16
 

Bump This!  I have been scouring the forums for a solution, and this worked perfectly!

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaginasWebdotPE
Member
 
Avatar
Total Posts:  46
Joined:  2008-10-22
Lima, Peru - Miami, USA
 

hello,

thanks, it works, but i have one issue,

https://www.cosasperuanas.com works, but https:cosasperuanas.com does not (note the www), it does not happen with the unsecure pages (both works, with and without www), any advise?

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaginasWebdotPE
Member
 
Avatar
Total Posts:  46
Joined:  2008-10-22
Lima, Peru - Miami, USA
 

here the answer:
A RapidSSL certificate is only valid for one host. www.cosasperuanas.com is a different host than cosasperuanas.com. We setup the certificate to work for the host www.cosasperuanas.com so trying to connect to your site by visiting https://cosasperuanas.com will give you a certificate error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
webscot
Sr. Member
 
Total Posts:  192
Joined:  2009-05-12
 

If anyone actually has a current 2011 solution that might work for this problem in 1.4.1.1, we would really appreciate it.

We have the exact same problem as originally posted in this thread.

Quite frankly it has become so tiring to have to FIGHT with every frickin’ step with this software.

We have tried all the different .htaccess convolutions we could fine; unchecking every box in the base and secure urls in store hierarchy; we have tested direct https URLs to actual CSS files and those work just fine; and, NOTHING is working to allow logging in, checking out, etc.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redlights
Jr. Member
 
Total Posts:  15
Joined:  2011-03-02
 

Hi webscot,

i’m using 1.4.1.1 also and i have the same problem, have tried everything above, but when i click “proceed to check out” it shows the following error:

“Not Found
The requested URL /home/myuser/www/index.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

If found any solutions please share!

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
webscot
Sr. Member
 
Total Posts:  192
Joined:  2009-05-12
 

I have seen mention of your problem in the forums before. Search for “shared SSL 404” and you should find some other possible solutions.

Our problem was actually a bit different. It has been solved.

Turns out nginx wasn’t passing the _SERVER["HTTPS"]=on paramter to php. Our host admin was able to fix this.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top