Magento Forum

Page 2 of 4
Secure Urls not working when checking out
 
andreladocruz
Guru
 
Total Posts:  322
Joined:  2008-05-07
Brazil
 

friends,

I just found that there is a logical error on configuration.

when you mark TO NOT USE https on frontend it does and when you set TO USE it goes without https.

let´s see what happens next.

regards.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vadimc
Sr. Member
 
Avatar
Total Posts:  87
Joined:  2008-10-25
London
 
YoavKutner - 31 December 2008 11:37 AM

The issue seems to be with the default store only.

What works for me right now is to change the scope in the configuration to your default store view and change the configuration for ‘Use Secure URLs in Frontend’ to yes.

That should enable the secure URL’s again.

We are looking into this issue deeper and will post any updates on this.

Thanks

yoav

this worked for me, thank you very much! after the upgrade the Base URL had the value of {{base_url}}, so i changed it to my actual secure url :https://www.mydomain.com/

 
Magento Community Magento Community
Magento Community
Magento Community
 
eagleeyed
Member
 
Total Posts:  32
Joined:  2008-08-21
 

EDIT: Hmmm, just saw Vadmic’s post, sorry, beat me too it.

Ok, everyone, have tested this a couple of times, and on seperate installations, and I think I have found the problem and the cause.

The Varien Team Member did say how to fix it, but did not list all the steps.

To Get SSL enabled:

1. Go into your admin.
2. System and then configuration.
3. Go onto the ‘Web’ page.
4. Put your full secure link in both Secure URL and Secure Link URL.  eg. (https://www.yourdomainname.com/)
5. Copy and paste your secure name in full, as you will need it again.
6. On the same page make sure ‘Use Secure URLs in Frontend’ is enabled.  This will NOT enable SSL yet.
7. This is also very important, make sure your full Unsecure URL is where it is supposed to be in the Unsecure section.  If it is not your site will remain in SSL.
8. Click ‘Save Config’
9.For Current Configeration scope select your default store view.  If you have multiple store views you will have to do this for all of them.  These instructions presume you are using only one.
10. UNCHECK ‘Use Website’ next to the following three items: Base URL, Base Link URL and Use Secure URL’s in Frontend.

They must be unchecked as a bug in the current version is preventing it getting the settings from the website.

11. Paste the full secure URL (that I asked you to copy on Step 5) into both Base URL and Base LInk URL.
12. Make sure Use Secure URL’s in Frontend is set to yes.
13. Under ‘Unsecure’ make sure your Unsecure URL is in base link, else your site will remain secure on every single page.
14. Click ‘Save Config’
15. You should not have secure URL’s enabled for your website.  If not try deleting the cache folder.

As said, the cause of this problem as the Varien team member seemed to have figured out before in a earlier post, is that the Store configeration is not able to get the settings from the website, thereby unable to know your SSL address.

I also dont know why there are two Base URL things, one with Link in the name.

Hopefully this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
turbo1
Sr. Member
 
Avatar
Total Posts:  296
Joined:  2008-08-19
Los Angeles, CA
 

@eagleeyed
Thank you for the post.  I do have to ask myself though why on earth SSL broke in 1.2.0. Didn’t they test that?  Why do I have to change configurations to get it to work now.. I’m just really soured on the whole 1.2.0.x grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
vadimc
Sr. Member
 
Avatar
Total Posts:  87
Joined:  2008-10-25
London
 
turbo1 - 04 January 2009 08:55 AM

@eagleeyed
Thank you for the post.  I do have to ask myself though why on earth SSL broke in 1.2.0. Didn’t they test that?  Why do I have to change configurations to get it to work now.. I’m just really soured on the whole 1.2.0.x grin

hehe, its just natural to make mistakes mate. do not forget that we had Christmas and New Year holidays when i bet most of us were drinking and celebrating, so its still well done to Magento team for doing what they do smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
eagleeyed
Member
 
Total Posts:  32
Joined:  2008-08-21
 
turbo1 - 04 January 2009 08:55 AM

@eagleeyed
Thank you for the post.  I do have to ask myself though why on earth SSL broke in 1.2.0. Didn’t they test that?  Why do I have to change configurations to get it to work now.. I’m just really soured on the whole 1.2.0.x grin

No probs, and I dont know why that was not tested.

I have just found another issue with this release, going to do a thread about it now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vadimc
Sr. Member
 
Avatar
Total Posts:  87
Joined:  2008-10-25
London
 

removed

 
Magento Community Magento Community
Magento Community
Magento Community
 
N Lopez
Sr. Member
 
Total Posts:  94
Joined:  2008-06-16
 

EDIT: Hmmm, just saw Vadmic’s post, sorry, beat me too it.

Ok, everyone, have tested this a couple of times, and on seperate installations, and I think I have found the problem and the cause.

The Varien Team Member did say how to fix it, but did not list all the steps.

To Get SSL enabled:

1. Go into your admin.
2. System and then configuration.
3. Go onto the ‘Web’ page.
4. Put your full secure link in both Secure URL and Secure Link URL.  eg. (https://www.yourdomainname.com/)

I was trying this but I selected “Use Secure URLs in Admin Panel” and I can not access my Admin Panel because it gets redirected to: https://www.mydomain.com/admin and I have a “page not found” error. How can I disable this without having the admin panel?

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

I was trying this but I selected “Use Secure URLs in Admin Panel” and I can not access my Admin Panel because it gets redirected to: https://www.mydomain.com/admin and I have a “page not found” error. How can I disable this without having the admin panel?

You can fix this by editing the codes manually in the database. You can change these setting in the core_config_data table in your Magento database.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ASchroder
Member
 
Avatar
Total Posts:  49
Joined:  2008-10-09
New Zealand
 

I noticed a few people were having trouble with this when upgrading to Magento 1.2.0.1. I went through and fixed it myself and have documented what I did on my blog. I have included screenshots so if anyone is having trouble with the instructions, it might help to have a look.

 
Magento Community Magento Community
Magento Community
Magento Community
 
TanRambun
Sr. Member
 
Avatar
Total Posts:  93
Joined:  2008-11-16
Bangkok, Thailand
 
YoavKutner - 31 December 2008 11:37 AM

The issue seems to be with the default store only.

What works for me right now is to change the scope in the configuration to your default store view and change the configuration for ‘Use Secure URLs in Frontend’ to yes.

For me the solution of YoavKutner solves the problem. SSL is working again in the default store. It did not break in the other stores after upgrading.

 
Magento Community Magento Community
Magento Community
Magento Community
 
envisionweb
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-11-16
Orlando, FL
 

ok ASchroder.com’s thorough explanation outlined on his link solved my problem. Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rise Creative Group
Jr. Member
 
Total Posts:  4
Joined:  2009-01-11
 

Hi all, I’m still not able to get the SSL certificate working with my setup. Now every time I check for the system to use secure SSL on the front end and try to access the checkout page, it goes to the main page of the store instead of the one page checkout.

Any thoughts?

Thanks!

Stephan Barrett

 
Magento Community Magento Community
Magento Community
Magento Community
 
speedygolf
Jr. Member
 
Total Posts:  14
Joined:  2008-12-11
 

post by eagleeyed

worked for me..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rise Creative Group
Jr. Member
 
Total Posts:  4
Joined:  2009-01-11
 

I’m still having an issue. It did work for a second, then nothing. What is the protocol and making admin changes then testing? Do I need to empty the cache folder each time?

I have attached screenshots of the settings. These settings are still causing the cart to go back to the main store page when trying to go to checkout on the SSL layer. Works with non SSL.

Thanks!

Stephan

Image Attachments
magento_config.png
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 4