Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Secure Urls not working when checking out
 
gadgetsdirect
Jr. Member
 
Total Posts:  21
Joined:  2008-09-06
 

When checking out, the software stays in unsecure more.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xrussx
Member
 
Total Posts:  54
Joined:  2008-11-24
 

I am having this issue. I just upgraded to 1.2.0.1 and I disabled the front-end secure url and then re-enabled the front-end secure url’s and it didn’t re-enable them.

I went back to 1.1.8

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

Same problem here. secure URL is not working on the front end. However, it is working on the back end. I upgraded from 1.1.8 to 1.2.0.1.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

Has anybody find out how to fix this issue? This is pretty important since checkout process will not process transactions with unsecured URLs.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xrussx
Member
 
Total Posts:  54
Joined:  2008-11-24
 

Here is a bug report that was opened yesterday

http://www.magentocommerce.com/bug-tracking/issue?issue=4609

 
Magento Community Magento Community
Magento Community
Magento Community
 
turbo1
Sr. Member
 
Avatar
Total Posts:  296
Joined:  2008-08-19
Los Angeles, CA
 

You guys are absolutely right - SSL is broken on the front end in 1.2.0.1. Anyone running a production site, DO NOT UPGRADE TO 1.2.0.1! It’s a violation of many credit card processor’s terms to not use SSL.

Can anyone confirm if 1.2.0 also had this issue?  Blah..  shut eye

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

I think many (including me) has already updated the production site, since this was not very visibile on test site after testing for a day. If anyone has any solution on how to fix this please post here. Thank you to all.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

Here is a work around to fix this problem for now:
Go to System-> Configuration -> General -> Web.
Make sure you go down to the Store level in “Current Configuration Scope”.

Under Secure section, uncheck the “Use Website” for “Base URL” and enter your full secure website: https://www.domain.com/
Remember to include the / at the end.

 
Magento Community Magento Community
Magento Community
Magento Community
 
turbo1
Sr. Member
 
Avatar
Total Posts:  296
Joined:  2008-08-19
Los Angeles, CA
 

Bumping this to the top because people need to see this and it needs to be addressed!

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

we are looking into this issue

Thanks

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

The issue seems to be with the default store only.

What works for me right now is to change the scope in the configuration to your default store view and change the configuration for ‘Use Secure URLs in Frontend’ to yes.

That should enable the secure URL’s again.

We are looking into this issue deeper and will post any updates on this.

Thanks

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
turbo1
Sr. Member
 
Avatar
Total Posts:  296
Joined:  2008-08-19
Los Angeles, CA
 

Thank you for the update.  grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
thomasmore
Sr. Member
 
Total Posts:  80
Joined:  2008-10-21
 

Doesn’t this problem exist in 1.1.8 as well? I could not get frontend SSL to work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 
thomasmore - 31 December 2008 02:48 PM

Doesn’t this problem exist in 1.1.8 as well? I could not get frontend SSL to work.

No, this was working fine in 1.1.8

 
Magento Community Magento Community
Magento Community
Magento Community
 
turbo1
Sr. Member
 
Avatar
Total Posts:  296
Joined:  2008-08-19
Los Angeles, CA
 

This is not resolved.. the frontend was already set to use SSL, just as it always had been. And the other suggested fix didn’t help either- it makes EVERYTHING ssl once you are on a secure page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
eagleeyed
Member
 
Total Posts:  32
Joined:  2008-08-21
 

Hey YoavKutner.

I tried your solution, and unfortunately it has not worked on my end.  I did do all the usual things including browser clear and refresh, clear cache etc (which seems to still be working even though I turned cache off, will investigate that now and do a bug report if cache is also having probs)..

Glad to hear you are looking into it though, good luck, and if you need to use a customer account to try experiencing this problem PM me for a seperate ftp and magento login, no customer details on this server so safe.

By the way, I am using a fresh install, fresh database etc.

Good luck, and Happy New Year for everyone.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4