Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

ssl certificate error / FASTCGI error duplicate header ‘Status’
 
hermz
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2008-01-17
 

Hello everybody,
i managed it to install magento offline on WAMP and online on our website.
i can reach the frontend, but the admin panel can’t be reached after installation:

http://www.hermann-radsport.li/magentobeta/admin

Frontend:
http://www.hermann-radsport.li/magentobeta/

in my apachelog i can see this:
FastCGI: comm with server “/var/webs/www.hermann-radsport.li/php5/php” aborted: error parsing headers: duplicate header ‘Status’,

i dint install magento as a cgi or fastcgi - i just enabled mod_rewrite in my hosting control center, my htaccess looks like this:

############################################
## uncomment these lines for CGI mode

#Action php5-cgi /cgi-bin/php-cgi 
#AddHandler php5-cgi .php

############################################
## default index file

#DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## disable magic quotes for php request vars

#php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

#php_flag short_open_tag on

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

#SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    #Options +FollowSymLinks 
    
RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

    #RewriteBase /magentobeta/

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php

</IfModule>

Order allow,deny
Allow from all

Anyone knows what’s the matter?

I’ve atched you a zip with my upcoming install-guide - hopefully one day i can release this working....
PHP INFO’s:
magentofolder:

http://www.hermann-radsport.li/magentobeta/phpinfo.php

rootfolder:

http://www.hermann-radsport.li/phpinfo.php

noticed the server API difference.....but i don’t know what todo......

Image Attachments
SSL_Zertifikat_error.jpg
File Attachments
magento_guide_0.7.14800.zip  (File Size: 270KB - Downloads: 69)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi hermz,

It looks like for some reason that magentobeta folder is served with FastCGI PHP, instead of mod_php (like your root folder).

Could you please make sure that you have exactly the same .htaccess as you posted here, and there were no other modifications done for magentobeta folder in you control panel or in httpd.conf file.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top