Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.1.8 to 1.2.0 upgrade issue
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

I’m trying to upgrade 1.1.8 to 1.2.0 via Magento Connect but I’m getting the following error message:

magento-core/mage_all_latest requires package "magento-core/Interface_Adminhtml_Default" (version >= 1.1.6version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Interface_Adminhtml_Default cannot be installedconflicts with installed packages
magento
-core/mage_all_latest requires package "magento-core/Interface_Frontend_Default" (version >= 1.1.5version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/interface_frontend_default_default_blue requires package "magento-core/Interface_Frontend_Default" (version >= 1.1.4version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Interface_Frontend_Default cannot be installedconflicts with installed packages
magento
-core/mage_all_latest requires package "magento-core/Interface_Install_Default" (version >= 1.1.3version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Interface_Install_Default cannot be installedconflicts with installed packages
magento
-core/mage_core_modules requires package "magento-core/Lib_Google_Checkout" (version >= 1.1.1version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Lib_Google_Checkout cannot be installedconflicts with installed packages
magento
-core/mage_core_modules requires package "magento-core/Lib_Js_Mage" (version >= 1.1.3version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Lib_Js_Mage cannot be installedconflicts with installed packages
magento
-core/lib_js_mage requires package "magento-core/Lib_Js_Prototype" (version >= 1.1.3version <= 1.1.3), downloaded version is 1.2.0
magento
-core/mage_core_modules requires package "magento-core/Lib_Js_Prototype" (version >= 1.1.3version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Lib_Js_Prototype cannot be installedconflicts with installed packages
magento
-core/mage_core_modules requires package "magento-core/Lib_Varien" (version >= 1.1.3version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Lib_Varien cannot be installedconflicts with installed packages
magento
-core/lib_varien requires package "magento-core/Lib_ZF" (version >= 1.1.1version <= 1.2excluded versions1.2), downloaded version is 1.7.2
magento
-core/Lib_ZF cannot be installedconflicts with installed packages
magento
-core/lib_zf requires package "magento-core/Lib_ZF_Locale" (version >= 1.1.1version <= 1.2excluded versions1.2), downloaded version is 1.7.2
magento
-core/Lib_ZF_Locale cannot be installedconflicts with installed packages
magento
-core/interface_adminhtml_default requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.1.8version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/mage_all_latest requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.1.8version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Mage_Core_Adminhtml cannot be installedconflicts with installed packages
magento
-core/mage_all_latest requires package "magento-core/Mage_Downloader" (version >= 1.1.1version <= 1.2excluded versions1.2), downloaded version is 1.2.0
magento
-core/Mage_Downloader cannot be installedconflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR
upgrade failed

I don’t know what packages this means, but I don’t have any additional extensions installed on my store. Any idea?

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

It does not appear that Connect has updated core to 1.2, which is a pre-requisite for the others..

I did my upgrade off of the 1.2-trunk branch

Obviously back up files/db and to a non-production environment until tested.

 
Magento Community Magento Community
Magento Community
Magento Community
 
laserbeam
Jr. Member
 
Total Posts:  28
Joined:  2008-07-31
 

I’ve tried to avoid to use the Magento Connect Manager for the upgrading since it’d never worked for me for last a couple of major upgradings.  It always messed up with the system and you’re never able to browse or log into your admin after upgrading.

The best way to upgrade to newer version is to download the full package and upload it to the server after you’ve deleted the old one and then go the the home page to restart the system (you need to remember your old user name/password, as well as the database settings to get the system restore to working condition since you will be asked to enter these during the setup).  It works well since your database is still there and all you need to do is keep all custom files in the media directory on the server from the old one.

 
Magento Community Magento Community
Magento Community
Magento Community
 
snowdog
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-01-22
Poznan, Poland
 

I had the same issue when tried to install all upgrades from Connect, finished with fatal error.

On the second store I installed ONLY Mage_All_Latest and this time upgrade was smooth and quick (other upgrades installed automatically).

 
Magento Community Magento Community
Magento Community
Magento Community
 
zadpro
Sr. Member
 
Avatar
Total Posts:  247
Joined:  2007-12-10
FL, USA
 

I had this problem on first day, which was because not all packages were available for download. I was too quick for magento smile
It is now working fine via Magento Connect and no errors so far.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top