Magento Forum

   
Products not appearing at all after import
 
royb2012
Jr. Member
 
Total Posts:  3
Joined:  2011-12-03
 

I’ve been experimenting with the product import and it works around 20% of the time for me… After exporting 1 product and using it as a template I then tried to import 5 products as a test as follows:

1) Select System>Import
2) Import behaviour - “Replace Existing Complex Data”
3) Select my saved csv file
4) Magento reported no problems
5) Import
6) Reindex Data
7) Refresh Cache

8) Nothing.

Nothing appears in the backend or frontend. I can’t for the life of me figure out why? It’s like Magento just lied to me and told me it has imported the products when it simply hasn’t! I did another export to see if the products I just “imported” would be on the csv and there was nothing. Am I missing something? I’ve read many other posts and I thought I was doing everything right?

I use Magento 1.5.1.0

Is there any way I can attach the product list for someone to see? It won’t let me attach .csv to the forum.

Thanks in advance for any help,

Roy

 
Magento Community Magento Community
Magento Community
Magento Community
 
sebastianshmidt
Jr. Member
 
Total Posts:  7
Joined:  2012-01-09
 

It is one of the best and the most popular solutions to do it. check the following:
1. Ensure you have writable permissions on this folder. Change permissions to 777 recursively. You can do it using SSH via this command (execute it in Magento directory):
> chmod -R 777 media/
2 Change ownership of the /media/ folder:
> chown -R {username}:{username} media/
3: Magento cannot resize images due low PHP memory limit. Magento resize images using GD library, however if there is no sufficient amount of memory for such operation Magento will return a placeholder image. Solution: Increase your memory limit. You should open your .htaccess file and find this string:
php_value memory_limit 256M
Make sure that this value is at least 256M, 512M is better.
4: Wrong attribute scope for small_image, thumbnail, base_image. Sometimes Magento processes images incorrectly, if they have scope=Store View (especially in case of multi-store installation).
Oopen your Magento admin panel -> Catalog -> Attributes -> Manage attributes. After this you should find image, small_image & thumbnail attributes. Make sure that all these attributes have scope = Global.

Maybe the problem is somewhere here, but you can also check this service- File2Cart ( http://www.file2cart.com )-this seems to claim to be able to do import automatically.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top