Magento Forum

Magento (PHP4 running as CGI) install failure - no error message
 
clicktheo
Jr. Member
 
Total Posts:  4
Joined:  2008-01-11
 

Hi,

Well, after going through cPanel earlier, my host said that it had PHP 5.2.5, but in reality upon a quick phpinfo() check, it’s PHP 4.4.7. I’ve put through a ticket to have this server configured with PHP 5.2.5 again, as they had to edit the modules for me so that I could attempt a Magento installation in the first place. So, in the mean time i’m running it via CGI as your instructions said, and I have used CHMOD on the relevant files, and uploaded your file to my cgi-bin directory, and edited my .HTACCESS file. However, upon going to my directory using my web browser (/magento/install), instead of the server giving me a load of error messages, all that happens is that the page attempts to load, and it doesn’t time out. So I have no error message or anything.

Can anyone help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Daimonas
Jr. Member
 
Total Posts:  12
Joined:  2008-01-19
 

Make sure you have excute enabled on the script in cgi-bin. Also you don’t need to put /install in your path, unless you actually created a directory called that and if so you going to have more problems later on.

I would recommend deleting everything you have now and just downloading the magento-installer package and unzip with the default directory /magento and then open your browser to http://yourdomain.com/magento

For full instructions on this install, see my previous post

Apache/PHP Install using CGI

 
Magento Community Magento Community
Magento Community
Magento Community
 
clicktheo
Jr. Member
 
Total Posts:  4
Joined:  2008-01-11
 

I’ve resolved this now, but another problem. I click the continue button which links to another page after accepting the terms and conditions, but the page simply refreshes. The botton doesn’t remain grey - it goes orange and becomes enabled, but it doesn’t link to the next step.... My .htaccess is as follows:-

AddHandler application/x-httpd-php5 .php

############################################
## uncomment these lines for CGI mode

#Action php5-cgi /cgi-bin/php-cgi
#AddHandler php5-cgi .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

php_flag short_open_tag on

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

RewriteBase /sales/

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php

</IfModule>

Order allow,deny
Allow from all

 
Magento Community Magento Community
Magento Community
Magento Community
 
Daimonas
Jr. Member
 
Total Posts:  12
Joined:  2008-01-19
 

Do you really have magento installed under root of /sales? or do you have /sales/magento? You may need to turn off mod-rewrite if your going to install via custom directories. The next URL in the install redirects to custom url, sounds like your server is just reloading index.php

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top