Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.4.0.1 to 1.6.1 via full package update
 
Relja
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2010-10-22
 

I got to the final point where I call some page in my shop. I believe all the database updates were done, now the applyUpdates() method is being called, but the following error appears:

Fatal errorCall to undefined method Mage_Core_Helper_Data::useDbCompatibleMode() in /Applications/XAMPP/xamppfiles/htdocs/shop/app/code/core/Mage/Core/Model/Resource/Setup.php on line 308

The mentioned method is in the core_helper_data class, so it seems as the system doesn’t see the whole class.

Have no clue where to go from here, any help would be significant.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Relja
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2010-10-22
 

Anyone? Anything?

I don’t know even how to debug this one.

 
Magento Community Magento Community
Magento Community
Magento Community
 
imwy2cool
Sr. Member
 
Total Posts:  164
Joined:  2009-05-07
 

You might have already tried this, but have you disabled all local extensions under app/etc/local and change disable local extensions from false to true? it might be you have an extension that is not compatible with 1.6.1.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top