Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Magento APS on Plesk 9 asks for Encryption Key. 
 
matrixtech
Jr. Member
 
Total Posts:  2
Joined:  2008-11-24
 

Hello. I am trying to install Magento from the APS repository under Plesk 9. Everything seems fine, except that the wizard wants me to enter the Encryption Key before Plesk will install Magento. Since all documentation says that the standard Magento install creates the key, I don’t know what to do.

I’ve even tried to copy a key I found in somebody’s documentation and that didn’t work.  Attached file shows what Plesk wants.

Thanks,
Joe PV

Image Attachments
12-25-2008 3-21-19 PM.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Encryption Key is a word/phrase/any character sequence, that will be used for data encryption. You can put anything in this field.

Don’t forget to write it down, as you might need it if reinstalling Magento on existing database.

 
Magento Community Magento Community
Magento Community
Magento Community
 
matrixtech
Jr. Member
 
Total Posts:  2
Joined:  2008-11-24
 

Thanks for the reply.  I guess I did try entering my own made up key before, because this is what I got.  No matter what I put in the fields, the interface says “You have specified incorrect values”.  I have put passwords in the appropriate blanks, but when you submit and this result shows, the passwords disappear.  I guess this is the point that I am really stuck.  I just thought that it was a faulty or invalid Encryption Key before your reply.

Thanks in advance for any help here.

-Joe

Image Attachments
12-25-2008 9-36-38 PM.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Hey Joe,

This is a wild guess as my experience with the APS packages is fairly limited, but - can you leave the value for the Encryption key blank and just let it auto generate?  This is the way it works in the default install and I would suspect that this is the way it should work with the Application Packaging Standard.

If you get no browser feedback, this could be an issue with P9 (as it’s so new) - check the following file after install to see if the system generated a key for you.

app/etc/local.xml -> [key]

Merry Christmas!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Christophe Bouvier
Jr. Member
 
Total Posts:  2
Joined:  2009-01-20
 

matrixtech: do you found a solution ? I seem to have the same problem: same message but no clue (yellow line) on the error

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aussie Hemper
Jr. Member
 
Total Posts:  17
Joined:  2009-02-12
 

I left the encryption part blank and am on Plesk 9.0 as well.  however when proceeding i couldn’t go any further my browser (firefox 2.0.0.16) just went to a blank screen with this URL:

http://www.domain.com.au/magento/index.php/install/wizard/administratorPost/

I go back but nothing changes.

I can’t find any file or folder that it is referring to?

any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mike Steinke
Jr. Member
 
Total Posts:  3
Joined:  2009-03-03
 

I am also having this same problem, I am just testing the install on my server before I start offering it to customers and i can’t even get it to install :( PLEASE help us!

Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
hydra
Guru
 
Avatar
Total Posts:  378
Joined:  2008-08-26
Amsterdam
 

Hi,

I suggest you guys contact your hosting company to sort this out for you.
Might be the fastest way to resolve this, as the problem sound more like a Plesk than a Magento problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ACruz
Jr. Member
 
Total Posts:  16
Joined:  2009-03-03
 

why dont you just generate a random key with

http://www.pctools.com/guides/password/

and go ahead?

I did´t in my old APS installations…

Now I manually install the software to avoid this type of problem.

Regards,

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mike Steinke
Jr. Member
 
Total Posts:  3
Joined:  2009-03-03
 

Because I run a web hosting company and I would like my clients to be able to install it themselves from their control panel like it is supposed to work.  If I cannot get it to work in this way I will have to stop offering it which I really do not want to do because I really like the product.

Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aussie Hemper
Jr. Member
 
Total Posts:  17
Joined:  2009-02-12
 

Update:

I uninstalled and reinstalled the magento program on my Live server.  Navigated through the installation and did not enter any encryption key in this particular space.  ( some files must have been corrupted with my first upload of magento took a long time but worth it)

On the next screen I was given a magento generated one to copy and keep.

I have mine saved for later!

I am running on Plesk 9.0
Magento 1.2.1
FTP-filezilla

hope this helps save your hair!

PS I am using WAMP for my development machine and have installed magento onto this without a hitch!

 
Magento Community Magento Community
Magento Community
Magento Community
 
nemrag
Jr. Member
 
Total Posts:  1
Joined:  2009-03-18
 

Hi all,

Im having this problem to, i have reinstalled, and it still wont let me get past this page.

driving me maddddd! cheese

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mike Steinke
Jr. Member
 
Total Posts:  3
Joined:  2009-03-03
 

It would seem that no one is going to come to your aid here.  It’s a shame really, I am removing it from my systems because of this.

Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
adedip
Jr. Member
 
Total Posts:  1
Joined:  2009-03-18
 

I’ve used ACruz suggestion...generating encryption key with the password generator he linked and it works!

But I have to say that Plesk’s installations suck...I suggest to install by yourself wink

cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
keewong
Jr. Member
 
Total Posts:  4
Joined:  2008-09-22
 

I’m on Plesk 8.6, and I get this problem with the Encryption key as well.
If I leave it blank, it tells me I have input the incorrect value.
And if I type in some generic term, it says the same thing.
And when I put in the encryption code I recieved from a previous install, it also says the same thing..

So I’ve resorted to just uploading it the old fashion way - and hopefully that works..

Ugg, installing this on a media temple DV server has been the bigger pain in the rear.. I hope it’s worth all the effort..

 
Magento Community Magento Community
Magento Community
Magento Community
 
eomannem
Jr. Member
 
Total Posts:  1
Joined:  2008-09-22
 

You have to search sth. like this path on your plesk-server

/usr/local/psa/var/cgitory/magento-1.3.0-1/APP-META.xml

edit the xml-File (actual line 466) to e.g.:

installation-only="false" min-length="0"

play around what will fit your needs

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2