Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Katalog Preisregeln und Rabatte verschwinden immer wieder
 
jiwersen
Jr. Member
 
Total Posts:  30
Joined:  2011-09-25
 

Hallo an alle,

ich habe da ein Problem mit dem Festlegen von Rabattaktionen.
D.h. das Festlegen funktioniert eigentlich wunderbar, jedoch kommt es in unregelmäßigen Zeitabständen (ca. 1-4 Tage) vor, dass diese nicht mehr aktiv sind.

Im Backend unter „Verkaufsförderung“ steht zwar alles unverändert auf aktiv, jedoch sind die Preise im Shop plötzlich wieder im Originalzustand (ohne Rabatt).
Ein einfacher Klick auf „Speichern und anwenden“ aktiviert den eingestellten Rabatt dann sofort wieder,… bis zum nächsten Auftreten dieses Fehlers.

Ich habe bei der Suche nach einer Lösung für das Problem schon mehrere Themen in Foren gefunden, die sich mit dem gleichen oder zumindest ähnlichen Problemstellungen auseinandersetzten. Leider habe ich bisher keine brauchbare Lösung gefunden.

Wir lassen über einen externen Anbieter einen cronjob alle 15 Minuten ausführen, bei dem die Datei „cron.php“ ausgeführt wird.
Dies hat das Problem aber nicht behoben.

Hat jemand eine Idee oder Lösungsansatz wie man diesen Fehler beheben kann?
Eventuell eine Modifizierung der cron.php, damit diese auch meine Rabatte neu setzt oder ähnliches?

Vielen Dank im Voraus

PS: Magento in der Version 1.4.1.1 mit Market Ready Germany wird verwendet

 
Magento Community Magento Community
Magento Community
Magento Community
 
cocolade
Jr. Member
 
Total Posts:  3
Joined:  2011-06-21
 

Hallo,

ich habe genau das selbe Problem,
in meinem Shop stellt sich die Katalog-Preisregel immer wieder von allein zurück.
Im Backend wird alles normal (also Status: aktiv) angezeigt.
Im Frontend steht der Sonderpeis nur in der Ãœbersicht, sobald man auf eine Artikelseite bzw. in den Warenkorb guckt steht der alte Preis da.

Wenn ich auf Speichern und Anwenden klicke stimmt alles wieder.

Ich kann nicht nachvollziehen was diesen Fehler auslöst.

Magento Version 1.6.1.0 deutsch

Vielen lieben Dank für jede Idee oder Lösung,
Corinna

 
Magento Community Magento Community
Magento Community
Magento Community
 
Reini
Jr. Member
 
Total Posts:  17
Joined:  2010-05-04
 

Das Problem habe ich leider auch.

Mit einer früheren Version hat das tadellos funktioniert, jetzt gehts leider nicht mehr.

 
Magento Community Magento Community
Magento Community
Magento Community
 
blau16
Member
 
Total Posts:  31
Joined:  2011-12-12
 

hatte dasselbe Prob.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Reini
Jr. Member
 
Total Posts:  17
Joined:  2010-05-04
 
blau16 - 20 December 2011 04:14 AM

hatte dasselbe Prob.

Und wie hast du es gelöst?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Oliv
Jr. Member
 
Total Posts:  4
Joined:  2011-10-19
 

Ich häng mich hier mal ein. Ich habe das gleiche Problem. GIbts Lösungen?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top