Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Markup Validation Service, Character Encoding error
 
Etasker
Member
 
Total Posts:  54
Joined:  2008-07-17
Denmark
 

I’m running Magento in Denmark, in danish I’ve run into a problem the site can not pass http://validator.w3.org validation test.

I get the following error:

Sorry, I am unable to validate this document because on line 422 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.

The error was: utf8 “\xE5” does not map to Unicode

I played around with the charset coding, nothing works, then i view source in my browser and copied it into a new html file, then i could validate it, just fine.

But the source code is completely the same. So I think it have to be SOMETHING behind the scenes, some file maybe, which is not saved correct in the right coding of something.

I also tried adding

AddDefaultCharset UTF-8
to the .htaccess.

The big problem is, that i am not sure how the searchengines will react, if the character encoding is wrong, maybe it will index it wrong.
The website looks just fine in the browser e-tasker.dk but when I test it in any spider view e. g. http://www.premierdirectory.org/spider-view.html it makes funny characters!

Really hope anybody can help, this is really give grey hair.
Played a lot with it can not get it right.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top