Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Incorrect Chart Data in 1.6.1.0
 
a1anm
Guru
 
Total Posts:  318
Joined:  2009-10-08
 

Ever since upgrading to 1.6.1.0 the charts in the dashboard are not reporting correct results.  For example if I made 500 sales last month the chart will only show about 300.

If I run an actual sales report the correct data is getting returned so it only appears to be the charts which are incorrect.  This was fine before the upgrade.

Anyone know why sales are getting left off from the charts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
helaku
Sr. Member
 
Avatar
Total Posts:  108
Joined:  2009-12-01
 

Hello.
The chart on its own and the Total Revenue display the data only for completed orders. The other data is displayed for all orders including canceled orders too.

 
Magento Community Magento Community
Magento Community
Magento Community
 
a1anm
Guru
 
Total Posts:  318
Joined:  2009-10-08
 

Even when taking this in to consideration my dashboard data is way out and missing lots of completed orders.  Prior to the upgrade it was fine.

I have tried refreshing lifetime stats.

The other strange thing is that the YTD date range is reporting different data to 2YTD.  For example YTD for September shows 100 whereas 2YTD shows 150 (none of which are correct).

Any other suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
a1anm
Guru
 
Total Posts:  318
Joined:  2009-10-08
 

I now know why the data appears to be incorrect.  The labels on the chart are incorrect and recent data is getting displayed.  If you look at the attached screenshot you can see that the chart is showing Junes figures but labeling it as September.  I am therefore not seeing any data from the last 3 months.

Any ideas why it is displaying this incorrectly?

Image Attachments
Dashboard  Magento Admin - Mozilla Firefox_2011-11-22_14-16-17.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
psmindia
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2008-09-17
jaipur
 

i just working on magento latest version 1.6.1.0 but its dashboard chart working.. i search other several threads, but solution not working

 
Magento Community Magento Community
Magento Community
Magento Community
 
HPVD
Jr. Member
 
Total Posts:  10
Joined:  2008-12-22
 

same problem here. Only very few of new orders are displayed.
Before the update to 1.6.1 (from 1.5.) everything was fine with the dashboard.

Has anybody found a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
freshwebs
Sr. Member
 
Total Posts:  153
Joined:  2008-05-27
Leicestershire, UK
 

Having the same issue.
Using Magento 1.6.1.0
I’m also seeing no data what so ever on the dashboard - no sales are being shown, even those that have been shipped.

Anyone got suggestions?

Thanks,
Eddie

 
Magento Community Magento Community
Magento Community
Magento Community
 
psmindia
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2008-09-17
jaipur
 

Having the same issue.
Using Magento 1.6.1.0
I’m also seeing no data what so ever on the dashboard - no sales are being shown, even those that have been shipped.

Anyone got suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jerbourg
Jr. Member
 
Total Posts:  10
Joined:  2008-09-18
 

Me too - and my sales report is (nearly) empty.  It has recoded some sales though.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Hilly
Jr. Member
 
Total Posts:  14
Joined:  2010-08-22
 

Same problem here. Incorrect charting after upgrade to 1.6.1.0?

 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilC
Jr. Member
 
Total Posts:  7
Joined:  2010-01-28
 

Just upgraded to 1.6.1.0 and getting same effects. The reports are correct but chart data is 2 months behind - ie figures showing for dec 2011 are those from oct 2011.

Anybody any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
weatherfront
Jr. Member
 
Total Posts:  30
Joined:  2009-10-07
 

Me too ;=(

Just realised that my update from 1.4.01 via 3 steps to 1.6.1 and now my Dashboard Lifetime & Average are wrong.

Also have some names missing from Last 5.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jonmck
Sr. Member
 
Total Posts:  234
Joined:  2009-02-02
Birmingham, AL
 

Did anyone ever figure this out?  Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
a1anm
Guru
 
Total Posts:  318
Joined:  2009-10-08
 

Jus checked on 1.7.0.0 and the problem still exists.  Any fixes?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Greg Demetrick
Member
 
Avatar
Total Posts:  64
Joined:  2009-03-31
Burlington, VT
 

I think the issue is that Magento changed the criteria it uses to generate these reports. This is what I got from support when I asked them about the problem.

Orders will only be reflected on the dashboard chart if they have been invoiced.

In addition, I see that you have custom order statuses. The only order status that will be counted in the reports, without customization, will be Processing, Pending, Cancelled, and Closed. All of your orders have using a custom status, which is why they are not being counted in the report.

Prior to 1.6 I believe that the Dashboard reflected orders in a Processing state and that state was not specific to a custom label. They also claim that you should be able to customize the reports to pull in your custom order statuses and correct this reporting. I will be looking into that in the next week or so. If I come across an easy solution I will post it here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
a1anm
Guru
 
Total Posts:  318
Joined:  2009-10-08
 
Greg Demetrick - 26 July 2012 05:12 AM

I think the issue is that Magento changed the criteria it uses to generate these reports. This is what I got from support when I asked them about the problem.

Orders will only be reflected on the dashboard chart if they have been invoiced.

In addition, I see that you have custom order statuses. The only order status that will be counted in the reports, without customization, will be Processing, Pending, Cancelled, and Closed. All of your orders have using a custom status, which is why they are not being counted in the report.

Prior to 1.6 I believe that the Dashboard reflected orders in a Processing state and that state was not specific to a custom label. They also claim that you should be able to customize the reports to pull in your custom order statuses and correct this reporting. I will be looking into that in the next week or so. If I come across an easy solution I will post it here.

I’m not sure if this is the problem (for us anyway).  All of our orders are getting pulled in.  It’s just that they are all one month behind.

We don’t have custom statuses and all orders are automatically invoiced.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2