Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

My 1.6.1 upgrade from 1.4.2 (summary of what solved my problems…)
 
bacci paintball
Jr. Member
 
Total Posts:  16
Joined:  2009-05-01
 

I just want to say thanks to all the magento users who post their fixes on these forums!  Hopefully the following list of my upgrade steps and references will help someone.  Please feel free to criticize anything I did wrong (probably many things) so if I did something really bad others don\\\’t make the same mistake. My store isn\\\’t live yet so no orders but I do have 5100 or so items and 900 categories.

I upgraded my local testing MAMP server from 1.4.2 to 1.6.0 and then the next day 1.6.1 came out.  I did the 1.6.0 mamp upgrade with minimal problems (the usual amount I was expecting) but my close to identical online testing site was more difficult since I upgraded from 1.4.2 to 1.6.1.

I first tried Magento Connect which resulted in tons of problems.  Then I tried upgrading through ssh with the suggestions by John in the second post of this thread:
http://www.magentocommerce.com/boards/viewthread/242215/

These steps went find then I did a ssh reindex and got this problem:
SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘website_date’ in ‘field list’
So I found this thread:
http://www.magentocommerce.com/boards/viewthread/246359/ with a suggestion by ceefour to run a mysql query.
I ran that and then reindexed and didn\\\’t get any errors. 
Next I tried accessing my homepage through my browser and after waiting and waiting I got a timeout.

With some tips from the following page I edited my .htaccess file:
http://duntuk.com/magento-upgrade-15
I bumped my php memory and time outs to:
php_value memory_limit 1024M
php_value max_execution_time 45000

I kept getting a 408 timeout and after refresh after refresh i started running to many of the same problems other 1.6.1 users were posting.  Missing mysql tables or tables with the wrong names or not being able to rename.

I found suggestions (on this website: http://www.expertmagentodevelopers.com/blog/how-to-upgrade-from-magento-1-5-1-to-magento-1-6-0/ ) of temporarily editing the /app/etc/config.xml file and changing the initStatements (only while updating) from

<initStatements>SET NAMES utf8</initStatements>
to
<initStatements>SET NAMES utf8; SET FOREIGN_KEY_CHECKS=0;
SET UNIQUE_CHECKS=0;</initStatements>

Next deleted my mysql database and reuploaded.  I did not revert to my 1.4.2 backup and start over.  I just reuploaded the 1.4.2 database. 
Then I started over by running the database update from the commando line.  Tried accessing the homepage and got the 408 timeout so I ran it again through the commando line (my understanding is that this means the database need longer or more cycles to update?).
Eventually I ran into

Column \\\"date\\\" does not exists on table \\\"catalog_product_index_website\\\"

Searching for the same problem I found a post on here by karnakos in the following thread:
http://www.magentocommerce.com/boards/viewthread/242215/P60/#

Karnakos\\\’ tip (which is quoted below since it so long) helped me realize that my installation had not carried over the sql upgrade files in the following folder:
app/code/core/Mage/Catalog/sql/catalog_setup/
Once I filled the files into that folder I used his tip of commenting out the lines 4169-4177 of the following file: app/code/core/Mage/Catalog/sql/catalog_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php

Next I tried visiting my homepage and my favi icon showed up in my address bar so I took this as a promising sign even though I once again received a 408 timeout error.  After probably 10 more refreshes/ssh database upgrade commands and when I was just about to delete the database and start over (literally on my host\\\’s cpanel about to delete the database and re upload) I noticed that my refreshed tab showed my welcome message!

I just changed my app/ect/config <initStatements> statement back and did a reindex and 1.6.1 seems to be running alright?
I also did delete my var/session and var/cache folders a few times throughout this process as well but who knows when?

Everything seems to be running alright but the main problem I have noticed is that the mysql database backups jumped from 3.5 megs to 26 megs.  I will have to be much more dilligent about cleaning up my cron jobs backups now.  In my cpanel my database is actually showing it\\\’s size as 20 megs smaller than my 1.4.2 database.
1.4.2 = 119.79 MB
1.6.1 = 99.19 MB

I think my next step will be running the database repair tool and see what types of errors it displays?
Thanks to all the magento users who post their fixs on these forums!
-Dan

\\\"karnakoss\\\" -

Alright, I\\\’ve been able to go through this update solving a lot of errors, here is a little how-to :

- first I\\\’ve got to say the website was a 1.4.X Magento version
- so I first updated to 1.5 downloading the 1.5 files and installing my old database on it (you can then upload your design and media folders to get your theme, extensions etc...)
- then I used the Brent\\\’s tuto : http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/magento_1.5_to_1.6_upgrade
- at this point, you can get a \\\’Mage registry key \\\"_resource_helper/core\\\" already exists\\\’ error so you need to delete cache and session files again
- here came the errors : first ones were the similar errors as the ones described there : http://www.expertmagentodevelopers.com/blog/how-to-upgrade-from-magento-1-5-1-to-magento-1-6-0/ so I modified my app/etc/config.xml file as recommended and I get rid of them.
- then I faced this error : Column \\\"date\\\" does not exists on table \\\"catalog_product_index_website\\\". Checking my database, I noticed that they were no date column but a website_date column instead. So I checked the code in the php upgrade file and it seems that this file wants to change the name of the \\\"date\\\" column into \\\"website_date\\\". Here I don\\\’t know if it\\\’s because I tried to access both backend and frontend at the same time after my upgrade (so the file has been called two times) but as I told you my column had already been renamed.
- So what I\\\’ve done is commenting the lines which rename the column in this file and I get rid of this error. (the file path is written in the error report, it\\\’s app/code/core/Mage/Catalog/sql/catalog_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php lines 4169 to 4177)
- Unfortunately other similar errors came and I had to make similar modifications (commenting renam column lines) in the following files : app/code/core/Mage/Sales/sql/sales_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php (lines 6621 to 6699) and app/code/core/Mage/Weee/sql/weee_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php (lines 412 to 458). So here I think you could probably face similar errors with different files than mine, I think there are much more files that try to rename columns so don\\\’t be surprised if you\\\’ve got different files or different error message, basically if you face a error \\\” column_name doesn\\\’t exist in table_name\\\”, first check your database to be sure it doesn\\\’t exist and then check the php file and modify the code.
- And I finally accessed to my store everything works fine.

I hope it will help you all, it was much more complicated than the previous updates (a fix from Magento team would be really appreciated for non programming people).

Edit: Just ran the magento database repair tool with a clean 1.6.1 database for reference and I only got three errors with a result of repair successful.
Add missing index(es) “FK_CORE_URL_REWRITE_PRODUCT_ID_CATALOG_CATEGORY_ENTITY_ENTITY_ID” to table “core_url_rewrite”
Add missing foreign key(s) “FK_CAT_PRD_FLAT_1_ENTT_ID_CAT_PRD_ENTT_ENTT_ID” to table “catalog_product_flat_1”
Add missing foreign key(s) “FK_CORE_URL_REWRITE_PRODUCT_ID_CATALOG_CATEGORY_ENTITY_ENTITY_ID” to table “core_url_rewrite”

I am getting a 408 timeout when I try to reindex through admin but I can run the ssh command to reindex.
-Dan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Enthusiast
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

Great post, thank you for sharing.

I want to share some other troubleshoot fixes from our blog:
http://turnkeye.com/blog/magento-upgrade-from-1-4-version-to-magento-1-5-magento-1-6/

Troubleshooting

1 – Magento upgrade script error:

upgrade-all: Please check for sufficient write file permissions.
Error: upgrade-all: Your Magento folder does not have sufficient write permissions, which downloader requires.

Execute this command to correct the error:

chmod -R 777 Upgrade

2 – Magento upgrade script error:

upgrade-all: Invalid stability in compareStabilities argument.

Execute these commands, it will fix the issue:

./mage channel-add connect20.magentocommerce.com/community
./mage channel-add connect20.magentocommerce.com/core
./mage sync

3 – Server error:

“Internal Server Error” instead of Magento storefront page or administration zone pages.

Most likely issue is connected with wrong permissions.

Fix this issue using these recursive commands:

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;

4 – Magento error: Different errors in Magento database.

Re-index your database in Magento administration panel and clear Magento cache.

5 – Magento error:

“Invalid mode for clean() method”.

Clear Zend cache (all files, including “Backend” folder) in [magento_folder]/app/code/core/Zend/Cache/

6 – Magento error:

“Call to a member function toHtml() on a non-object in …/Layout.php”.

Open [magento_folder]/app/design/frontend/default/[your_theme]/layout/page.xml and replace this line of the code:

<block type=”core/profiler” output=”toHtml”/>

With:

<block type=”core/profiler” output=”toHtml” name=”core_profiler”/>

7 – Magento error:

“Maximum key size must be smaller 32″.

Clear Magento cache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
imwy2cool
Sr. Member
 
Total Posts:  164
Joined:  2009-05-07
 

I posted a solution for upgrading that might help anyone else experiencing upgrade issues with 1.6.1 . . . and probably other Magento versions: http://www.magentocommerce.com/boards/viewthread/268899/.

I didn’t have to change permissions or any of that other stuff, and I think it would work for SSH database upgrades as well.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top