Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Weird Chars and Cannot redeclare class Mage_Connect_Command_Install
 
cblanquera
Jr. Member
 
Total Posts:  2
Joined:  2011-11-16
 

After I login to Magento connect from my admin I get this back. This is a vanilla install of Magento.

Mac OS X 2��ATTRo���-�-com.apple.quarantineq/0000;4e794ae7;Firefox;|org.mozilla.firefoxMac OS X 2��ATTRo���-�-com.apple.quarantineq/0000;4e794ae7;Firefox;|org.mozilla.firefoxMac OS X 2��ATTRo���-�-com.apple.quarantineq/0000;4e794ae7;Firefox;|org.mozilla.firefoxMac OS X 2��ATTRo���-�-com.apple.quarantineq/0000;4e794ae7;Firefox;|org.mozilla.firefoxMac OS X 2��ATTRo���-�-com.apple.quarantineq/0000;4e794ae7;Firefox;|org.mozilla.firefoxMac OS X 2��ATTRo���-�-com.apple.quarantineq/0000;4e794ae7;Firefox;|org.mozilla.firefox
Fatal error: Cannot redeclare class Mage_Connect_Command_Install in /home/webolutionary/public/dandm.webolutionaries.com/repo/downloader/lib/Mage/Connect/Command/Install.php on line 542

I ran the Magento Clean up script, checked my permissions cleared my cache and still a no go. I spent 2 hours trying to search for someone in my case with no luck. This is Magento CE1.6.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
Festen
Jr. Member
 
Total Posts:  5
Joined:  2011-10-22
 

same here magento community 1.6.1.0 anyone any tips

 
Magento Community Magento Community
Magento Community
Magento Community
 
Festen
Jr. Member
 
Total Posts:  5
Joined:  2011-10-22
 

Any of the Magento experts have to say anything about this issue. Google does not seem to be my best friend on this issue, since the only topic I can find about this issue is this one.

The problem really is a showstopper for me, if I cannot figure out what is going wrong here, I think I do not stand a chance in setting up my very own production store.

So here my desperate call for help : HELLUP

 
Magento Community Magento Community
Magento Community
Magento Community
 
ostindrais
Jr. Member
 
Total Posts:  1
Joined:  2011-12-02
 

I was able to find the solution to this problem.

Assuming you’re able to SSH into your server, do the following:

1. cd [Magento install folder]/downloader/lib/Mage/Connect/Command
which in your case would be
cd /home/webolutionary/public/dandm.webolutionaries.com/repo/downloader/lib/Mage/Connect/Command

2. As a stop-gap, check to make sure the problem files do exist by running this command:
ls ._*
You should see a list of files like this:
._Channels_Header.php ._Channels.php ._Config_Header.php ._Config.php ._Install_Header.php ._Install.php ._Package_Header.php ._Package.php ._Registry_Header.php ._Registry.php ._Remote_Header.php

These files are duplicates which have the strange characters in them. If you run “grep ‘com.apple.quarantine’ ._*” (which searches the file contents for the quoted string), you will probably see these files listed.

3. Delete these bad files:
rm ._*

4. Logout as you’re done. You should be able to login to Magento Connect.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top