Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

After upgrade from 1.4 to 1.6, Shipping method doesn’t display UPS
 
nithin_ank
Jr. Member
 
Total Posts:  10
Joined:  2011-09-28
 

Hi

After I ugraded from 1.4 to 1.6 my shipping method doesn’t display UPS shipping method but flat rate and free shipping are shown..

UPS is enabled and access key user id and password are given, but it doesn’t display UPS method alone

Any help :-( ??? rolleyes

when I enabled the “Show Method if Not Applicable”

it displays

This shipping method is currently unavailable. If you would like to ship using this shipping method, please contact us.

Image Attachments
1_4.jpg1_6.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
nithin_ank
Jr. Member
 
Total Posts:  10
Joined:  2011-09-28
 

Hi,

I found that if I change the origin to US instead of Canada in Shipping Settings then it works fine but it gives me wrong calculations..

What is the problem with Canadian Origin ??

Any help please rolleyesrolleyes  rolleyes

 
Magento Community Magento Community
Magento Community
Magento Community
 
nithin_ank
Jr. Member
 
Total Posts:  10
Joined:  2011-09-28
 

Got the solution…

Set the base currency in currency set-up in admin->configuration as origin country’s currency in shipping settings.

eg if (Canada is the origin country in shipping settings, then set the base currency as Canadian dollar)

Thats it Ups will work correctly…

Or else if u want it to work as it is I.e.., US dollar as base currency then u have to play a little with Ups.php in (app/code/core/Mage/Usa/Model/Shipping/Carrier/Ups.php)

Find:

if (in_array($responseCurrencyCode$allowedCurrencies))
     
{
           $cost 
= (float) $cost $this->_getBaseCurrencyRate($responseCurrencyCode);

      
}

And Replace it with:

if (in_array($responseCurrencyCode$allowedCurrencies))
     
{
         
//  $cost = (float) $cost * $this->_getBaseCurrencyRate($responseCurrencyCode);
             
$cost=$cost;

      
}

Your all done...grin

Clear Cache and run

gringringringringringrin

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageClub
Guru
 
Avatar
Total Posts:  386
Joined:  2009-07-25
India
 

Do you mean, it was not showing or not working ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
timnguyen
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2009-08-05
 

Hi guys,

This issue had took me a month to solve.

It is very simple, my website uses US dollar as the currency.

And in the Currency Setup (System -> Configuration -> Currency Setup), \"Allowed Currencies\” multi-select box, I just picked only US dollar. That was my BIG mistake!

SOLUTION IS: select the country which is your origin shipping country.

Then I had an other problem: The UPS system return $0 or just your handling fee.

SOLUTION IS: configure your Currency Rates (System -> Manage Currency Rates)

Good luck!
Tim Nguyen.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top