Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
Newsletter - Envoie mais rien ne se passe
 
Gabriiiel
Guru
 
Avatar
Total Posts:  563
Joined:  2008-04-29
France - Paris
 

Exécuter la “command” in “shell” ca veut dire qu’en ligne de commandes tu tapes “which php”

Mais which php ne te dit pas OU est php sur ton serveur, pour le savoir c’est “whereis php”

Donc tu fais whereis php et ça va te retourner :

php: /usr/local/bin/php

Le chemin est donc /usr/local/bin/php

(dans cet exemple - dans mon cas)

Pour ma part chemin de cron.php > /home/_________/www/cron.php

tu remplaces ________ par le nom de ton espace sur le serveur

Après c’est super simple tu remplaces dans l’expression “/absolute/path/to/bin/php -f /absolute/path/to/magento/cron.php” les variables

Ca donne - dans mon exemple :

/usr/local/bin/php -f /home/_________/www/cron.php

Si le résultat est OK tu n’as plus qu’à faire une tache cron avec webmin, tu mets “/usr/local/bin/php -f /home/_________/www/cron.php” dans le champ commande, pour le reste ce que tu veux (description etc. c’est toi qui vois c’est pour t’y retrouver c’est tout !)

S’exécute en tant que : “root”.

Pour “Quand exécuter” tu peux faire simple en choisissant tous les jours à minuit par exemple.

“Plage de date pour exécuter” tu mets “Exécuter à n’importe quelle date”

Tu sauvegardes, tu reviens dedans, et là tu vois des nouveaux boutons en bas, tu demandes à exécuter la tache, tu vois que ça marche voilà c’est terminé.

Bon il existe un paquet de guides sur cron sur le web notamment celui d’OVH (http://guides.ovh.com/DedieCron) sinon tu as les forums OVH et Google en général, quelques minutes suffisent et même si tu n’es “pas programmeur”, il te suffit de faire des recherches et de persévérer pour se débrouiller même avec ce qui paraît obscur de prime abord !

smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Merci d’avoir pris de ton temps pour m’aider.

J’ai modifier ma tache cron: /usr/local/bin/php -f /home/xxxxxxxx/www/cron.php

Et voilà le message que j’ai quand je l’execute directement de webmin:

Sortie de la commande /usr/local/bin/php -f /home/xxxxxxxx/www/cron.php ..

PHP Warning:  mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0
<br />
<b>Parse error</b>:  syntax error, unexpected T_OBJECT_OPERATOR in <b>/home/xxxxxxxx/www/cron.php</b> on line <b>31</b><br />

Par contre, j’ai un doute sur le nom de mon espace sur le serveur (xxxxxxx), est-ce que ce message d’erreur dit si ma commande est bonne?

Merci encore.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabriiiel
Guru
 
Avatar
Total Posts:  563
Joined:  2008-04-29
France - Paris
 

#!/usr/bin/php au début de cron.php semble résoudre le problème mais je ne pense pas que ce soit approprié.

Ou sinon utiliser curl ou encore wget -q /absolute/path/to/magento/cron.php ...

En tout cas le chemin est correct dans ce que tu as mis.

Voir ce que Sebastien en pense ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Quand je mets ‘wget -q /home/xxxxxx/www/cron.php’ comme commande.

J’ai ce message d’erreur:

Sortie de la commande wget -q /home/xxxxxx/www/cron.php ..

Aucune sortie générée

Merci pour tes réponses.

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Qu’en penses-tu Seb?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Tu as bien remplacé les xxxxxx par ton chemin réel ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Oui je l’ai remplacé mais je t’avoue que j’ai quand même un doute !!!! Je suis mauvais !!!!

Où le trouver ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Car quand je vais dans FILEZILLA, il me met juste www/cron.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabriiiel
Guru
 
Avatar
Total Posts:  563
Joined:  2008-04-29
France - Paris
 

C’est normal. Via ftp tu arrives directement dans xxxxx (qui correspond au nom d’utilisateur ftp par ailleurs).

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

OK, mais comment fait-on pour connaitre le chemin réel?
Ma question doit vous paraître idiote, mais je suis débutant.

Merci.

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

C’est bon pour le chemin réel.
J’ai trouvé et je suis sûr de moi.

Quelle commande suis-je mieux de mettre:

/usr/local/bin/php -f /home/xxxxxxxx/www/cron.php

OU

wget -q /home/xxxxxx/www/cron.php

Merci.

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

J’ai remis ma tache cron: /usr/local/bin/php -f /home/xxxxxxxx/www/cron.php

Et voilà le message que j’ai quand je l’execute directement de webmin:

Sortie de la commande /usr/local/bin/php -f /home/xxxxxxxx/www/cron.php ..

PHP Warning:  mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0
<br />
<b>Parse error</b>:  syntax error, unexpected T_OBJECT_OPERATOR in <b>/home/xxxxxxxx/www/cron.php</b> on line <b>31</b><br />

A la ligne 31 du fichier cron.php, j’ai:

if (!Mage::app()->isInstalled()) {
echo “Application is not installed yet, please complete install wizard first.”;
}

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

En recherchant un peu sur le net, il semblerait que l’explication de l’erreur suivante :

syntax errorunexpected T_OBJECT_OPERATOR
viendrait du fait que tu utilises PHP4.

Que renvoie la commande suivante ?

/usr/local/bin/php -v

Peux-tu essayer aussi ça

/usr/local/bin/php5 -v
 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Voilà ce que ca donne.

Avec la commande:/usr/local/bin/php -v /home/xxxxxxx/www/cron.php

Sortie de la commande /usr/local/bin/php -v /home/xxxxxxx/www/cron.php ..

PHP Warning:  mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0
PHP 4.4.8_pre20070816-pl1-gentoo (cgi) (built: Apr 10 2008 16:25:33)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Avec la commande: /usr/local/bin/php5 -v /home/xxxxxxx/www/cron.php

Sortie de la commande /usr/local/bin/php5 -v /home/xxxxxxx/www/cron.php ..

PHP 5.2.5-pl1-gentoo (cgi) (built: Apr 10 2008 15:57:28)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

On dirait que tu sembles avoir une idée SeL. Merci c’est cool.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Ok, c’est donc ça :
/usr/local/bin/php utilise PHP4, incompatible avec Magento.
Sur ton serveur, il faut que tu utilises /usr/local/bin/php5.

La commande est donc :

/usr/local/bin/php5 /home/xxxxxxx/www/cron.php
L’option -v sert à connaître la version de PHP. Elle n’est pas nécessaire lorsque tu appelles le script cron.php.

Tu ajoutes ça dans ton crontab (cf. les posts précédents de ce fil) et tu auras la un cron qui fonctionne. Tes newsletter devraient être envoyées automatiquement à l’heure où tu l’as paramétré.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3