Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

problem with images and gallery
 
greenamit
Jr. Member
 
Total Posts:  24
Joined:  2011-10-05
 

Hi,

I’m using MAGMI 0.7.16 (latests) on 1.6.0.0.
I imported my whole catalog with related items and it’s great.
I’m having hard time with images and media_gallery.

In /media/import/1200 I have: MB1000.jpg
In /media/import/OnePager is have: MB1000.jpg (same filename as above but different image)

I want the /media/import/1200/MB1000.jpg to be set to image, small_image and thumbnail and media_gallery to be /media/import/OnePager/MB1000.jpg.

I have it set like this:
store ,image ,small_image ,thumbnail, image_label, small_image_label, thumbnail_label,media_gallery
“admin”,"1200/MB1000.jpg”,"1200/MB1000.jpg" ,1200/MB1000.jpg","LABEL A” ,"LABEL A” ,"LABEL A” ,"OnePager/MB1000.jpg::LABEL B”

What I get is:
On the frontend all images are correct with the correct label (LABEL A). However I don’t see the /media/import/OnePager/MB1000.jpg image assigned in the gallery.
On the backend I see only 1 image in the product’s page - /media/import/1200/MB1000.jpg WITH the Gallery’s label (LABEL B). The image is also excluded.

What am I doing wrong?!?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dweeves
Enthusiast
 
Total Posts:  877
Joined:  2010-06-26
FRANCE
 

Hi,

you’re victim of “name aliasing”

I explain.
The final magento image is stored in a name dependent directory structure under media/catalog

example:

source name : MB1000.jpg will be stored as media/catalog/M/B/MB1000.jpg in magento product image storage
whatever directory structure is used, using 2 times the same name, magmi will store it as the same target file.

magmi image plugin copies the source image to its final directory/name.

Since you have 2 times same file name from different source directories, magmi identifies the target image (the magento stored one) as existing, thus not modifying anything but the associated label.

This is a specific use case that i could try to adress sometime soon. in the meantime, rename your files differently and all will be imported well.

For the exclude thing, as said in the wiki entry for image attribute processor (click on documentation link of plugin) , the exclude flag policy is the following by default:

- base images : exclude set
- gallery images : exclude unset

But you can force exclude to be unset just by putting a + before image name for base images.

 
Magento Community Magento Community
Magento Community
Magento Community
 
greenamit
Jr. Member
 
Total Posts:  24
Joined:  2011-10-05
 

Perfect!

Thanks for your answer.
I renamed one of the files and now it all appear as it should be.

One more question here:
Is there a way to ignore images that are set in the CSV but do not actually exist on the file system from being added with magento’s default image placeholder?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomharding
Member
 
Avatar
Total Posts:  63
Joined:  2011-03-24
 

Hi Dweeves,

I’m having a similar issue, only a little less complicated (but still the same amount of crazy).

My import (sql import) looks like:

image, small_image, thumbnail

And all 3 values are ‘+PLSSP740PBK_main_.jpg’

I use media_gallery but for this particular product it’s blank.

For some reason or other, the thumbnail doesn’t get set.

Am I a victim of this name aliasing thing as well?

Thanks Dweeves, I’d really appreciate it if you’d help me out! I’m a big fan of Magmi!

Tom

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageClub
Guru
 
Avatar
Total Posts:  386
Joined:  2009-07-25
India
 

We have 3 images in 3 columns.

img-1.jpg in image

img-2.jpg in small_image

img-3.jpg in thumbnail

But the import is only taking small image and thumbnail , but the main image is skipped .

Why is that ?

It has happened for all the products, which we tried to import.

Let me know, how to fix this.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top