Magento Forum

review tab
 
Charles
Member
 
Avatar
Total Posts:  73
Joined:  2008-03-27
Belgium
 

I’ve started to fool around with the modern theme. What an improvement this is compared to the default theme!

One of it’s great features is the use of tabs.

One of these tabs is the reviews tab. I’d like to make sure that all the functions that are related to reviews is put inside that tab. No separate page to insert a new review. No “comment this product” hyperlink on the product view part, ...

Now, my first attempt was to modify the review.xml layout file.

I tried to modify the following block

<catalog_product_view>
         <!-- 
Mage_Tag -->
         <
reference name="product.info.tabs">
            <
action method="addTab" translate="title" module="review"><alias>review</alias><title>Review</title><block>review/product_view_list</block><template>review/product/view/list.phtml</template>
            </
action>
        </
reference>
    </
catalog_product_view>
</
layout>

to

<catalog_product_view>
         <!-- 
Mage_Tag -->
         <
reference name="product.info.tabs">
            <
action method="addTab" translate="title" module="review"><alias>review</alias><title>Review</title><block>review/view</block><template>review/view.phtml</template>
            </
action>
        </
reference>
    </
catalog_product_view>
</
layout>

(the block part has been modified)

Nothing happens!

Can anyone explain me why this is ?

Thanks,

Charles

 
Magento Community Magento Community
Magento Community
Magento Community
 
Charles
Member
 
Avatar
Total Posts:  73
Joined:  2008-03-27
Belgium
 

upping

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageParts
Guru
 
Avatar
Total Posts:  415
Joined:  2007-11-18
 

Well, I ain’t using the modern theme so I can’t really check any of thee solutions. But I can make some guesses. First off, and this shouldn’t present any problem, but the block review/view.php also sets a template in its constructor. The templates are the same though so that shouldn’t be it, but it’s worth a shot. Second off, did you clear the cache in Magento after updating the xml files? If not, there will be no effect since the config is saved in the cache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Charles
Member
 
Avatar
Total Posts:  73
Joined:  2008-03-27
Belgium
 

Clearing the cache didn’t do it.
Well, I guess I’ll go to the drawing boards and create a whole new .php/.phtml file ;-((

 
Magento Community Magento Community
Magento Community
Magento Community
 
etoile03
Jr. Member
 
Total Posts:  4
Joined:  2009-05-16
 

Were you ever to find a solution to this?  I’m looking to do the same.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top