Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Another 1.6.0.1 Error Report - I could use some help
 
snaKeSz
Jr. Member
 
Total Posts:  11
Joined:  2010-05-07
 

Mage_Eav_Exception Object
(
    
[_messages:protected] => Array
        (
        )

    
[message:protected] => Maximum length of attribute code must be less then 30 symbols
    [string
:Exception:private] => 
    
[code:protected] => 0
    [file
:protected] => /xxxx/magento/app/Mage.php
    [line
:protected] => 549
    [trace
:Exception:private] => Array
        (
            
[0] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Eav/Model/Entity/Setup.php
                    [line] 
=> 632
                    [function] 
=> exception
                    [class] 
=> Mage
                    [type] 
=> ::
                    
[args] => Array
                        (
                            
[0] => Mage_Eav
                            [1] 
=> Maximum length of attribute code must be less then 30 symbols
                        
)

                )

            
[1] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Eav/Model/Entity/Setup.php
                    [line] 
=> 659
                    [function] 
=> _validateAttributeData
                    [class] 
=> Mage_Eav_Model_Entity_Setup
                    [type] 
=> ->
                    
[args] => Array
                        (
                            
[0] => Array
                                (
                                    
[entity_type_id] => 1
                                    [attribute_code] 
=> customer_payone_credit_rating_date
                                    [backend_model] 
=> 
                                    
[backend_type] => datetime
                                    [backend_table] 
=> 
                                    
[frontend_model] => 
                                    
[frontend_input] => label
                                    [frontend_label] 
=> Payone credit rating request date
                                    [frontend_class] 
=> 
                                    
[source_model] => 
                                    
[is_required] => 0
                                    [is_user_defined] 
=> 0
                                    [default_value] 
=> 
                                    
[is_unique] => 0
                                    [note] 
=> 
                                    
[is_global] => 1
                                
)

                        )

                )

            
[2] => Array
                (
                    
[file] => /xxxx/magento/app/code/community/Mage/Payone/sql/payone_setup/mysql4-install-0.2.0.php
                    [line] 
=> 47
                    [function] 
=> addAttribute
                    [class] 
=> Mage_Eav_Model_Entity_Setup
                    [type] 
=> ->
                    
[args] => Array
                        (
                            
[0] => 1
                            [1] 
=> customer_payone_credit_rating_date
                            [2] 
=> Array
                                (
                                    
[type] => datetime
                                    [input] 
=> label
                                    [label] 
=> Payone credit rating request date
                                    [global] 
=> 1
                                    [required] 
=> 0
                                    [default] 
=> 
                                    
[position] => 100
                                
)

                        )

                )

            
[3] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Core/Model/Resource/Setup.php
                    [line] 
=> 624
                    [args] 
=> Array
                        (
                            
[0] => /xxxx/magento/app/code/community/Mage/Payone/sql/payone_setup/mysql4-install-0.2.0.php
                        
)

                    
[function] => include
                )

            
[4] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Core/Model/Resource/Setup.php
                    [line] 
=> 421
                    [function] 
=> _modifyResourceDb
                    [class] 
=> Mage_Core_Model_Resource_Setup
                    [type] 
=> ->
                    
[args] => Array
                        (
                            
[0] => install
                            [1] 
=> 
                            
[2] => 2.4.9
                        
)

                )

            
[5] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Core/Model/Resource/Setup.php
                    [line] 
=> 327
                    [function] 
=> _installResourceDb
                    [class] 
=> Mage_Core_Model_Resource_Setup
                    [type] 
=> ->
                    
[args] => Array
                        (
                            
[0] => 2.4.9
                        
)

                )

            
[6] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Core/Model/Resource/Setup.php
                    [line] 
=> 235
                    [function] 
=> applyUpdates
                    [class] 
=> Mage_Core_Model_Resource_Setup
                    [type] 
=> ->
                    
[args] => Array
                        (
                        )

                )

            
[7] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Core/Model/App.php
                    [line] 
=> 412
                    [function] 
=> applyAllUpdates
                    [class] 
=> Mage_Core_Model_Resource_Setup
                    [type] 
=> ::
                    
[args] => Array
                        (
                        )

                )

            
[8] => Array
                (
                    
[file] => /xxxx/magento/app/code/core/Mage/Core/Model/App.php
                    [line] 
=> 338
                    [function] 
=> _initModules
                    [class] 
=> Mage_Core_Model_App
                    [type] 
=> ->
                    
[args] => Array
                        (
                        )

                )

            
[9] => Array
                (
                    
[file] => /xxxx/magento/app/Mage.php
                    [line] 
=> 640
                    [function] 
=> run
                    [class] 
=> Mage_Core_Model_App
                    [type] 
=> ->
                    
[args] => Array
                        (
                            
[0] => Array
                                (
                                    
[scope_code] => 
                                    
[scope_type] => store
                                    [options] 
=> Array
                                        (
                                        )

                                )

                        )

                )

            
[10] => Array
                (
                    
[file] => /xxxx/magento/index.php
                    [line] 
=> 80
                    [function] 
=> run
                    [class] 
=> Mage
                    [type] 
=> ::
                    
[args] => Array
                        (
                            
[0] => 
                            
[1] => store
                        
)

                )

        )

    
[previous:Exception:private] => 
)

After the update i had some issues with the onepay extension included in the german_marked_ready addon, so i decided to delete the whole package. While i tried that i get some cache clear errors.

My frontend is working with the core files now.. But when i go to the backend i get that error above flashed and then redirected to my frontend.

Anyone know how to fix that? I did a lot of research but no one in public forums had an answer by now.

Best regards,
Nico

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

I think the problem is that your module added an attribute to your install and now when you go back to upgrade it can’t find it. Can you query your eav_attribute table to see if it is there?

 
Magento Community Magento Community
Magento Community
Magento Community
 
MrManners
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2011-08-16
Frankfurt am Main
 

Hi,

I also have this bug on a new install of Magento 1.6.1.0.

First thing I did after Magento install was try and install this extension.

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top