Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
magento-core/Mage_All_Latest causing problems in connect
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

Hi,

I’m running magento on php4 cgi ver. Everything works fine - just about to complete final stages before going live and hit a bit of wall with the magento connect interface.

I’m trying to install the PROTX VPS forms module and logged into the connect downloader > when trying to enter the extension key I got plenty of errors.  I noticed that I coudn’t see any loaded extensions, so after viewing some threads I executed the ‘magento-core/Mage_All_Latest’ line.  Initially it seemed to work - although it tells me the only extension I have is the Libertine open fonts project!

So now when I run the ‘magento-core/Mage_All_Latest’ I get the following errors which seems to start with a PEAR version error?

magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package “magento-core/Lib_Google_Checkout” (version >= 1.1.1, version <= 1.2, excluded versions: 1.2)
magento-core/Mage_All_Latest requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Mage_Core_Adminhtml requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.1.8)
magento-core/Interface_Adminhtml_Default requires package “magento-core/Mage_Core_Adminhtml” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Frontend_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Install_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.7, version <= 1.2, excluded versions: 1.2)
magento-core/Lib_Js_Calendar requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Downloader requires package “magento-core/Lib_Js_Prototype” (version >= 1.0.19700)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.1.3, version <= 1.1.3)
magento-core/Lib_Js_Ext requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_ZF requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Varien requires package “magento-core/Lib_ZF” (version >= 1.1.1, version <= 1.2, excluded versions: 1.2)
magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

Apologies for code dump!!

Any help would be gratefully received - I’m almost there! although getting people to pay for something is kind of crucial!

Thanks
Vinny

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Have you tried installing PEAR first?

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

hi JHLC

Yes PEAR is installed and is on the server should there be a certain version?  Does the ‘needs 1.6.2’ message above relate to a PEAR version?

Thanks
Vinny

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@ redvinny: Yes I believe the 1.6.2 refers to the version of PEAR.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

@JLHC:  I just had the hosting company upgrade pear to 1.6.2 and it’s still doing the same.

the MAGE_PEAR_HELPERS seems to come up a lot in the errors

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Have you tried installing “magento-core/Mage_Pear_Helpers”?

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

I just tried that in connect and got this error:

magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
Install Errors
No valid packages found
PEAR ERROR: install failed

cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

would I be bypassing PEAR if I used SSH?  Would the process be simpler?

How, for instance would I install a PROTX extension via SSH?

Thanks
Vinny

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Try installing the following:-

magento-core/Mage_Downloader

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

Thanks for your help but I get this:

magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
magento-core/Lib_Js_Prototype requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Downloader requires package “magento-core/Lib_Js_Prototype” (version >= 1.0.19700)
Install Errors
No valid packages found
PEAR ERROR: install failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Hmm… this seems to be a little weird as I have not faced with such an issue before.
Have you tried asking this with your hosting provider?

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

My host confirmed that the ver is 1.6.2, they have asked me if I need any specific PEAR modules to be installed?

Do you know of any that are important?

Thanks
Vinny

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

having seen some other posts and asked my hosts:  it seems that I am running in a non-suEXEC environment.  Apparently the only way to upgrade or add extensions is to use SSH.  Which I’m now trying and will report back.

see: http://www.magentocommerce.com/boards/viewthread/17955/

thanks
Vinny

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

[SOLVED]

As mentioned above - updated everything via SSH which worked - it’s slightly scary as I didn’t really know what I was doing but following some forum posts I manged to successfully initialise the PEAR connect manager and update everything - IT did mess slightly with my .HTACCESS file as I was using the cgi ver and need to uncomment the ref to the cgi file in the .htaccess file.  good job I backed up also because i lost some of my customization.  vampire  It looks like I live to fight another magento day!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Glad that you got it working now. wink
I have not faced a problem like yours as all of our servers are suPHP/suEXEC enabled.

 
Magento Community Magento Community
Magento Community
Magento Community
 
davidgrun
Sr. Member
 
Total Posts:  245
Joined:  2008-07-10
 

I´m getting 505 error after installing magento-core/Mage_All_Latest for back and frontend… can´t do anything.
Do you have an idea of what to do???
THANKS

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2