Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

CMS in top Menu issue
 
scott wolpow
Sr. Member
 
Total Posts:  81
Joined:  2008-08-26
 

By following the hard coding methop in top.phtml I can add the menu item I want. The problem is that on any CMS page, that link does not show up.
What am I missing?
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anjanesh
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-03-15
Mumbai, India
 

As long as this line

<?php echo $this->getChildHtml('topMenu'?>
is present in app\design\frontend\default\default\template\page\html\header.phtml, everything in top.phtml will be included.

How did you get to check if the current page is a CMS page or not ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Another possibility is that you forgot to choose ‘static block and product’ in the display mode when you created your categories.

 
Magento Community Magento Community
Magento Community
Magento Community
 
scott wolpow
Sr. Member
 
Total Posts:  81
Joined:  2008-08-26
 

Turns out to be an ISP cache issue, I am going to try opendns.com. Tired of this with Time/Warner. Thanks for the help though, It will come in handy elsewhere. smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top