Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 3 of 3
Magento Connect Manager - 500 Internal Server Error
 
momoya
Member
 
Total Posts:  67
Joined:  2010-04-03
 

How do I resolve the following error SoftException in Application.cpp:256: File “/home/valuebin/public_html/index.php” is writeable by group SoftException in Application.cpp:256: File “/home/valuebin/public_html/index.php” is writeable by group, referer: http://www.valuebins.com/downloader/?return=http://www.valuebins.com/index.php/admin/?

I cannot access Magento Connect Manager nor can I login to Magento Admin. I would greatly appreciate the help to resolve above error. I’d really like to get my site back up immediately without doing a fresh reinstall of Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Master-Yoda
Jr. Member
 
Total Posts:  4
Joined:  2009-02-01
 
ladle - 26 April 2011 11:32 AM

Setting index.php inside of Downloader folder to 644 worked for me.

That worked for me also. Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
circuitpoint0
Jr. Member
 
Total Posts:  1
Joined:  2012-08-09
 

Hi Magento 1.7.2. Connect Manager Internal Server Error , get 500 Internal Server Error go to downloader PERMISSION 755 &/downloader/index.php PERMISSION 755 now its working fine. .... ok

Image Attachments
cPanel File 755.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
svijay_siva
Jr. Member
 
Total Posts:  1
Joined:  2013-05-16
 

Setting file permission of index.php inside of Downloader folder to 644 worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nhartman
Jr. Member
 
Total Posts:  6
Joined:  2011-10-24
 

[Fri Jun 14 05:34:19 2013] [error] [client xxx.xxx.xxx.xxx] client denied by server configuration: /home/xxx/xxx.com/store/app/etc/local.xml
[Fri Jun 14 05
:34:19 2013] [error] [client xxx.xxx.xxx.xxx] File does not exist: /home/xxx/xxx.com/forbidden.html
[Fri Jun 14 05
:35:10 2013] [error] [client xxx.xxx.xxx.xxx] File does not exist: /home/xxx/xxx.com/internal_error.htmlrefererhttp://xxx.com/store/index.php/admin/dashboard/index/key/db81e6994c7d6ad879b002b9fadd1b68/

I cannot get into Magento Connect to save my life i even made the index.php permissions 777 and all i get back is

Internal Server Error

The server encountered an internal error 
or misconfiguration and was unable to complete your request.

Please contact the server administratorwebmaster@xxx.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionallya 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

If anyone can help it would be greatly appreciated. I feel like i\’m throwing Rocks at this and nothing is going to work..

 
Magento Community Magento Community
Magento Community
Magento Community
 
bnafzinger
Jr. Member
 
Total Posts:  1
Joined:  2013-01-31
 

Setting the Downloader folder and Downloader/index.php to 755 worked for me.

Thanks a bunch.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mitali_cyrus
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2013-05-02
 
tommix - 14 January 2009 04:59 PM

All you need to do is go to downloader folder and delete .htaccess file.

Deleting didn’t quite exactly work for me.. but replacing it from an older version of downloader/.htaccess (cuz of backup) worked. Thanks..! smilesmile cheers..!

 
Magento Community Magento Community
Magento Community
Magento Community
 
nimit8989
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2012-02-21
 

After trying all solutions only magento-cleanup.php solved my problem .

 
Magento Community Magento Community
Magento Community
Magento Community
 
nimit8989
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2012-02-21
 

Its simple.
Put your magento-cleanup.php file generate it from url.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kiran046
Jr. Member
 
Total Posts:  12
Joined:  2012-06-20
 
mitali_cyrus - 13 August 2013 01:58 AM

tommix - 14 January 2009 04:59 PM
All you need to do is go to downloader folder and delete .htaccess file.

Deleting didn’t quite exactly work for me.. but replacing it from an older version of downloader/.htaccess (cuz of backup) worked. Thanks..! smilesmile cheers..!

changing the downloder folder and index.php in downloder folder to 755 works for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vibaweb
Jr. Member
 
Total Posts:  1
Joined:  2013-07-29
 

Set all folders to 0755 permissions (including the downloader folder)

Set all files to 0644 permissions

Worked for me!

 
Magento Community Magento Community
Magento Community
Magento Community
 
abibabou
Jr. Member
 
Total Posts:  3
Joined:  2010-10-26
 

Hi,

I read and looked around to solve my issue and still can’t get my head around it.

I am using magento 1.7.0.2 hosted on 1and1 business package. The whole site works fine, front end as well as back end, but when use System->Magento connect->Magento Connect it redirects me to the magento connect login page.

When I try to login to magento connect manager using a wrong password magento returns a “invalid user name or password” which is checking the login credentials and behaves as expected.

When I try to login with the correct credentials magento returns me a 500 error and lock the whole site for a few minutes, and when I say lock I mean the whole site is unavailable for 5 to 10 mins.

I have tried resetting all files and folder permission using “magento-cleanup.php” without any success.

I am desperate to get this working again.

Could you please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
AttilaB
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2013-04-17
 

Change the index.php permission to 644 in the downloader folder. It works 100%

 
Magento Community Magento Community
Magento Community
Magento Community
 
Axiso
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2014-05-23
 

Another solution for local or dedicated hosting : make sure the server config allows the use of the .htaccess Order directive. “AllowOverride Limit” has to be set in the server / virtualhost config. Or there will be a “.../dowloader/.htaccess: order not allowed here” in the log file.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 3 of 3